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Quick start
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If you are an experienced user of Windows programs and/or Geographic Information Sys-
tems (GIS) software, this section has a few pointers to get you started using Cadcorp Spatial
Information System (SIS). It covers: 
• installing Cadcorp SIS
• loading maps and other data 
• moving around the map base
• adding simple geometry of your own
• producing a print
It does not describe many of the advanced features of Cadcorp SIS products, details of
which can be found in the relevant chapter in the main section of the manual, such as
• the use of scale 
• editing graphical items
• using raster image and grid data
• thematic mapping 
• using databases 
• using properties and formulae
• creating shapes and other collections
• named object libraries 
• topology 
• projections
• feature tables 
• ground modelling 
• spatial analysis
The information in this chapter is concise. If you experience any difficulties, consult the
main section of the manual or the on-line help for a fuller description of the features.
If you are a new user and require more comprehensive information and a step-by-step
guide to installation, ➲Chapter 1:“Introduction”.
rp SIS V6 Getting Started QS-1
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■ Installation
1 Plug the hardware lock (dongle) into the parallel port of your computer.
2 Have your licence number ready. You can find this on the case of your Cadcorp SIS

CD-ROM.
3 UK users should set their Regional and Language Options to English (United King-

dom) before installation.
4 Put the CD-ROM in the CD-ROM drive. If this is the first time you have used it, the

installation will auto-run. Otherwise run SETUP.EXE.
5 The installation process creates a Cadcorp SIS Program group which you can access

from the Start>Programs menu on your Desktop. 

■ Starting with Cadcorp SIS for the first time
This manual describes all the commands provided by products in the Cadcorp SIS suite:
Cadcorp SIS Map Viewer, Cadcorp SIS Map Manager, Cadcorp SIS Map Editor, and Cadcorp
SIS Map Modeller. Depending on the Cadcorp SIS product you are using, some of these
commands may not be available on your system. ➲Chapter 1:“Introduction”

◆ The map window

The initial display contains a single map window. Click on the Maximise button on the
right of the Title Bar to ensure that this window expands to fill the available space. Map
windows contain map graphics and your own graphic data. 

◆ Create a project workspace

Use the File>New... command to start the Create Workspace Wizard. A workspace remem-
bers the default projection, windows, datasets, overlays, and libraries for a project. In
subsequent sessions you can just load a workspace to restore all these settings. Workspace
files have a *.sis extension.

◆ Select a co-ordinate system

Use the Map>Co-ordinate systems... command to select the desired projection. If you are
working on UK data, this is most likely to be OSGB 1936.British National Grid. To make
this projection the default for all map windows, close the map window first, before select-
ing the projection.
Cadcorp SIS uses a viewing projection for displaying the maps, and a co-ordinate system
projection for storing positions. You can choose either, and Cadcorp SIS will automatically
make the other one compatible.

◆ Load your external datasets

Most map data files are supplied in a specific format, such as Ordnance Survey NTF, Map-
Info MIF, ESRI Shape, etc. Cadcorp SIS supports the use of many data formats.
To add map data to your map window, use the Add Overlay wizard, on the Map menu.
Choose the File option. This allows you to choose any of the supported formats that are
stored as files on your PC or on a network disk drive. Each file is loaded as an overlay in the
Overlays dialog.
QS-2 Cadcorp SIS V6 Getting Started
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You can see which files have been added to your session by selecting the Map>Overlays...
command. The external data is then available for you to see, select, copy and query, but you
cannot edit it.
If you have a lot of data tiles to load, you can create an index dataset, which is one overlay
containing all map tiles of a user-defined type. Select one file from the directory that con-
tains all the geo-referenced map tiles. The wizard will prompt with the details for that
dataset, the outlines for which will then be displayed on screen. 
If you want to make copies of your external data which you can then edit, use the
Imported File option. The original data then remains unaffected on your disk.
If you wish to load a database, you have a choice of an editable Blobs dataset, a read-only
Blobs dataset, an SQL92 database, or a points database.
Data can also be downloaded from an FTP site, or via a plug-in data source.
Cadcorp SIS can read many different file types and new ones are always being added. If
you do not see the file type you want to use, check the Cadcorp web site or telephone Cad-
corp support for the latest information. ➲page 5,Where to get help

If the data is geo-referenced, Cadcorp automatically places it in its correct location in the
world. If it is not, use the Alter>Move Dataset command to position it.

■ Moving around map windows

◆ Zooming

You can zoom using:
• the multiplication key on the numeric pad (*) to zoom out
• the plus key on the numeric pad (+) to zoom in
• the wheel on an Intellimouse
• the Zoom commands on the Map menu
• the Zoom Icons on the View toolbar

◆ Panning

You can pan using:
• the map window scroll bars
• the cursor keys, and the PgUp, PgDn, Home and End keys on the numeric pad
• the Pan commands on the Map menu
• the Pan icons on the View toolbar

■ Viewing 3D data (Manager, Editor, Modeller only)
If you are using 3D datasets you can view them in three dimensions by opening a 3D win-
dow (the Window>New 3D Window command).
Cadcorp SIS V6 Getting Started QS-3
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You cannot edit data in this window, but it is dynamically linked to the map window, and
will be updated immediately with any changes made there.

◆ Panning and zooming

You can move around a 3D window using the following features. The way they operate is
controlled by the 3D move mode (selected on the 3D menu):
• 3D window scroll bars
• + and * keys
• the 3D toolbar

■ Adding your own data 

◆ Create a user dataset

You can use the Map>Add Overlay... command to create either:
• a base dataset. This is a file (*.bds) which is saved to disk and can be shared over a net-

work (in this case it can be read by many users, but edited only by one at a time).
• an internal dataset. This is not stored as a file and cannot be accessed by other users,

nor used in a different window.

◆ Make the new user dataset current

In the workspace window, you can select the Display View tab (use the Tools>Workspace
Window command to display the workspace window if it is not visible):

Use the dataset’s context menu (click the right mouse button) to make it current.

◆ Construct your data

You can use the commands on the Construct>Geometry 2D menu to create line items and
area items. 
QS-4 Cadcorp SIS V6 Getting Started
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Lines can be straight or freehand, orthogonal, drawn in free space or traced over existing
data. They can be drawn in any colour and with different styles (eg solid, dotted, dashed,
etc), their pen controlling their colour and style. 
Select pens from the Styles toolbar:

Area outlines can be curved or straight, or be composed of a mixture of curved and straight
segments. They are filled with a colour or pattern, which is defined by their brush. Select
brushes from the Styles toolbar: 

Use the commands on the Construct>Text menu to add text.
To place symbols, use the Construct>Geometry 2D>Point command. As you place
points, you can select from one of many libraries which shape (symbol) they should use.
Cadcorp SIS contains a whole range of data construction and editing features, allowing you
great scope in adding data. For instance, you can construct 3D geometry, or create a TIN or
DTM to carry out ground modelling. You can add and use attribute data, eg to produce a
thematic map with bar charts. You can produce intelligent line and area items (topology),
which have knowledge of their adjacency and connectivity to other topological items. All
these features are described in the main section of the manual.

■ Printing

◆ Printing what you see

You can use the File>Print... command to print the view in the current window to any con-
nected printer. You should pan and zoom first so that the view in the map window is the
view you want reproduced.
Cadcorp SIS V6 Getting Started QS-5
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◆ Printing using print templates

Use the File>Print Template>Wizard or Quick Wizard to select an area of the map win-
dow and print it using a print template. Print templates are like pre-formatted sheets which
can contain standard information, such as your company details, logo and title block.
The Quick Wizard allows you to select a template, place it, change the scale and define a
view rotation.
The wizard allows you to further customise the template as you use it, adding any or all of
the following:
• a title bar
• key map
• legend(s)
• scale bar
• north point
• grids
• graticules
QS-6 Cadcorp SIS V6 Getting Started
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■ About Cadcorp SIS
The Cadcorp Spatial Information System (SIS) is a suite of products that combine the capa-
bilities of Digital Mapping, Geographical Information Systems (GIS) and Computer Aided
Design (CAD). There are several products in the suite:
• Cadcorp SIS Map Viewer 
• Cadcorp SIS Map Manager 
• Cadcorp SIS Map Editor 
• Cadcorp SIS Map Modeller 
• Cadcorp SIS Control Development Modules 
• Cadcorp SIS Active Server Component 
• Cadcorp SIS Map Server 
• applications for SIS (apSIS) 
• mobile SIS (mSIS) 
Cadcorp SIS is designed specifically for the Microsoft Windows environment, and operates
with most versions of Windows, including Windows XP, Windows ME, Windows 2000,
Windows NT, Windows 98, and Windows 95.
All products read vector data in many different formats. UK users can read all Ordnance
Survey formats. All information contained in the files, such as survey date, accuracy code,
etc is retained and available to the user.
Cadcorp SIS also supports many raster formats, such as Windows BMP, RLC, JPEG, PNG,
ECW, MrSID, and TIFF. Data from other GIS, CAD, and other graphics systems can also
be read, as well as database files.
You can add your own overlays to the map base, and display and manipulate any combina-
tion of base data and your own data. Any part of a map base can be viewed and printed at
any scale irrespective of the scale of the base data. These views can be automatically super-
imposed onto print templates containing titles, date, and so on.
1
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Cadcorp SIS products can be customised using GisLink (see the Cadcorp SIS Program-
ming Reference Guide), Microsoft Visual Basic or Microsoft Visual C++, enabling tasks
to be automated and functionality to be extended.

✐ The SIS ASC and ISAPI are server applications, and therefore do not work with 
Windows 95, Windows 98, or Window ME.

On a Windows-compatible network (eg Novell or Windows NT), many users are able to
share data, viewing the same part of the map base simultaneously if they wish. Data can be
stored centrally on a network file server, or individual users can store information on their
own computer and control its availability to other users.

◆ Cadcorp SIS Map Viewer

Cadcorp SIS Map Viewer allows you to display and print all the data formats supported by 
Cadcorp SIS. There are commands for finding specific locations on the map, panning to dif-
ferent areas and zooming in to look at detail. You can use some basic measuring tools. You
can also carry out red-lining by adding text and lines, and use thematic maps. 

◆ Cadcorp SIS Map Manager

Cadcorp SIS Map Manager lets you display, add information to and print a wide range of
vector and raster format files. You can link the maps to any ODBC databases. Associated
data can be displayed in data tables and displayed as pie charts, bar charts and other
themes. 
You can add and edit your own data points, lines, polygons and text. You can query external
map data and your own data in various ways eg measure distances, lengths and areas.

◆ Cadcorp SIS Map Editor

Cadcorp SIS Map Editor extends the capabilities of Cadcorp SIS Map Manager, offering
extensive drawing functionality and editing capability, plus spatial testing and map
authoring.

◆ Cadcorp SIS Map Modeller

Cadcorp SIS Map Modeller incorporates all the features of Cadcorp SIS Map Editor. In addi-
tion you can work with 3D maps and, using OpenGL technology, you can quickly visualise
your geographical data in real-time dynamic 3D views. You can also drape raster and vector
images over 3D ground models for visual impact. Cadcorp SIS Map Modeller also provides
tools to let you build and edit your own 3D models, using DTMs, TINs, surfaces and solids.
You can also carry out Grid Analysis, which is a powerful method of exploring interactions
between different map coverages. Buffer zones and Thiessen polygons allow you to create
areas of influence.
2 Cadcorp SIS V6 Getting Started
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◆ Cadcorp SIS Control

Cadcorp also provides a 32-bit ActiveX Control (OCX) for organisations which develop
their own products and applications. The Cadcorp SIS Control can be used with a variety of
programming languages (eg Microsoft Visual Basic, Microsoft Visual C++, Borland Del-
phi), and allows you to view maps in your own applications.The Cadcorp SIS commands
are initially hidden from the user, so your application is completely user-defined.
The CDM Viewer Level incorporates the functionality of Cadcorp SIS Map Viewer.
The CDM Manager Level contains all the functionality of Cadcorp SIS Map Manager, as
well as most of the user interface.
The CDM Modeller Level incorporates most of the functionality of the Cadcorp SIS Map
Modeller product.

◆ Cadcorp SIS Active Server Component

This product provides the facility for you to write Internet GIS applications, which users
can run with ordinary Internet browsers (such as Netscape Navigator and Microsoft
Explorer). Your application can use the powerful features of Cadcorp SIS, without
end-users having to install any browser plug-ins. Cadcorp SIS Active Server Component is a
32-bit COM Server side application. The programmer can create tools that can be used in
internet browsers to perform GIS functions such as ‘Zoom In’, ‘Select a record’, ‘show the
nearest’ and so on. ➲Chapter21: “Internet products”, Cadcorp SIS Active Server Com-
ponent (ASC)

◆ Cadcorp SIS Map Server

Cadcorp SIS Map Server offers the capability to serve SWDs on the web quickly and easily.
You can use Cadcorp SIS to create the maps, and these can then be easily distributed around
an organisation and its customers. Your web server can display a map in any standard web
browser without need for plug-ins. It can also display a map window of an SWD with basic
information about the content of the file, such as the list of overlays within it and its scale.
The browser can also use basic zoom and pan commands.
 ➲Chapter21: “Internet products”, Cadcorp SIS Map Server

◆ Cadcorp apSIS

Cadcorp apSIS (applications for SIS) Software Developer Kit (SDK) is a suite of program-
mable components combining the Microsoft Component Object Model standard with
OpenGIS standards. These can be used to add GIS functionality to applications written in a
variety of programming languages, eg Microsoft Visual Basic, Microsoft Visual C++, and
so on. Using these COM objects a programmer can add graphical displays, use data projec-
tions and transformations, create, select and manipulate geometry, and carry out spatial
querying, for example. apSIS has a low-level API, and is designed to be used with cursor
datasets.
For more details refer to the Cadcorp apSIS User Guide.
Cadcorp SIS V6 Getting Started 3
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◆ Cadcorp mSIS

Cadcorp mSIS (mobile Spatial Information System) consists of two software applications:
Cadcorp mSIS Office which runs on a Windows desktop PC; and Cadcorp mSIS Mobile,
which runs on a Pocket PC.
The project administrator uses Cadcorp mSIS Office to create the project, including data
schemas, features, and attributes of the data to be captured. This information is transferred
to Cadcorp mSIS Mobile to collect the data (with an additional GPS receiver if available).
On returning to the office the data is transferred back to Cadcorp mSIS Office for viewing
and exporting data.
For more details refer to the Cadcorp mSIS User Guide.

■ Cadcorp SIS and OpenGIS
The OpenGIS Consortium (OGC) is a diverse group of people involved in many aspects of
geographic information systems, who are working towards the integration of geospatial
data and geoprocessing resources. They aim to involve the world’s developers and users of
geographic information resources towards a common goal of delivering certifiably interop-
erable products.
Cadcorp is a member of the Technical Committee of the OGC. The OGC Technical Com-
mittee produces the OpenGIS specification, which provides a common standard for GIS
software. The aim is that, by making software compliant with the OpenGIS specification,
GIS systems and data will become interoperable.

◆ Cadcorp SIS Version 6 and OpenGIS 

Cadcorp SIS can read and write geographical data in relational databases using the SQL92
table formats. These formats are documented in the OpenGIS Simple features Specifica-
tion. Cadcorp intends to submit Cadcorp SIS for client-side “OpenGIS Simple Features
Specification for SQL” conformance testing, when OGC makes such tests available. Such
conformance would mean that Cadcorp SIS will be able to read data held by any third-party
server software that conforms to this specification and uses the SQL92 table formats.
Cadcorp SIS Version 6 implements all the geometrical functionality of the OpenGIS Simple
Features Specification. This includes:
• point, line and area items
• multi-point, multi-line and multi-area items
• multi-geometry items, for mixing points, lines, and areas
• Boolean operations between all item classes
• all OpenGIS geometrical testing methods
• WKB (well-known-binary) representation of geometry
• WKT (well-known-text) representation of geometry
Cadcorp SIS Version 6 also handles many of the co-ordinate systems, geodetic datums, and
ellipsoids listed in the European Petroleum Survey Group Geodesy Parameters (see
www.epsg.org). 
For more details on the OpenGIS Simple Features Specification, see the Cadcorp SIS
on-line help, or the OpenGIS website at www.opengis.org.
4 Cadcorp SIS V6 Getting Started
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Visit the OpenGIS Implementing and Conforming Products page on the OpenGIS website
at www.opengis.org/testing/product/index.php to see which Cadcorp products implement
which OpenGIS specifications, and which Cadcorp products are certified as conformant.

■ Where to get help

◆ On-line Help

Cadcorp SIS includes comprehensive on-line help: 
1 Press F1 when you have a command selected to get help on that command. 
2 Select the Contents command from the Help menu (Help>Contents) to search for help

on any topic or command.
3 In any dialog box which has a question mark button, click on the button then click on

the part of the dialog for which you require assistance.
4 The Help>About... command displays the user name, company name and product

licence number (which are set during installation).
To use the on-line help, the file SIS.CHM must be installed. You can choose whether or not
to load the on-line help while installing.

◆ Cadcorp on the web

Visit our website for details on latest developments and for the latest drivers and releases.
Our address is www.cadcorp.com.
You can also use the Help>SIS on the web commands:
Help>SIS on the web>Cadcorp launches your web browser and connects you to the Cad-
corp site, taking you to the Home page. 
Help>SIS on the web>Download does the same, except it takes you straight to a page
containing software for you to download. (To access this area you must input the correct
user name and password.)

◆ This manual

This Getting Started guide introduces key aspects of the Cadcorp SIS product that are rele-
vant to the new user. For more information on all the topics mentioned, and many more not
covered here, refer to the Cadcorp SIS User Guide.

Product coverage
This manual can be used with all Cadcorp SIS products. Some chapters describe features
that are not available in every Cadcorp SIS product. On the first page of each chapter, a
cross (✘) by the product name indicates that the chapter may contain some information that
is not relevant for that product.

Cross-references and hyperlinks
References to other pages in the manual are indicated with an arrow. For example:
➲page7, Contacting Cadcorp. If you are reading the online (Acrobat PDF) version of this
manual, you can click on these cross-references to jump straight to the page and location. 
Cadcorp SIS V6 Getting Started 5
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◆ Cadcorp Technical Support

If you have a maintenance agreement and pay a yearly maintenance fee, you are entitled to
unlimited technical support by telephone. Call Cadcorp Technical Support and be prepared
to quote your licence number. You may be asked what version of Cadcorp SIS you are run-
ning, and other details of the program. 
To find out these details, use the Help>About command:

◆ Training

Cadcorp offers a number of different training courses which can be tailored in length and
content to suit your company’s requirements.
6 Cadcorp SIS V6 Getting Started
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◆ Contacting Cadcorp

Our contact details are:

■ Introducing Geographic Information Systems
The rest of this chapter consists of a short introduction to geographic information systems.

◆ Geographic information

Many organisations hold information that contains a reference to a real-world location or
place, such as:
• a street address
• a name of a building
• a county or administration district
• a grid reference
• Latitude and/or Longitude 
• a place name
• a country
All of these refer to a location in the physical world, and, as such, are deemed to be geo-
graphical information.
One way of representing geographical information is to present it visually – on a map. The
map acts as a visual representation of objects in the real world. For example, on a typical
map, different symbols are used to represent discrete objects. This is one form of geo-
graphic information. 
By making this information digital (by storing it in a computer) we can begin to query and
process the information more efficiently. Imagine trying to measure the length of all the
major roads in a country using a paper map. For a computer this can be a simple process.

◆ Linking data with places

We can further develop the richness of our geographic information by bringing together
data from various sources. We may have a map which shows roads, but we could improve it
by differentiating between the types of road, such as major roads and minor roads. This will
help in planning journeys, or in illustrating how well-served a new shopping complex
might be.

Computer Aided Development Corporation (Cadcorp) Ltd.

Sterling Court
Norton Road 
Stevenage
Herts SG1 2JY
UK

Tel: +44 (0)1438 747996
Fax:+44 (0)1438 747997

Email: cadcorp@cadcorp.com
Website: www.cadcorp.com
Cadcorp SIS V6 Getting Started 7

mailto:cadcorp@cadcorp.com
http://www.cadcorp.com


Chapter 1 ● Introduction www.cadcorp.com
Another example is county boundaries. It is useful to show where the boundaries are, but it
is even more useful if you can quickly find out how many people live inside the boundary,
or how many houses are available to rent in that area, or what the unemployment rate is,
and so on. 
The demographic information is linked to the physical world by the administrative bounda-
ries. These are the geographic places to which our information relates. 

◆ Attributes

This demographic information is an attribute of the location. A location can have more than
one attribute. For example, a building may have attributes such as the number of storeys, or
the number and type of people living in it, the landlord’s details and so on. All of this infor-
mation is brought together because it refers to the same geographic location.
Because we can bring data together and integrate it, we can then begin to ask questions of
the spatial information, by using a Geographic Information System, or GIS as it is more
commonly known.

◆ Geographic Information Systems

A GIS is a suite of computer technologies which, to varying degrees, allow the capture,
editing, manipulation, display, analysis, and export of geographic information.
There are many different systems and different types of user. The global GIS market is a
multi-billion dollar concern. Users of GIS (and geographic information) include Local and
Central Government, business, planners, retailers, marketing agencies, telecommunications
companies, mapping agencies, conservation groups, and many more. GIS themselves range
in functionality and complexity. Simple systems may have three or four functions which
can be as basic as displaying topographic (base mapping) data and allowing the user to
print out a map, while more sophisticated or ‘high end’ systems allow extremely complex
calculations and processes to be performed. Such processes may include locating the opti-
mal site for a new building or analysing satellite imagery.

East Downs

East Downs

Employment

Housing

Schools

Chilham

Chilham

Employment

Housing

Schools

Boughton

Boughton
Employment

Housing

Schools
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◆ Data

There are many ways of getting data into a system: you can purchase ‘off the shelf’ data or
create or obtain your own datasets. There are many vendors of digital spatial information,
and there are also many agencies that concentrate solely on converting paper or textual
records into a digital format. 
The format often depends upon the system in question. In general, GIS data is stored in one
of two formats, vector or raster.

Vector data
Vector data is a means of storing real world objects as points, lines, and polygons. For
example, a road network can be represented as lines, housing plots as areas, and accident
locations as points. There are no hard and fast rules about how a real world object can be
represented, though you should give some consideration to which is the most appropriate.
In all cases, attribute (qualitative or quantitative) information can be linked to these points,
lines, and polygons. For example, points, lines, and polygons can be used to represent an
urban area. The points represent the locations of local shops in the area, the lines represent
the road network, and the areas show the various types of land use, such as residential,
farmland, or greenbelt.

Raster data
Raster data is different to vector data in that information is stored in a regular grid. The grid
consists of regular shapes (normally squares) and each cell in the grid has a value depend-
ing on what is represented. Each cell in the grid is the same size. Raster data can include
aerial photography, satellite images, base mapping, or user defined data.
In the following diagram, a vector representation of an area is shown below a raster repre-
sentation of the same information. Notice how the point data is converted into blocks.

Vector or raster?
Raster and vector data have their strengths and weaknesses. Vector data usually requires
less storage space, but raster data can be easier to capture (by photography or scanning, for
example). The types of analytical operations that can be applied on data are also affected if
the data is raster or vector. Indeed, some systems can handle only one sort of data, vector or
raster.

raster

vector
Cadcorp SIS V6 Getting Started 9
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Data Layers
Within a GIS, regardless of whether it is a raster or vector system, data is usually segre-
gated into layers. These layers can be ‘roads’, ‘countries’, ‘county boundaries’ and so on.
Obviously they will be represented slightly differently in raster or vector formats, but, in
general, a GIS realises its potential by ‘overlaying’ each of these layers. This allows you to
concentrate on objects of interest or relevance to the analysis or study. The following illus-
tration shows three typical data layers: roads, buildings, and property lines (Ordnance
Survey GB Landline data).

By breaking data down into these layers, we can use a GIS to analyse the relationships of
objects. In many systems, it is a routine task to identify ‘how many objects are within the
area’ or ‘which is the nearest’. This kind of analysis is called a spatial query. The ability of
a system to perform such tests allows users to carry out a variety of tasks from analysing
where the best customers of a business are, to finding the most suitable place to site a radio
mast with the least visual impact on the environment.
GIS and geographic information, when coupled appropriately, offer huge savings in cost
and time in many business and analytical functions.

Databases
A GIS normally has links to Relational Databases (RDBMS) such as Oracle or Access.
These links allow data to be brought in from existing digital sources, although the data will
still need to be geo-coded - related to its physical location.
For example, a series of records in an Oracle table may have several fields including two
fields with an x and y co-ordinate pair (25 High Road, Anytown, Anycounty, 567900,
230930). These values can be used to place the record at this co-ordinate value within a ref-
erence system.

◆ GIS as a tool

GIS is a collection of tools to perform certain tasks. It is important to identify which tasks
you need. A GIS which offers ‘high end’ functionality will let you perform operations
which go beyond the simple display or printing of spatial data. A fully functional GIS pro-
vides the following facilities:
• capture and editing
• manipulation and analysis
• visualisation
• dissemination/export
10 Cadcorp SIS V6 Getting Started
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Many GIS systems offer a subset of these capabilities but very few offer all of the functions
in one application. Also, some systems concentrate on specific elements. For example, a
package may not have any editing capabilities but may be a good visualisation tool. The
following sections discuss each of the above topics in terms of what a GIS can do. 

Data capture and editing 
Data capture is a fundamental requirement of GIS. Data capture may simply be the import-
ing of data - for example, opening a file. Data capture can also include the use of peripheral
hardware such as digitisers, scanners, or links to textual or database records. GIS also lets
you create your own data from scratch, or incorporate or augment external data such as aer-
ial photographs, satellite images, points, lines, polygons, and so on. Some systems may,
however, only allow vector or raster data to be incorporated, or may at least favour one over
the other. 
Example A Planning Department would like to find out about the number of houses which
are suffering from heat loss. They decide to commission an airborne thermal image survey,
where an aircraft flies over the area in question. This data then has to be processed and cap-
tured into the GIS. This will allow the images to be fitted to the places they relate to
(geo-coding). Because this data has been captured, the survey images will relate to other
data. This will allow the Housing Department to find the highest emitters and develop a
works programme.
One step beyond data capture is data editing. Editing functions allow you to duplicate data
and/ or modify it for a given purpose. Data editing may be necessary when features in the
real world are demolished, or new features constructed. A new road may need to be added
onto a ‘Street’ layer within a GIS. Modification may be at a micro or macro scale: a small
amount of data may be altered, or a whole overlay may have to be deleted.
Example The Housing Department want to edit some of their survey data to incorporate a
more recent thermal image survey. Having found new areas of heat loss, they now want to
draw new building outlines to show the properties which still suffer from heat loss.

Data manipulation and analysis 
Once the data has been captured and brought up to date, it can be analysed. You can meas-
ure the length of a road, the size of a conservation zone, the distance between two towns,
and so on.
Manipulation can involve the selection of certain records from a dataset or layer. This can
use SQL (structured or standard query language) or can involve spatial operations. SQL
allows you to interrogate databases by using a specific generic syntax. For example:

SELECT*FROM buildings WHERE AREA < 2000
This would select all records from a layer called buildings with an area less than 2000m2.
More complex analysis would include calculating answers to problems which have many
criteria, such as finding the optimum location for a new supermarket taking into account:
• the size of the sites available, and
• the number of customers with access to transport within a given time/distance
There are obviously differences between raster and vector analyses. A raster package may
concentrate on image analysis, or a vector package may concentrate its capabilities on top-
ological or network analysis.
Cadcorp SIS V6 Getting Started 11
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Example After receiving data from the survey team, the Housing Department discovers it
has the resources to insulate only 50% of the properties which are suffering from heat loss.
However, funding is available for those properties where the residents are pensioners. The
GIS can find which are the most significant heat emitters (using GIS analysis they can
query the values from the survey). Other queries can then find out which of theses proper-
ties are inhabited by pensioners. This is a multi-criteria analysis.
Analytical GIS excel in producing informed, data-driven solutions to real-world problems.

Data visualisation
Perhaps the most impressive use of GIS is for producing visual representations of geo-spa-
tial data. Analytical calculations produce answers to problems, but the answers are often
best presented visually, using the GIS’s powerful graphic tools. These images (akin to tra-
ditional maps) can communicate complex information in a variety of ways. Remember that
these images are alternate representations of data. Many techniques can be used to portray
information to the viewer. Points can be used to show locations, symbols can be placed to
differentiate between facilities, and shading and annotation can be employed to show varia-
tions, and so on. 
The following illustration shows two ways of representing the same data. Both images
show the total population over 70 years of age for each area in Kent (1991). These tech-
niques are called graduated symbol and thematic shading. In the image on the left, the
graduated symbols change size, with larger circles indicating more people. In the image on
the right, darker shading indicates more people. From both of these images, we can imme-
diately tell where the higher concentrations of elderly people are. The second image will
probably have greater impact to people who are used to dealing with the area boundaries.

The choice of technique is important. Often, images are generated which can confuse the
viewer or intended audience. 
12 Cadcorp SIS V6 Getting Started
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Beyond 2D
Some GIS products offer advanced visualisation beyond two dimensions (2D). These range
from 3D terrain models to the output of digital movie files or ‘fly throughs’. The image
below shows 3D and 2D scenes of part of South Wales viewed in Cadcorp SIS Map Model-
ler. The upper window shows a digital elevation model (DEM) which is a movable 3D
‘landscape’, the lower window is the 2D representation of the same area.

This approach to displaying data can also be applied to non-physical data such as surfaces
of ‘pollution’ or demographic data.
Obviously, not all GIS have such advanced visualisation capabilities, but most have at least
a 2D ‘map style’ display of the underlying data. 

Dissemination and data export 
A GIS system is only as good as the information it can provide. For instance, even if the
most sophisticated analysis can be performed in a short time, it is meaningless if the
intended recipient cannot interpret the end results.
To present information, a GIS employs a variety of methods ranging from the printing out
of a map image (with scale bar, north arrow and legend) to a spreadsheet-style report of
tabular information. Many systems allow you to create a Layout, which can include charts,
maps, tables, text, and so on. When creating this output, consider its fitness for purpose.
The best outputs are those which use only the best tools, rather than all of them. 
Other methods of data dissemination include internet GIS, where a server provides GIS
images or query results over the internet through a web browser. 
Cadcorp SIS V6 Getting Started 13
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The most common way of sharing data, though, is to save data to a disk, which can be
accessed by others using the same GIS. (This is the client-server model.) Unfortunately, a
GIS will not necessarily open all formats of data. For instance, Vendor A’s GIS may open
Vendor B’s data type but not Vendor C’s. This is because some formats are proprietary, or
because a system is not designed to open other data. To counter this, many GIS products
allow data to be exported or converted into a format which can be read by other systems.
There are also many commercial packages which will translate data from one format to
another. 
Cadcorp SIS reads data in its native format on demand. This means that you do not have to
wait while the data is being converted before you can use it.

◆ Further reading

More advanced discussion can be found in the following references. If you want more help
or information, please contact Cadcorp. We offer training on all the areas discussed, and
can tailor it to your requirements.

Introductory Texts 
Exploring Geographic Information Systems  Nicholas Chrisman, 1996, John Wiley
and Sons (WIE) ISBN 0471108421 
Principles of Geographical Information Systems  Peter A. Burrough, Rachael A.
McDonnell, 1998, Clarendon Press ISBN 0198233655

Technical Introduction 
GIS: a computing perspective  M. F. Worboys, 1995, Taylor & Francis ISBN
0748400656 

Web Resources 
(UK) Association for Geographic Information  The Association for Geographic Infor-
mation (AGI) is the UK centre for geographic information. It represents the broad interests
of the geographic information community, and includes a GIS dictionary.
http://www.agi.org.uk
(UK) Ordnance Survey GB  The UK National Mapping Agency’s site includes informa-
tion on GIS data for the UK. http://www.ordsvy.gov.uk 
(US) United States Geological Survey  US Government agency, some useful guides to
GIS use. http://www.usgs.gov/,  http://info.er.usgs.gov/research/gis/title.html 
See also the Cadcorp web site.

Reference 
Geographical Information Systems  Paul A. Longley (Editor), Michael Goodchild
(Editor), David Maguire (Editor), David W. Rhind (Editor), 1999, John Wiley and Sons,
ISBN 0471321826
Fundamentals of Spatial Information Systems  Robert Laurini (Editor), Derek
Thompson (Editor) 1991, Academic Press Inc, ISBN 0124383807

Data capture and editing 
GIS Data Conversion: Strategies, Techniques, and Management  Pat Hohl (Editor),
1997, Onword Press, ISBN 1566901758
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Data manipulation and analysis 
Spatial Analysis and GIS  A.S. Fotheringham (Editor), P. Rogerson (Editor), 1994, Tay-
lor & Francis, ISBN 0748401040
GIS for Business and Service Planning  Paul Longley (Editor), Graham Clarke (Edi-
tor), 1996, John Wiley & Sons (Sd), ISBN 0470235101

Data visualisation 
Mapping: Ways of Representing the World  Daniel Dorling, David Fairbairn, 1997,
Addison Wesley Longman Higher Education, ISBN 0582289726 
How to Lie With Maps  Mark Monmonier, 1996, University of Chicago Press, ISBN
0226534219
Visualisation and GIS  D. Unwin, H. Hearnshaw (Eds), 1994, Wiley & Sons (London).
Cartography and GIS  Association for Geographic Information Paperback, 1997, Associ-
ation for Geographic Information, ISBN 1874059039
Envisioning Information Edward R. Tufte, 1990, Graphics Press

Dissemination and data export 
Geographical Information Systems and Computer Cartography  Christopher B.
Jones, 1996, Addison Wesley Publishing Company, ISBN 0582044391 
GIS Online: Information Retrieval, Mapping, and the Internet  Brandon Plewe, 1997,
Onword Press, ISBN 1566901375
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■ System Requirements
Before you install Cadcorp SIS, make sure that your computer has at least the following:
• Pentium 133 processor
• 16MB RAM (32MB or more is strongly advised)
• 500MB hard drive (40MB free disk space)
• VGA graphics/MS Windows driver
• Enhanced keyboard
• mouse (Intellimouse is supported)
• Windows XP, Windows ME, Windows 2000, Windows NT 4.0 or higher, Windows 98,

or Windows 95
This is a minimum specification. Map data is often large and requires much processing
power. Significant improvements in performance are seen with computers which have more
memory and faster processors.

◆ The hardware lock (dongle)

Each computer running Cadcorp SIS must either have a dongle connected to its parallel
port, or must be on a network which has a valid network dongle.

Network dongles can be used with NetWare, Microsoft Windows NT or DOS. See the
README.WRI file in your Cadcorp SIS  directory for additional information.
When connecting a dongle, plug it in by the end marked Computer. Please note that trying
to connect it by the other end, or trying to connect it to a serial port, may damage it.
Static electricity may harm the dongle, and you should discharge any static charge you may
have (by touching a metal desk or door frame) before handling it. If there is excessive static
build-up in your office you might consider using an anti-static spray on the carpet or an
anti-static pad in front of the computer desk.
17
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If you have a problem with the dongle, contact Cadcorp. Do not attempt to open or disman-
tle the dongle; this will invalidate your licence.
Servers must have a local dongle for the ASC and ISAPI.

◆ Licence number (Licence key)

During the installation process you must type in the unique licence number with which
your dongle is programmed to run. This is displayed on the case of your Cadcorp SIS
CD-ROM.

■ Installation
The Cadcorp SIS installation is a simple process with clear on-screen instructions. The fol-
lowing notes may help you if you need further information.
We recommend that you close any other programs that are running before you install.
During the installation if you make a wrong selection you can always go back to the previ-
ous screen. You can also exit the installation at any time. 
1 Put the CD-ROM in the CD-ROM drive. The installation auto-runs (unless you have

run it before, in which case you need to run SETUP.EXE from the CD-ROM).
You will see the installation Welcome screen:
18 Cadcorp SIS V6 Getting Started
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2 On the next screen, read the software licence agreement and accept it before
continuing.

3 Next, type your name, organisation, and the licence number for the Cadcorp SIS prod-
uct(s) you want to install. The licence number can be found on the case of the
CD-ROM. It must be typed exactly as it is shown there.
Cadcorp SIS V6 Getting Started 19
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4 Choose a suitable destination folder.

5  Select the type of installation.
20 Cadcorp SIS V6 Getting Started
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6 Finally, you can review your selections before continuing with the installation.

7 When the installation is complete, you must restart your computer.
Cadcorp SIS V6 Getting Started 21
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◆ Reinstalling and removing products

You can also run the Cadcorp SIS installer to add, update or remove options for your Cad-
corp SIS products. Run the installer again and select the options you want. 

This screen also offers a reinstallation option: this allows you to reinstall some or all of
your Cadcorp SIS products or components.

◆ Installing the Cadcorp Software Development Kit (SDK) or the Internet 
Development Kit (IDK)

When installing the Cadcorp Software Development Kit (SDK) or the Internet Develop-
ment Kit (IDK), an extra licence is needed for additional Cadcorp SIS products. Within the
Bonus directory on the Cadcorp installation disk is the Cadcorp SIS Licence Editor pro-
gram. This will allow new Cadcorp products to be licensed without reinstalling the
applications.
User notes for the Cadcorp SIS Licence Editor program are also on the Bonus directory, in
the document Cadcorp SIS Licence Editor.doc. 

■ Starting Cadcorp SIS applications
You start a Cadcorp SIS application like any other Windows program (eg from the Pro-
grams option on the Start menu, using a shortcut, or running the executable file SIS.EXE).
You can add any of the following command line options:

Option Action 

"filepath" load the named saved window definition

-country:XXX overrides the computer’s default locale to get the letter code
(eg GBR, JPN, etc) which controls country-specific features,
eg -country:GBR

-DS:server set the network dongle server name or IP address
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-DT:time in minutes set the dongle time out. After this time, the dongle will
become available for another user.

-Embedding used by other OLE applications

-Empty do not load previously loaded SWDs

-foldername load any programs from the custom directory which are con-
tained in the folder with this name

-INTERNATIONAL make all country-specific features (eg datasets, index overlay
namers) available in the user interface

-LN:licence number set the licence number

-NoCustom do not start programs listed in the Custom folder

-product run a particular Cadcorp SIS product. The options are: 
MapView

MapMan 

MapEdit 

MapModel 

eg -product:MapModel runs Cadcorp SIS Map Modeller. The
Splash screen is displayed by using the LOADER.EXE file
(see the example on the next page).

-REGMACHINE store Registry information (Preferences) by machine (that is,
under KEY_LOCAL_MACHINE) instead of by user (under
HKEY_CURRENT_USER) 

-WS:"filepath.sis" load the named workspace (*.sis file) at start up

Option Action 
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You can modify the properties of the shortcut that runs a Cadcorp SIS application, using the
Windows Properties dialog.

options
24 Cadcorp SIS V6 Getting Started
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■ Introduction
Cadcorp SIS currently reads data from over 100 dataset and database formats, and can
export data to over 40 dataset or database formats. Many databases are supported and Cad-
corp SIS can access them by using ODBC, ADO, and DAO drivers, or use direct drivers
which are provided for Excel, Lotus 123, FoxPro, Access, SQL Server, and Oracle8i/9i.
All the graphical dataset/database formats are read directly in their native format. Any com-
bination of dataset/database formats, even with different projections, can be read
concurrently and overlaid. The dataset projections are re-projected ‘on the fly’ to the
selected view projection. This means that no external translation processes are required and
data does not have to be duplicated to a number of formats. Cadcorp SIS links dynamically
with many GIS, CAD, and database formats, which provides maximum interoperability.
As well as these formats, Cadcorp SIS can link to Safe Software’s Feature Manipulation
Engine (FME), and use FME Translation to read any FME supported format.
Support for new and updated formats is always being added, and so other formats may be
supported which are not documented here. If you wish to use a dataset or database format
which is not listed, contact Cadcorp for the most up to date information, or visit our website
to review the current list at www.cadcorp.co.uk/formatlist. Download the latest plug-ins at
www.cadcorp.co.uk/plugin.

■ Checklist of supported formats
The following table lists the supported formats.

❏ Graphical dataset and database format checklist  
Format Read Edit Export 
❖ CAD and GIS file formats

AutoCAD DXF 12 - 2000 (*.dxf) ✔ ✔

AutoCAD DWG 12 - 2000 (*.dwg) ✔ ✔

Autodesk Drawing Web Format (*.dwf) ✔

ARC/INFO Export (ASCII) (*.e00) ✔
25
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ArcView Shape (*.shp) Cursor Dataset ✔ ✔

ESRI Bil Format (*.Bil, *.hdr) ✔

Bentley MicroStation design file (*.dgn) ✔

Intergraph CIT image files (*.cit) ✔

Intergraph RLE image files (*.rle) ✔

Cadcorp SIS Base Dataset file (*.bds) ✔ ✔ ✔

Cadcorp SIS Shared Dataset file (*.sds) Cursor Dataset ✔ ✔ ✔

Cadcorp SIS Export Dataset (*.sed) ✔ ✔

ER Mapper’s Algorithm (*.alg) ✔

ER Mapper’s Enhanced Compression Wavelet (*.ecw) ✔ ✔

GDS AIF (*.aif) ✔

GDS BIF (*.bif) ✔

GDS Things (*.thf) ✔

MicroGDS File (*.man) ✔

Genasys GenaMap (*.Di) Unsupported ✔

MOSS MX (*.dpf) ✔

MOSS MX (*.dpw) ✔

MapInfo (*.tab) ✔ ✔

MapInfo Interchange Format (*.mif) ✔ ✔

Sysdeco (*.tfd) ✔

Siemens SICAD (*.vc) Unsupported ✔

❖ OpenGIS specified file formats

OpenGIS Geography Markup Language 2 (*.gml and *.gz) ✔ ✔

❖ USA national data formats

US Census Bureau TIGER/Line 95 (*.bw1, *.rw1) ✔

❏ Graphical dataset and database format checklist  (Continued)
Format Read Edit Export 
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USGS DLG-3 Optional Format (ASCII) (*.opt, *.do) ✔

USGS GTOPO30 (*.hdr) ✔

USGS Digital Elevation Model (1 degree) (*.dem) ✔

Spatial Data Transfer Standard (SDTS) (*.ddf) ✔

NIMA Vector Map Level 0, Vmap0 (Edition 3) ✔

Digital Chart of the World (*.dcw) ✔

❖ GB national datasets (Ordnance Survey)

OS MasterMap Topological Polygons (*.gml and *.gz) ✔

OS MasterMap Independent Polygons (*.gml and *.gz) ✔

OSCAR Traffic Manager(*.ntf) ✔

OSCAR Network Manager (*.ntf) ✔

OSCAR Asset Manager(*.ntf) ✔

Land-Form PANORAMA DTM 1:50 000 (*.ntf) ✔

Land-Form PROFILE contours 1:10 000 (*.ntf) ✔

Land-Line 1:1250, 1:2500, 1:10 000 (*.ntf) ✔ ✔

Data-Point (*.ntf) ✔

Strategi (*.ntf) ✔

Meridian (*.ntf) ✔

BaseDataGB (*.ntf) ✔

BoundaryLine 96 - 2000 (*.ntf) ✔

Address Point (10cm resolution) (*.ntf, *.csv, or *.ap) ✔

Code Point (*.csv) ✔

LIDAR (*.dat) Unsupported ✔

OS CITF Topo 93 (*.ctf) Chargeable ✔ ✔

OS CITF Topo 96 (*.q1) Chargeable ✔ ✔

Post Office Address File (10m resolution) (*.paf) ✔

❖ Japanese national datasets

Japanese GSI (*.mem) ✔

Japanese GSI (*.rst) ✔

Additional Japanese formats are available through Informatix
(Cadcorp SIS distributor for Japan)

❖ Other national datasets

Ordnance Survey Ireland (*.ntf) ✔

❏ Graphical dataset and database format checklist  (Continued)
Format Read Edit Export 
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Ordnance Survey Northern Ireland (*.ntf) ✔

EDBS (Germany) (*.edbs) Chargeable ✔

KF-85 (Sweden)  (*.k85) ✔

❖ Hydrographic datasets

S57 Chart (*.030) ✔

S57 Catalogue (*.000) ✔

EuroNav (*.gxf) ✔ ✔

❖ Other file formats

Targa Image File (*.tga) ✔

Scalable Vector Graphics (*.svg, *.svgz) ✔

VRML (*.wrl) ✔

❖ Any format from Safe Software’s Feature Manipulation Engine (FME)

(requires an FME licence) ✔

❖ Reading and writing graphics in a database or server application

Cadcorp SIS ASCII Blob format (any database) ✔ ✔ ✔

OS MasterMap for Access2000 ✔ ✔

OS MasterMap for SQL Server ✔ ✔

OS MasterMap for Oracle9i ✔ ✔ ✔

ER Mapper’s ECW Image Web Server ✔

❖ OpenGIS Specified server formats

OpenGIS Blob Well Known Binary (WKB) (any database) ✔ ✔ ✔

OpenGIS Blob Well Known Text (WKT) (any database) ✔ ✔ ✔

OpenGIS Blob Geography Markup Language (GML) (any
database)

✔ ✔ ✔

OpenGIS SQL92 Dataset (any database) ✔ ✔ ✔

OpenGIS Web Mapping Server (raster) ✔ ✔

OpenGIS Web Feature Server (vector) ✔ ✔

OpenGIS Web Terrain Server (DEM) Unsupported ✔ ✔

❏ Graphical dataset and database format checklist  (Continued)
Format Read Edit Export 
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❖ Oracle Plug-in servers

Oracle8 Spatial Cartridge (Relational Model) ✔ ✔

Oracle8i Spatial (Object Relational Model) ✔ ✔

Oracle9i Locator (Object Relational Model) ✔ ✔ ✔

Oracle9i Spatial (Object Relational Model) ✔ ✔ ✔

Informix Spatial Plug-in Datablade Unsupported ✔

Safe Software’s Feature Manipulation Engine (FME) ✔

❖ Supported databases

Any database with a ODBC, DAO, or ADO driver ✔ ✔

Using direct database drivers ✔ ✔

Lotus 123 ✔ ✔

Excel 97, 2000 & 2002 (XP) ✔ ✔

Access 97, 2000 & 2002 (XP) ✔ ✔

SQL Server 7, 2000 ✔ ✔

FoxPro ✔ ✔

Paradox ✔ ✔

Dbase III, IV and 5 ✔ ✔

Oracle8, 9i ✔ ✔

Text files (*.html, *.htm, *.txt, *.csv, *.tab, *.asc) ✔ ✔

❖ Raster formats

ER Mapper’s Enhanced Compression Wavelet (*.ecw) ✔ ✔

LizardTech’s MrSID format (*.sid) ✔

Intergraph CIT (*.cit) ✔

ESRI BIL (Binary Interleave Format) (*.bil) ✔

GIF (*.gif) ✔ ✔

JPEG (*.jpg) ✔ ✔

JPEG Multi Level (4 levels) (*.jpg) ✔ ✔

GeoJPEG (*.jpg and *.jfw) ✔ ✔

B&W TIFF with anti-aliasing  (*.tif, *.tiff) ✔ ✔

TIFF No compression (*.tif, *.tiff) ✔ ✔

❏ Graphical dataset and database format checklist  (Continued)
Format Read Edit Export 
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TIFF Packbits (*.tif, *.tiff) ✔ ✔

TIFF Group 4 fax (*.tif, *.tiff) ✔ ✔

TIFF LZW Compression (*.tif, *.tiff) ✔ ✔

GeoTIFF (*.tif, *.tiff and *.tfw) ✔ ✔

BMP (*.bmp) ✔ ✔

BMP dithered (*.bmp) ✔ ✔

GeoBMP (*.bmp and *.bfw) ✔ ✔

PNG Bitmap 24-bit (*.png) ✔ ✔

PNG Bitmap 256-colour (*.png) ✔

PDF Portable Document Format (*.pdf) ✔

Intergraph RLE (*.rle) ✔

RLC Run Length Compression Bitmap (*.rlc) ✔

Windows MetaFile (*.wmf) ✔ ✔

Mandelbrot Compression (Fractal Sample) Unsupported ✔

❏ Graphical dataset and database format checklist  (Continued)
Format Read Edit Export 
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Notes

All the datasets listed here are accessed using the Map>Add Overlay Wizard.

 ➲Chapter 13: “Working with overlays”

Some datasets are file-based and accessed through File. Some more complex datasets or
Services are accessed through plug-ins, and Oracle9i Spatial, Ordnance Survey DNF,
OpenGIS SQL92, and Blobs are accessed through their respective options.
Binary formats are generally smaller in file size and read in faster than ASCII formats. If
you have a choice of data format, binary is better for use in Cadcorp SIS.

Chargeable These plug-ins are not part of the core software, and an additional charge
is made for their use.

FME requires purchase of Safe Software’s FME licence

Cursor Datasets Some Cadcorp SIS plug-ins are treated as cursor datasets. Only the data
queried by the user is loaded into memory, not the whole file, so cursor
datasets are memory efficient.

Blob Blob (Binary Large Object) strings provide a database-independent way
of storing items in any database. A Blob string is a string that completely
encapsulates a graphical item, ie its geometry, properties, and attributes.

Unsupported These plug-ins are not part of the Cadcorp SIS core product and will not
be supported by Cadcorp Ltd under any licence or support agreement.
This does not mean that Cadcorp Ltd will not update or modify them but
that any requests will be treated at a lower priority than fully supported
products. These can be copied from the plug-ins directory in the Bonus
folder on the Cadcorp SIS 6.0 Installation CD.
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◆ Cursor datasets

Some datasets can be read into Cadcorp SIS as a cursor dataset. This means that only a
small part of a large dataset is loaded into the system at a time, based on the screen extents.
As you navigate around the map, the data that is loaded changes to match the view. This
form of dynamic indexing is fast, and allows access to large datasets. When you select the
geometry, Cadcorp SIS queries the item selected, rather than storing all the drawn items in
memory. This is called ‘hot snapping’, and is more efficient and uses less memory than
loading the entire dataset. Hot Snapping operations with cursor datasets can be changed
with the Tools>Preferences command.

■ Geo-referencing files
Some data products (GIS, Digital Mapping and Remote Sensing software) provide data
files that are geo-referenced and can be included as overlays in the normal way, using the
Add Overlay Wizard. If the graphics in the data file have been positioned using a co-ordi-
nate system, the data appears in the correct geographical position.
Other data files, mostly created in CAD, or scanned images which have no regard to their
location in the world, may have selected a convenient local position as the origin of the
co-ordinate system for the data. In this case, Cadcorp SIS provides the ability to move the
data to its correct geographical position, rotating it as necessary, and defining the units of
measurement used. You can relocate it by selecting any item from the overlay, then using
the Alter>Move Dataset command, described below.
To display a file which is not correctly geo-referenced, it is important that you know the
geographical location of at least one point on the graphics. 
For example, if you were using the National Grid co-ordinate system projection, you must
establish the National Grid reference of a point on the graphics. (You may need to consult
the provider of the data file to obtain this information.)
The following example uses an Ordnance Survey Land-Line DXF file which is to be posi-
tioned within the National Grid.
1 Use the Imported File option in the Add Overlay Wizard to add the DXF file to the

SWD. It is a good idea to remove any other overlays (select them, then click the Delete
button), or make them invisible (click on the icon in the Workspace Window).

2 Click the OK button to return to the Map Window. Do not be surprised if you cannot
see any graphics. Remember, the DXF file is not geo-referenced, so the origin of its
co-ordinate system (0, 0) has been placed at the origin of the current map projection. In
the case of the National Grid, this is near the Isles of Scilly which lie off the south west
coast of Britain.

3 Choose the Zoom Overlay command from the DXF overlay’s local menu. This will
shift your current view to display the full extent of the chosen overlay (the DXF file).

4 Select any item in the DXF dataset by clicking on it.
5 Select the Alter>Move Dataset command.
6 For the position to move from, click on a point on the DXF graphics whose co-ordinate

position you know. 
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7 If you want to scale or rotate the dataset before placing it, press Enter to see the Trans-
formation dialog:

➲Chapter 12: “General editing techniques”
Using this you can increase the size of the file by Scaling it, you can Mirror it, or you
can Rotate it by one of its axes.

8 To place the selected point in its correct geographical location, type in its co-ordinates
(in the Position bar at the bottom of the Cadcorp SIS window), or click on existing
graphics which are at the correct location. 

9 When the DXF dataset is in the correct location, you can save it as a file using the
File>Export>To File command. Remember when doing this to make any other over-
lays invisible, otherwise you will export them with the DXF.

10 To view the exported file, use the File>Add Overlay Wizard and the File option.
11 If you save the SWD, the details of this transformation will also be saved, so that when

you next load this SWD file (using the File>Open command), the DXF dataset will be
in the correct location. It is best, though, to export the file for future use.
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■ Assembling a map base
This chapter deals with the assembly of a map base for the first time. You do not need to
know how to assemble a map base if:
• you are working on a map base which has already been defined for you by your system

administrator
• you are running an application which is based upon Cadcorp SIS and which has a cus-

tomised start-up. This could involve an initial keymap being automatically loaded, or
you may be prompted for certain information while the system starts. In this case, refer
to the documentation specific to your application, or consult your supplier.

■ Starting a new session
When starting work with Cadcorp SIS for the first time, you should carry out the following
tasks. Each of these is explained in its own section in this chapter.
1 Select the required map co-ordinate system (a co-ordinate system and a viewing

projection).
2 Create a workspace.
3 Create a new SWD file.
4 Load up the datasets you require.
5 Save the SWD file (File>Save command).
In subsequent sessions, not all these tasks are necessary.

■ Selecting the co-ordinate system
You may need to select a viewing projection and a co-ordinate system. 
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The viewing projection is the means by which the Earth’s surface is mathematically trans-
formed to appear on your screen. The viewing projection is like a map projection used to
create maps and charts on paper.
The co-ordinate system is the reference used to interpret and report spatial positions in
datasets.

◆ Notes on projections

A workspace has a default co-ordinate system (or more precisely, both a viewing projection
and a co-ordinate system). ➲page 37, Workspaces

Each SWD has a co-ordinate system which it remembers.
Each window can have a different co-ordinate system. So you can have the same SWD dis-
played in several different windows, and each SWD can be displayed using a different
co-ordinate system in each window.
If you start a Cadcorp SIS session and do not open a workspace, the default co-ordinate sys-
tem is Latitude/Longitude.OpenGIS.WGS_84. New SWDs adopt this co-ordinate system,
but you can change it.
If you open a workspace, any new files created adopt the workspace co-ordinate system,
but you can change it later.
If you open an SWD file, it uses the co-ordinate system it had when it was saved, but you
can change it later.
Each map window can use a different co-ordinate system from other windows. You can
select either a viewing projection or a co-ordinate system for the current window using the
Map>Co-ordinate systems... command. 

If you choose a viewing projection, Cadcorp SIS makes the co-ordinate system compatible
with it. If you choose a co-ordinate system, the viewing projection is made compatible.
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The following example shows some Ordnance Survey Meridian data. First it is displayed
using its standard viewing projection (OSGB 1936.British National Grid), then using a Lat-
itude/Longitude co-ordinate system:

■ Workspaces

◆ What is a workspace?

Workspaces are files with a *.sis extension. A workspace remembers a setup for a Cadcorp
SIS session. 
Workspaces contain the following information:
• the default co-ordinate system and viewing projection
• all SWD files and their associated windows
• the workspace-specific library (called (workspace)) and any linked libraries
• named tables from database windows
The workspace default co-ordinate system and viewing projection are applied to all new
SWD files created while the workspace is open. However once a map window is open, you
can define and save the co-ordinate systemco-ordinate system required.
If several people are contributing towards the same project, you might create a workspace
for that project, thus ensuring that everyone uses the same basic setup.
If individuals share a computer, each user might have their own workspace. This allows
each person to set up their own environment.
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The following diagram summarises the Cadcorp SIS program structure, the connections
between the workspace, the saved window definitions, the named object libraries, and
named tables.

ArcView *.shp

Overlay 1

object library *.nol

object library *.nol

AutoCAD *.dwg

Overlay 2

Overlay 3
OS Landline data *.ntf

Overlay 4
Aerial photography *.bmp

Overlay 1
OS Raster maps *.jpg

Overlay 2
GDS *.bif

Overlay 3
OS Landline data *.ntf

Overlay 4
Scanned document *.tiff

Overlay 5
Blobs 
(a way of storing graphics in a database

database
planning records in

Oracle

database
Civil Engineering in

Access

database
Population Data/Census

in IBM DB2

Engineering library holds pens, 
brushes, and print templates for 
engineering use

planning library holds pens, 
brushes, and print templates for 
planning use

saved window definition *.swd
All graphical data is added as 
an overlay within the SWD.

saved window definition *.swd
You can have thousands of 
overlays contained in one SWD 
and thousands of layers in each 
overlay

project workspace *.sis
The project workspace stores your preferences and 
links to the SWD (overlays of data), tables (database 
connections), and object libraries (pre-defined and 
shareable pens, brushes, print templates, and so on.

A project workspace can contain numerous SWDs 
(*.swd), object libraries (*.nol), and table connections.
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◆ Creating a workspace

Creating a workspace before starting a session
Select the File>New command, choosing Project Workspace from the file types offered.
The wizard requires you to choose a directory and file name for the new workspace (*.sis)
file.
The workspace is created and its name appears in brackets on the title bar - after the pro-
gram name and before any SWD file name.
From now on, the settings controlled by a workspace will be saved when you carry out a
File>Save Workspace or File>Close Workspace.

Creating a workspace during a session or at the end of a session
If you do not have a workspace in operation, you can use the File>Save Workspace com-
mand at any time during a session to save a workspace. The new workspace stores the
parameters in force at the time of the save.

◆ Starting with a workspace

You can have Cadcorp SIS start up with a workspace pre-loaded by using the command line
option -WS:filename.SIS. 
➲Chapter 2: “Installation”, Starting Cadcorp SIS applications

Alternatively you can open a workspace after starting Cadcorp SIS by either:
• selecting the File>Open Workspace command and the *.sis file required
• selecting File>Open, choosing Project Workspace (*.sis) from the Files of type

drop-down, and selecting the file required
When you open a workspace, its (workspace) library appears in the workspace window’s
library view, and its default projection is loaded. Opening the workspace also opens up the
SWD files that were open at the end of the previous session, with all their settings and
windows.
Use the File>Close Workspace command to end the current workspace before opening
another (for instance, when another user takes over the computer, or you start work on
another project).

◆ Saving a workspace

Use the File>Save Workspace command to save the current workspace, or, if there is no
workspace in operation, to create a new workspace with the current parameters.
Workspace files prompt to be saved if they detect changes to the library setup or the named
table setup. ➲Chapter 17: “Table windows”

Selecting the File>Close Workspace command also allows you to save the workspace
parameters.
A workspace currently in use is saved by File>Exit, and also when you open a new
workspace.
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■ SWD files (saved window definitions)
If you open an existing workspace, the SWD file(s) in use at the end of the last session will
automatically be loaded. You can also open other existing SWDs, or create new ones.
An SWD file is an assembled view of one or more datasets. It is normally a small file, con-
taining little actual data, but holding a record of the following:
• a list of all overlays in use, and their status at the time of the last save
• any overrides or filters set. Overrides control the default colours for graphics, fonts for

text, etc. Filters govern which items are displayed on screen.
• a view extent
The SWD file links to datasets by remembering their file locations. Be careful when you
move SWD files and datasets to different disks. Try to store SWD files on the same disk as
the datasets they reference.
If no workspace or SWD was specified on the command line, Cadcorp SIS automatically
creates an empty SWD called Map (with no Workspace) on start up.

◆ Creating a new SWD file

A new SWD uses the viewing projection and co-ordinate system projection of the current
workspace. If no workspace is open, the default projection Latitude/Longitude WGS 84 is
used.
Start the File>New wizard, then either:
• select Saved Window Definition from the options. The wizard requires you to choose a

directory and file name. A new SWD file is created in the chosen directory with the
name you chose, and is displayed in a map window.

• select Blank Map Document if you do not wish to create an SWD file straight away. A
map window called Map is opened, but no file is saved. If you wish, you can save the
blank document as an SWD at a later stage.

◆ Creating 3D windows and table windows

Once you have a map window open, you may go on to produce a 3D window and/or a table
window. ➲Chapter 17: “Table windows”

◆ Opening an existing SWD file

If you open a workspace, Cadcorp SIS automatically loads the SWD files which were being
used when the workspace was last saved.
To open other SWD files either:
• use the File>Open... command
• drag and drop an SWD file from the Windows Explorer into the workspace window

(display view, table view or theme view tabs)

■ Loading maps and other data files
Having started a new SWD file you are ready to display maps and other data files. You can
also load database files. 
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These files containing maps and other data are called datasets. Datasets are loaded in Cad-
corp SIS as overlays. An overlay is a view of a dataset. There is no limit to the number of
overlays which can be included, and each one can have a different projection.
New formats are always being added so if the format you wish to use is not supported con-
tact Cadcorp for the latest information, or visit our website (www.cadcorp.com).
All datasets can be loaded into the current session by drag and drop, or using the New
Overlay Wizard.

◆ Drag and drop

You can drag and drop datasets on:
• the workspace window (display view, theme view and table view tabs)
• map windows, table windows or 3D windows
If you drag a dataset using the right mouse button, you can choose whether it is inserted
(loaded as a normal overlay) or imported (an editable copy is made).

◆ Add Overlay Wizard

To run the Add Overlay Wizard, use:
• the Wizard... button in the Add Overlay area in the Overlays dialog 
• the Add Overlay... command, which is found:

• on the menu bar as Map>Add Overlay...
• on the default local menu when you right-click in the map window
• on the SWD local menu on the display view, theme view, and table view tabs in the

workspace window
Select the type of dataset you want to include.
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Backdrop
A backdrop depicts the area of the map you are working on. There are several backdrops
provided with Cadcorp SIS, and they appear as a grey-filled outline over which your map
data is displayed. 

Backdrops are named items. 
When you create a backdrop, you are creating a new internal dataset which contains a
named item. This internal dataset is normally put first in the overlays list (overlays are
drawn in the order in which they appear in the list, and a backdrop must be drawn first).
Backdrop overlays can only be made visible or invisible (so that you do not snap to them
when clicking with the mouse).
Named items are named objects, stored in libraries. 

File
Use this option to load any of your datasets (eg Ordnance Survey NTF, Address Point,
AutoCAD DXF, BDS, etc) as overlays. These files remain stored on your disk, and a link to
them is created in the SWD.
External datasets are loaded as non-editable overlays (if you want to edit such files, use the
Imported File option to load copies of them instead). However, BDS files (which contain
user data) are loaded as editable overlays.

Internal Dataset
Use this option to create a new internal dataset.
Internal datasets are user datasets which are stored within the SWD (they do not exist as
separate files). They cannot be used in other SWDs or accessed by other users. They are
often used for data of a temporary or personal nature. 
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Create New File
This option allows you to create a new shared dataset (*.sds) or base dataset file (*.bds). A
dataset is a file saved to disk in which you save the graphical data that you create. You are
required to choose a directory and file name for the new file. 
To load an existing file, use the File option (see above).

Index Dataset
An index dataset tiles together dataset files in a rectangular grid to make a continuous map
base. Any of the supported plug-in namers can be indexed. ➲page 47, Index datasets

Ordnance Survey CD-ROM (GB specific)
This option is used for loading data directly from the Ordnance Survey CD-ROM. It will
load only OS Land-Line data. To do this, insert the CD-ROM, then start up the Add Over-
lay... Wizard. Choose Ordnance Survey CD-ROM. Click on the root directory where the
data is stored and press Finish. This should load up all the OS Land-Line tiles available.
They can be either 1:1250 and/or 1:2500 scale. They will be loaded with the tile outlines
and the labels on. These can be modified if required using the Overlays dialog, Dataset tab,
Details button.

Imported File
Normally external data such as Ordnance Survey NTF, DXF, MicroStation DGN, etc can-
not be edited. If you want to edit such datasets, you should use this option, which places a
copy of the files onto a new Internal dataset in the SWD. These copies can be edited with-
out affecting the original file on disk.
Any of the supported file formats can be imported as editable overlays.
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Plug-in Data Source
This allows you to load a dataset whose contents are read from an external data source (eg
a database, an Internet server) using a plug-in driver. One example is Digital Chart of the
World, where a great deal of information is provided on several CDs.

You are required to browse to the location of the data, and select the information required.

Editable Blobs
Blobs are Binary Large Objects. An editable Blobs dataset is an editable dataset which
stores items as Blob strings in a database.
Cadcorp SIS can use various formats for the Blobs, including the OpenGIS standards. The
structure of the database tables is defined by Cadcorp SIS, and all table management is han-
dled by Cadcorp SIS. ➲Chapter 16: “Using databases”

OpenGIS SQL92 Dataset
These are editable datasets which store items in an OpenGIS SQL92 database. This option
requires you to select a database to use, or allows you to create a new one.
The structure of the database tables is defined by the OpenGIS Consortium. This allows
Cadcorp SIS to operate with other software which supports the OpenGIS SQL92 standards.
➲Chapter 16: “Using databases”

View Blobs
This option allows you to use a read-only view of a database table which has a column of
item Blob strings. You are required to select the database to use, or you can create a new
one.
Cadcorp SIS can use various formats for the Blobs, including the OpenGIS standards. Each
row with a valid Blob string will be an item within the dataset, with attributes from other
columns in the table.
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View Points
This option loads a read-only view of a database table which has columns which specify
X, Y and optional Z co-ordinates. Each row is represented as a point item, with attributes
from other columns in the table.

■ Saved Window Templates
A Saved Window Template (SWT) is a collection of overlays and a view which you can
save. This allows you to have one SWT which will act as a basemap, which you can recall,
add overlays to, and save as an SWD. For example, there could be one SWT for a council,
and individual SWDs based on the SWT for Planning, Environmental Health, and so on.

◆ Creating a new SWT file

1 In Windows Explorer, in the Cadcorp SIS 6.0 folder, create a new folder called Tem-
plates. This is where your SWT files will be stored.

2 In Cadcorp SIS, either:
• Start the File>New Wizard, and choose Blank Map Template. This creates an SWT in

the workspace window called Template, suffixed with the number of the SWT in the
workspace window.

• Create a new SWD as usual.
3 Add the required overlays to this map document.
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4 Use the File>Save As… command to save the SWT. Remember to choose the Save as
type Saved Window Template, and to save it in the Templates folder created earlier.

◆ Opening an existing SWT file

1 Start the File>New Wizard, and choose Map Template. You see thumbnails of all
available templates on the right panel as you click on them on the left.

2 Click Finish when you have chosen the SWT. This loads the map as an SWD in the
map window.

3 You can add new overlays to this, and save it as an SWD.
Use the Map>Go To>Home command to go back to the extents of the original SWT.

■ Shared dataset (SDS) files
A shared dataset file (*.sds) is an editable overlay, used with large datasets, which returns
only a user-specified view of the data. They are queried on a need-only basis, which
reduces the RAM required for their display. When these are used, the schema can be speci-
fied at the time the overlay is created.
SDS files have the following advantages:
• they have a low memory requirement
• they have item-level locking
• they can be shared
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• they are current, because the data is being queried continually
SDS files are used when working with Cadcorp mSIS. They are cursor datasets.

◆ Creating an SDS

1 Start the Add Overlay Wizard., and choose Create New File.
2 Choose a location for your SDS file.
3 In the Dataset Details dialog, you can specify the schema columns by clicking the Cre-

ate… button.

4 From the created schema you can choose a feature table column and a feature code
column.

■ Index datasets
An index dataset does not contain any data. Instead it is a pointer to all files of selected
type(s) which reside in a selected directory or directories. It tiles together these dataset files
in a rectangular grid, making a continuous map base.
For instance, if you had 20 LandLine tiles in a directory called C:\DATA\1250\JPW1, and
another 12 in a directory called C:\DATA\1250\JPW2, you can create an Index dataset
pointing to these files in these directories. Then, whenever you load the index dataset in the
Overlays dialog, all the LandLine tiles in both directories are automatically loaded together
on screen.

◆ Advantages

Once you have created an index, if you later copy more new files to the indexed directories,
the new files are automatically loaded when the Index is used, without any further action
being required.
Where you are using a large number of tiles at once, the large volume of map data this rep-
resents can easily be greater than can fit into your computer's memory. In this case, some of
the tiles cannot be opened and will not be displayed on your screen. When you use an
Index, the computer opens map tiles as you pan to them and closes them as you pan away.
This gives you seamless mapping as you pan around on screen.
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An Index allows you to place a limit on the number of files which can be open on screen at
the same time. If your computer does not have large amounts of RAM and you find that
performance slows when a lot of tiles are open at once, you can use this feature to counter-
act the problem. By setting the limit on open tiles option to a lower number (the default is
64), you can guard against this loss of performance.
You may use multiple paths and/or file types. In this way you can access files which are in
several different locations (eg some on your computer’s hard drive and some on the net-
work server), or which are of different types (eg some raster files in BMP format, and the
rest in TIFF).

◆ Creating and using index datasets

To create an index: 
1 Start the Add Overlay Wizard.
2 Select Index Dataset from the options, then click Next.
3 Select a directory where the files you want to index reside, and click on one of the file

names. Click on Next. The Index Dataset dialog opens:

The Tile information area shows the tile width, file naming convention, and the number
of files of that type found. 
When you have multiple directories indexed, the Matches option shows the number of
files of that type found in the currently selected directory. The Total matches option
shows the total found in all the directories. This is the number of tiles which will be
loaded and displayed in the map base when you use this Index (unless the limit on the
number of open tiles is lower than the number of matches found).
The Tiling details area allows you to select a different tile naming convention, to set a
limit on the number of tiles to have open at one time (see the later section Limit on Open
Tiles), and whether to create a keymap. ➲page49, Creating a key map
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Use the Mixed Tile Sizes checkbox to make sure that all larger and smaller files of the
same file type are automatically included. For instance, if you used mixed file sizes
while indexing on LandLine 1:1250 files, any LandLine 1:2500 files would also be
included. You cannot mix file types in the same Index eg LandLine with OSCAR.
In the Tile path(s) area, you will see the name of the directory you just selected. To add
further directories to the list: 
• click on the folder button, and follow the same procedure as before
• then select a directory followed by a file (the file naming convention must be the same

as previously)
• then click Open
The Extension drop-down allows you to select a different type of file to index in the
selected directory.
Directories can be removed from the Index by selecting them and clicking on the button
containing a cross. 

4 When all the Index parameters are correct, click on Finish. Cadcorp SIS then creates the
index dataset with an appropriate name (eg LandLine 1:1250) and puts it in the Over-
lays list. 

5 To rename the index, go to the Overlays dialog, click the index name so that it is high-
lighted, then type a new name in the Name box.

Indexes are stored as part of the SWD when you use the File>Save command.

◆ Creating a key map

You may automatically generate a keymap for all the tiles in the index by selecting the Tile
outlines option. Selecting Labels will label each tile with its name. 
The keymap allows you to see the extent of the datasets referenced by the Index dataset,
and the names of the dataset files.

Keymaps are created as a non-editable area item with a label using non-editable box text.
The text is placed on level 255 to ensure that labels are always drawn after the tile items.
For details on the levels on which graphics are drawn, .
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By setting the value of the Limit on open tiles option to 0, no tiles are opened, but a keymap
is still displayed if the Tile outlines option is enabled, and labelled if Labels is checked:
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■ Microsoft Windows conventions
Cadcorp SIS uses the standard Windows interface and conventions. Please refer to your
Windows documentation if you need any help with re-sizing, moving, or closing windows.

■ The main window
The main window contains the menu bars, toolbars, and different types of windows, includ-
ing workspace windows, map windows, table windows and 3D windows.
Many windows can be open simultaneously. These can be different map windows or map
windows together with their associated table window and/or 3D window.
Windows can be re-sized, moved, maximised or minimised by using the mouse pointer,
according to standard Windows conventions.

■ Menus: selecting commands

◆ Main menus

The main window displays a menu bar immediately below the title bar. The main menu
headings cascade into sub-menus. Refer to your Windows documentation if you require
any help in selecting commands.

◆ Local menus and the item menu

Cadcorp SIS is an object-oriented system. All graphics within it are known as items, and
fall into item classes which have certain properties. Examples of item classes are line items,
area items, point items, etc. Each class of item has its own set of functions which are appli-
cable to all items of that class.
When an item or items are selected, you can access the functions applicable to those
item(s) via either:
• the Item menu
• the item(s) local menu
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The Item menu
The commands on the Item menu and its sub-menus are unavailable until you have selected
an item. With an item or items selected, the Item menu provides the same commands as the
item’s local menu, except:
• you do not see the commands common to all items (those commands which appear

below the first separator in the local menu)
• there is an additional Select command (eg Select Line items). This appears on the local

menu only when there are items of more than one class selected, and it allows you to
select items of that class only.

The Local menu
To display a local menu, press the right mouse button when the pointer is over the area of
interest.

✐ In this manual we assume that you are right-handed, and have set your mouse up 
for right-handed use (left button selects, right button displays a context-sensitive 
menu). If you are left-handed, and have set up your computer for left-handed use, 
you click the right mouse button for selections, and the left mouse button to see 
local menus.

The local menu appears next to the cursor. Commands applicable to the selected item class
are shown first, above the separator. Below the separator appear other commands which are
common to many classes of items.
The technique for calling up the local menu is slightly different depending on whether you
are selecting one item, several items, or no items:
1 To see the default local menu, click the right mouse button when there is a map on the

screen but there are no items selected:

2 To see the local menu of a single item, click the right mouse button with the pointer
over it. (If the pointer is in empty space, Cadcorp SIS displays the local menu for any
currently selected items, or the default menu if no items are selected.)
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3 As you release the mouse button, the menu is displayed. If the item selected is non-edit-
able, all the editing functions are shown as unavailable, leaving only those applicable to
non-editable items.

4 To see the local menu of a group of items, first select them, then click the right mouse
button with the pointer in a blank area of the screen. (This method can also be used
with a single item.)
If the items are of different classes, there are sub-menus indicated for each of the classes.
A local menu when a line item and an area item are selected might look like this:

A local menu for an editable line 
item might look like this:

A menu for an area item might look
like this:
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■ Windows

◆ The map window

The map window is the window where data is displayed and where you can construct your
own data.

If there are several map windows open, it is within the current map window that graphics
are added, edited, deleted or queried. The title bar of the current window is highlighted.

◆ Table windows

You can open a table window when you want to see and use table data. ➲Chapter 17:
“Table windows”

the current Map Window a table windowWorkspace window
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◆ The workspace window

The workspace window allows you to see and change many details of the current session
relating to the SWDs, the overlays and their contents, and to themes, properties, tables and
libraries. 

You can choose whether or not to display the workspace window, using the Tools>Work-
space Window command. When displayed, it appears to the left of the current window.
➲Chapter 8: “The workspace window”

◆ 3D windows

3D windows are used to display three-dimensional graphics.

◆ The Program Window

You can choose to have the Program Window displayed (by default it is not). The Program
Window is useful for de-bugging when you are writing programs. It lists the names of all
commands recently executed, and whether they have succeeded or failed. See the Cadcorp
SIS Programming Reference Guide for a description of its commands.

To display it, select the Tools>Program Window command (not available with Cadcorp
SIS Map Viewer).
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◆ The position bar

The position bar provides a readout of the position of the cursor, a way of entering co-ordi-
nates using the keyboard, and the currently selected co-ordinate system. You can choose
whether or not to display the position bar, using the Tools>Position Bar command or the
command on the local menu of the toolbars:

The default location for the position bar is at the bottom of the screen, immediately above
the status bar. However, you can locate the position bar anywhere on the screen by drag-
ging it with the mouse. Moving it near the upper or lower margin of the main Cadcorp SIS
window will cause it to dock. Positioning it elsewhere will place it as a free-floating hori-
zontal bar, with a banner and control box. Use the Ctrl key while dragging to prevent
docking.

The first pane on the position bar displays the co-ordinates of the current position. If the
Track checkbox is selected, the readout of the cursor position is continuously updated.
With the Track box unchecked, the co-ordinate is updated only when the cursor is clicked
in the map window. This provides a means of querying positions.
The drop-down list in the middle of the position bar allows you to choose the format for
displaying and entering co-ordinates. The drop-down list on the right of the position bar
allows you to choose your co-ordinate system. You can also input co-ordinates here. If you
type a number on the keyboard while the focus is in the map window, the focus is moved to
the position bar for you to type in co-ordinates.

◆ The status bar

At the bottom of the main window is the status bar. It has an area to the left where prompts
are displayed, plus five more panes:

The prompt area displays the function of any command while your cursor is pointing to it.
Once you have selected the command, it prompts for the next action you are required to do.
If you have not invoked a command, the default prompt is Select item, with Shift to toggle,
or Ctrl to copy, and is for the default action, which is selecting graphics. 
The other panes, from left to right, are as follows:
• the number of items currently selected
• the number of editable items currently selected
• the class of the selected items (as long as only one item class is selected)
• the displayed width (in real world units) of the view in the current window
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• the current display scale 

■ Toolbars
Cadcorp SIS provides several toolbars, and you can choose which of these to display. 
Toolbars are named objects stored in libraries. The supplied toolbars are contained in the
non-editable (standard) library, and cannot be modified. However, you can use them to cre-
ate your own customised toolbars in an editable library.

◆ Choosing which toolbars to display

When you first install Cadcorp SIS the Standard, Styles, Text and View toolbars are selected
for display. They appear below the main menu bar at the top of the Cadcorp SIS window.
To choose which toolbars to display, either:
• click the right mouse button while the cursor is over the grey panel surrounding the

toolbars. The menu will display a list of all toolbars, with ticks beside the toolbars cur-
rently displayed. Select or de-select from the list.

• use the Tools>Toolbars... command, and in the toolbars dialog select or de-select tool-
bars as required:

All toolbars relevant for your Cadcorp SIS product are listed here. They include the
non-editable toolbars provided in the (standard) library, plus any you have created
yourself.

◆ Creating your own toolbars

There are two methods of creating your own toolbars:
• using the Customize Toolbar dialog (use the Tools>Toolbars... command). The new

toolbar is stored in the current library.
• using the workspace window’s library view tab (in this method you can choose to store

the new toolbar in any editable library)

Using the Customize Toolbars dialog
1 Select the Tools>Toolbars... command.
2 Select a toolbar from the list which you can edit to create your new toolbar.
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3 Click on the Customize button to see the Customize Toolbar dialog: 

4 The list on the left shows the tools currently included in the selected toolbar. The list on
the right contains all the tools available, plus the -- Separator --.
To remove a tool or separator from the current toolbar, click on it in the included list,
then click the right chevrons button.
To add a tool or separator to the current toolbar, select it from the available list and click
the left chevrons button (it will be added immediately after the currently selected icon).
Using normal Windows conventions, you can make multiple selections in either list.

5 To change the order of tools in a toolbar, select a tool to move, then click the up or
down arrow to move the selected tool up or down the list.

Using the workspace window’s library view tab
The (standard) library is read-only, so you cannot modify the toolbars in it. However, if you
have an editable library open you can either create a new, blank toolbar in it, or copy and
paste an existing toolbar from the (standard) library into the editable one.
Either:
1 On the library view tab of the workspace window, right-click on the editable library

and choose New Object….
2 From  the New Object pull-down menu, choose Toolbar Definition, and click OK.

A new item will appear in the library. There will be a folder called Toolbar Definition,
and an item called ToolbarDefinition.

3 If you right-click on the ToolbarDefinition item, you can access its properties and add
tools. This will appear in your window.

4 If you want this menu to appear in all subsequent sessions, save the workspace.
Or:
1 On the library view tab of the workspace window, select and copy a suitable toolbar

definition from the (standard) library, using its local command Copy.
2 Select your own editable library (remember that the (temporary) library is not saved at

the end of a session), and use its local menu to paste in the toolbar definition.
3 Use its local command to rename it.
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4 Double-click on the toolbar definition or select its local command Properties... to see
the Customize Toolbar dialog.

5 Then add, remove, and reorder tools, as described above.

◆ Moving toolbars

You can move toolbars by clicking on their grey background area, then keeping the mouse
button held down while you slide the toolbar to the new position. Toolbars can be placed
anywhere on screen, even outside the Cadcorp SIS window.
Toolbars without text boxes (that is, with icons only) change to vertical toolbars when you
locate them at the right-hand edge of the main window.
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■ Map windows and 3D windows
This chapter describes the functions available for moving around the map window, which
contains 2D views.

■ Current cursor position
The position bar displays the position of the cursor.

The current cursor position is given in one of two ways: 
• with the Track option checked it is continuously updated as you move the cursor
• with Track unchecked it is updated only when you click a screen position
The units and precision used are those set on the Units tab displayed by the Map>Co-ordi-
nate Systems... command.
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The first pane allows you to choose the format for the co-ordinate read-out, and is one of
the following:

❏ Co-ordinate formats  
Co-ordinates displays positions as 3-dimensional co-ordinates, either:

• as X,Y,Z distances from the origin if the co-ordinate sys-
tem is Cartesian (eg National Grid) 

• in latitude, longitude and height if the co-ordinate system is
spherical (eg Latitude/Longitude). Positions rotate if you
rotate the axes.

When used with a Grid, TIN or DTM, the Z height gives the
value of the cell of the Grid, or the height at that point on a TIN
or DTM.
eg 241km,596km,15km

Grid Item displays cell values of cursor position for grid items 
eg DTMs, DEMs or grids

Irish Grid displays positions as grid references using the Irish National
Grid system:
eg IN 5067 6432
The precision used reflects the units set. So if you were using
metres with no decimal places, the read-out might be IN 43765
62893. If you are using metres accurate to 3 decimal places,
the read-out would reflect this accuracy eg IN 43765801
62893277.

Latitude/Longitude reports positions in latitude and longitude, plus a geoidal
height, using the current co-ordinate system datum
eg 51.569˚,-3.760˚,0km

Linear co-ordinates used for inputting co-ordinates only
Not used for displaying co-ordinates of a position.

National Grid displays positions as grid references using the Great Britain
National Grid system 
The precision used reflects the units set - see Irish Grid above.
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■ Panning and zooming using the keyboard or mouse

◆ Using the scroll bars

Each map window has slider bars for panning the view horizontally (East/West if the map
has not been rotated), and vertically (North/South if the map has not been rotated).

◆ Using an Intellimouse

If you have an Intellimouse, you can use the middle mouse wheel/button to zoom the view
in or out. Holding the wheel down starts the Map>Pan>Drag command (“sticky hand”
panning). Make sure the correct drivers are installed.

◆ Using a three-button mouse

The middle mouse button automatically starts the Map>Pan>Drag command (“sticky
hand” panning).

Polar co-ordinates displays the current cursor location using a polar co-ordinate
system. The present position is given as a bearing (using the
Angle units set on the Units tab of Map>Co-ordinate Sys-
tems...), plus a distance and height (using the Linear set units).
Positions are shown relative to a point selected using the
Measure>Setup>Polar co-ordinates command. 
eg 135˚, 371m, 0m

Relative
polar co-ordinates

gives polar co-ordinates (a bearing and distance, plus optional
height) relative to the last snapped position
eg 172˚,19m,0km

WGS84 
Latitude, 
Longitude, Height

displays positions as latitude and longitude co-ordinates, plus
their geoidal height
eg -4˚,-52˚,48.3m (meaning 4˚S, 52˚W, 48.3m)

❏ Co-ordinate formats  (Continued)
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◆ Using the cursor keys

Pressing the cursor keys shifts the view in the direction of the arrow. If you have a full
numeric pad the PgUp, PgDn, Home, and End keys can be used to pan north-east,
south-east, north-west and south-west (make sure you are operating with NumLock off):

The default scrolling step in all directions is 8 pixels. You can change this by holding down
the Shift and/or Ctrl keys in combination with the scrolling keys as follows:

◆ * and + Keys

Use the multiplication key (*) on the numeric pad to zoom out, and the plus key (+) to
zoom in, doubling or halving the area of map displayed. These functions work only on the
numeric pad. The * and + keys on the main area of the keyboard do not work in this way.

Shift 1 pixel

Ctrl 64 pixels

Shift + Ctrl half window height and/or width

1 2 3

4 5 6

7 8 9

North

South

EastWest

NorthWest NorthEast

SouthWest SouthEast
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■ The Zoom commands
The Zoom commands appear on the Map menu, and most of the commands can also be
accessed using the icons on the View toolbar. ➲Chapter 5: “Introducing the interface”

Most of the Zoom commands are ‘transparent’, ie you can use them while you are in the
middle of another command. ➲page 74, Transparent zoom commands

❏ Zoom commands  
Command Action 
All Map>Zoom>All 

This command zooms out to show the full theoretical extent of the cur-
rent viewing projection. In the UK, this will be sufficient to show the
entire British Isles.
It is possible to zoom out further than this, but you will then be operat-
ing outside the extent of the current map projection.

Extent Map>Zoom>Extent 
This command zooms in or out to display the full extents of all graph-
ics on all overlays in the SWD. Backdrop overlays are ignored, unless
there are no other graphics to zoom to.

In/Out Map>Zoom>In/Out 
This command zooms the map window in or out to a rectangular area
defined by two screen positions. These positions describe the opposing
corners of a box which defines the area you wish to zoom to or from.

Previous view Map>Zoom>Previous View 
This command recalls the previous view to the screen.
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Roamer Map>Zoom>Roamer (F10) 
This command gives you a magnifying glass (the Roamer) on your cur-
sor. The Roamer magnifies the graphics underneath it as you move the
pointer around:

While using the Roamer, you can increase the magnification by press-
ing the plus key (+) on the numeric key pad, or decrease the
magnification by pressing the asterisk key (*). 

You can snap to zoomed graphics while using the Roamer.
The Roamer is a ‘transparent’ command.
➲page 74, Transparent zoom commands

You can select a square or circular Roamer, using the
Tools>Preferences… command.

Selection Map>Zoom>Selection (red icon)
This command zooms so that the currently selected graphics fill the
view. If no graphics are selected this command is unavailable.

Gazetteers Map>Zoom>Gazetteer…
This command lets you zoom in to a pre-defined location, using a
gazetteer.
➲page68, Plug-in gazetteers

Grid Reference... Map>Zoom>Grid Reference...
This command displays the Grid Reference dialog. It allows you to
type in a Grid Reference and pan the map window to that location. The
dialog box remembers previously used grid references.
➲Chapter  7: “Querying the data in the map window”, Finding grid
references, page86

Step In/Out Map>Zoom>Step>In/Out
Zooms into or out of the current window. The centre of the view
remains the same, and the zoom factor is changed by a factor of 2. You
don’t need to give any screen positions.

❏ Zoom commands  (Continued)
Command Action 
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Raster The Map>Zoom>Raster command sets the view scale so that one
pixel in the bitmap or grid item equals one pixel on the screen, to
achieve the perfect resolution. To do this, the view is zoomed in or out,
using the centre of the screen as the centre of the zoom. 
1 Select the bitmap or grid item.
2 Select the Map>Zoom>Selection command, to centre the raster

image on the screen. 
3 Select the Map>Zoom>Raster command.
The width (X dimension) will always be correct, and if the bitmap’s
pixels are square then the height will be correct too.
This command also operates without a bitmap or grid item being
selected. In this case, Cadcorp SIS searches for a bitmap or grid item
and zooms to it.

To Scale Map>Zoom>To Scale 
This command allows you to input a scale at which to display the
graphics on screen (eg 1250, 500 etc). The Zoom to Scale dialog also
shows the co-ordinates of the centre of the view. You can input a differ-
ent value for the centre.
When you zoom in or out in the map window, this scale changes. 
This feature allows you to visualise your graphics at your chosen scale
which can be useful for checking print displays.

Zoom Overlay Zoom Overlay 
This local command zooms the current view in or out so that an over-
lay fills the window. Select the overlay in the workspace window and
choose the Zoom Overlay command from the overlay’s local menu.

Zoom Box Zoom Box
Click two positions on the map to define opposite corners of a rectan-
gular area. This area will be enlarged to fit the current window size.
This is similar to the operation of Map>Zoom>In.

❏ Zoom commands  (Continued)
Command Action 
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◆ Plug-in gazetteers

A gazetteer lets you find a named location and zoom to it on the map. The
Map>Zoom>Gazetteer… command lets you select a gazetteer:

Then you can choose a named location, and Cadcorp SIS zooms to it:

The following plug-in gazetteers are available for use with Cadcorp SIS. More might be
available in the future, from Cadcorp or Cadcorp VARs. The Help>About command lists
all loaded plug-in gazetteers.

Gazetteer name Function 

World Cities stores the locations of 2000 cities and small countries 
throughout the world

OpenGIS Gazetteer Client a client of an OpenGIS Gazetteer Service, querying 
locations over the Internet

Cadcorp OS MasterMap Gazetteer contains gazetteers of TOIDs or Cartographic text 
from a Cadcorp SIS OS MasterMap database 
➲Chapter 4: “Loading external data”
68 Cadcorp SIS V6 Getting Started



 Chapter 6 ● Working with map windowswww.cadcorp.com
■ The Pan commands 
The Pan commands let you change the visible area of the current map window without
changing the zoom factor.

◆ Map>Pan>Continuous

This command dynamically pans over the current map window.
1 Click in the window.
2 Hold down the mouse button and slide the mouse in the direction of movement.
3 Release the mouse when you have moved to the relevant view.
4 Press Esc to finish, or select another command.

◆ Map>Pan>Drag (“sticky hand panning”)

1 With your cursor at a useful reference point, click and hold. The current view becomes
attached to the cursor and remains attached while you move the cursor around, as long
as you keep the mouse button held down.

2 Drag the graphics in the window as required.
3 Press Esc to exit “sticky hand” panning, or select another command.

◆ Map>Pan>Re-centre

This command changes the current map window so that it is centred on a snapped position.
You can indicate a position in another map window to define the centre.
1 Select the Map>Pan>Re-centre command, or press the F11 function key. 
2 Click on a position in any map window.
3 The map window changes so that it is centred on the position you provided.

◆ Map>Pan>Snap

1 Select the Map>Pan>Snap command.
2 Click a position on the map which you want to move to a new location in the view.

Alternatively type in the co-ordinates of this position.
3 Either:

• click a second position (or type in its co-ordinates), to which the first point you chose
will be moved.

• press Enter to place the first position you chose at the centre of the view. 
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■ The current window
The current window is the one in which all commands and actions are carried out. If you
have more than one window open on screen, you must make sure that the window you want
to work on is the current window before you carry out any action. Do this by clicking in the
required window, or by accessing the SWD local menu on the display view, theme view, or
table view tabs in the workspace window.
You can tell immediately which is the current window because its title banner is
highlighted.

■ Saving and recalling views 
You may store any view which is currently on screen, giving it a name by which to recall it
later. Views are named objects, and newly-created ones are stored in the current library.
1 Zoom and/or pan until the view you have on screen is the view you want to store.
2 Make sure the library where you want to place the view is the current library.
3 Select the Map>View>Store command. In the Save View As dialog, type in a folder

name if you want to create a new folder (you will need to do this if there are no other
views in the enabled libraries), or select an existing folder name if appropriate. All
view folders in all enabled libraries are listed.

4 Enter a name for the view.
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5 The view is then stored in the current library.

◆ Recalling stored views

Once a view has been stored it can be recalled using the Map>View>Recall command. A
zoom and pan are automatically carried out so that the stored view fills the current window.

◆ Deleting, copying, and renaming views

A view’s local menu on the libraries tab in the workspace window allows you to delete or
rename the view, copy it to the clipboard (for pasting into other libraries), or see its proper-
ties (its projection and scale).

■ Rotating views
1 If you have several windows, click in the window you wish to rotate.
2 Select the Map>View>Rotate command.
3 Either:

• click two points on the screen. The view will then be rotated so that an imaginary line
connecting these points becomes horizontal on the screen.

• press Enter and type in an angle by which to rotate the view in a clockwise direction 
If you want to return a rotated view to its original rotation, accept the angle you are
prompted with here.

◆ Making point text remain horizontal in rotated windows

Point text with the Horizontal property set to True will always remain horizontal, even
when the view is rotated.
This feature only works with point text.
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■ Multiple views or windows

◆ Splitting the current window into two

With the Window>Split Horizontal and Window>Split Vertical commands you can
obtain two views of the same map window. If you use both commands, you obtain four
views.
If you split the current window in this way, you can zoom and pan in each new view inde-
pendently (see below), but you cannot resize the views or make further views. 
Clicking the command a second time restores the single view.

◆ Creating a new window from a current window

The Window>New Map Window command creates a new window containing a view
identical to the current one. 
The Window>Create by Zooming command allows you to select an area of the current
view to be shown in a new window.
Whichever command is used, the original window is retained, and another window is cre-
ated with the same title but suffixed :1, :2, etc. 
You can zoom in and out and pan across these windows independently (see below). 
These windows may be resized and moved individually, and may be tiled or cascaded using
the Tile Horizontally, Tile Vertically or Cascade commands on the Window menu. They can
also be split into two using the Window>Split Horizontal and Window>Split Vertical
commands.

◆ Pushing windows and recalling windows

If you are displaying several windows at the same time, the window you want may be
obscured by others.
• Using the Window>Push command, you can push any window to the bottom of the

pile, while still retaining its status as the current window. 
• Any window can be brought to the front by selecting its name from the list at the bot-

tom of the main Window menu, or by clicking anywhere within it.
• The Window>Next command (Ctrl + F6) makes the next window the current window.

(‘Next’ in this context refers to the window that was created immediately after the cur-
rent window.)

◆ Zooming and panning in multiple windows

When working with multiple windows, you may zoom or pan in each single window inde-
pendently, but you may have to select the window you require before carrying out the
operation. 
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In each of the windows except the current window, an outline is drawn to show the extents
of the current window (as long as the current window’s extents lie within that window): 

The outline will normally be a rectangle (as shown above), but it could be a distorted quad-
rilateral if the view projections are different, or a cone if the current window is 3D.

◆ Using one window as an aid to zooming/panning in another window

You can use one window as a reference view for another when zooming or panning. 

Example
Suppose Window 1 displays a large part of a residential area at small scale, while Window
2 is zoomed in to look at just a few of the houses. You now want to change the view in Win-
dow 2 to look at a few houses in a different part of the same residential area. Use Window 1
as a reference view in which to select the new area to be viewed in Window 2: 
1 Click anywhere in Window 2 to make it the current window (the zoom and pan func-

tions operate on the current window). 
2 Select the Map>Pan>Snap command. 
3 In Window 1 click on the house you wish to pan to be displayed in Window 2.
4 Click in the centre of Window 2 to place the house at the centre of the view.
This technique can also be used with other Map>Zoom commands, where you have differ-
ent SWD files on screen, and use one as a reference view for the other.
The Map>Pan>Re-centre command allows you to specify the centre of one map window
by clicking in another map window. ➲page69, Map>Pan>Re-centre
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■ Redraw
There may be times when the screen image appears with bits of graphics missing. This can
happen when graphics have been moved or deleted, or after using the cursor keys to pan
across the map base.
Text and point items are not always redrawn immediately, and so can appear incomplete.
This is because they have only one reference point for locating them on screen, and in some
circumstances, if that point is on screen already, Cadcorp SIS cannot know that the rest of
the text or point item needs redrawing.
Use the Map>Redraw command (F5) to refresh the current window, or the Win-
dow>Redraw All command to refresh all windows. 
During a long redraw you can halt the operation by clicking on the Cancel button which
appears on the status bar at the bottom of the screen, or by pressing Ctrl + Break.

■ Transparent zoom commands
The zoom commands are transparent commands. You can use any transparent command
while you are in the middle of another command, without the need to cancel or complete
the command.
To select this feature, choose the ‘Transparent’ Zoom Commands option in the Preferences
dialog (Tools>Preferences...).
For example, suppose you want to measure the distance between two points that are far
apart on the map. You could zoom out so that you can see both points on the screen at the
same time, but then you might find it difficult to select them accurately if the display scale
is small. Using transparent commands, you could follow this procedure:
1 Select the Measure>Distance command.
2 Select the Map>Zoom>In command.
3 Zoom in on the first point.
4 Select the first point.
5 Zoom and/or pan until the second point is easy to select.
6 Select the second point, completing the Measure>Distance command.
Similarly, you can use the transparent Zoom commands while you are in the middle of con-
structing graphics, such as lines. 
You can use the Roamer (Map>Roamer), another transparent command, while you are in
the middle of a measure or construction command. The Roamer gives you a magnified
view of the graphics immediately beneath the pointer. ➲page 65, The Zoom commands
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■ What information does the data provide?
With external or user data displayed on screen, you can access information on: 
• the dataset file (eg the date it was created and amended, its scale and projection, etc) 
• individual items within the files (eg their feature code, item class, length if they are a

line item, etc) 
This chapter tells you how to access this information.

■ Querying datasets

◆ The Dataset tab in the Overlays dialog

The Dataset page in the Overlays dialog contains information about the datasets included
as overlays in the current SWD. Some of these settings can be changed from here.
The page displays:
• the name of the dataset to which the overlay refers
• the co-ordinate system projection (this can be changed)
• its precision (which can be changed if this is a user dataset)
• the dataset scale (this can be changed)
• feature table it uses (which can be changed if this is a user dataset)
• the number of graphical items it contains
• the amount of computer memory it takes up
• the Owned status (if this is a BDS file) 
• properties of the overlay, such as its pen and brush, its status, at what scales it is drawn,

and so on ➲Chapter 9: “Working with overlays”
• the dataset’s details
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A typical dataset details dialog looks like this:

In the case of a BDS, you will see and can change the co-ordinate system projection, the
dataset precision (which you can change only if you are the owner) and the scale. Other
information is shown, and you can also access the overlay’s properties.
This same information is also accessed in the workspace window (display view and theme
view tabs), and from an overlay’s local command Dataset Details....
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◆ Display view tab in the workspace window

On this tab you can view a tree structure for all the SWDs in the current session, showing
the overlays they contain and the contents of those overlays.

The local menu for each overlay includes the Dataset Details... command which gives you
information on the dataset to which the overlay refers. ➲page75, The Dataset tab in the
Overlays dialog
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■ Querying graphical items

◆ Map Tips

As you move the cursor around the map window, wherever you stop the cursor and it finds
a hot snap (on hittable or editable data), Cadcorp SIS shows the snapped item’s Map Tip:

The information contained in the Map Tip is user-definable, and contain one or more lines
of information. You can also choose not to display Map Tips.
By default, Map Tips show the value of the Description property, but they can display any
property or formula.

Defining a Map Tip
1 Select the Overlays dialog and the Schema tab.
2 Select the overlay required.
3 In the Columns area, select the property or properties to be shown as the Map Tip, and

click in the checkbox next to the property.
4 Click the Map Tip checkbox.
5 Make sure that the Hidden checkbox is not ticked.
6 You can choose any number of Map Tips columns. They are displayed in the map win-

dow in the same order as on the schema.

Turning off the display of Map Tips throughout the SWD
Uncheck the Show Map Tips option in Tools>Preferences....

Turning off the display of Map Tips for an individual overlay
1 Select the Overlays dialog and the Schema tab.
2 Select the overlay required.
3 Select the column.
4 Click in the Hidden checkbox.
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◆ Status bar

Whenever you have items selected in the map window, the status bar displays the total
number of items selected, the number of editable items, and (if the items are all of the same
class) the class of items.

◆ Item properties

You can inspect an item’s properties in two different places:
• if you have the Property View tab selected in the workspace window, the selected

item(s) properties are shown here. Using the drop-down at the top of the window, you
can choose whether to see all the item’s properties, or just a selected category of
properties.

number of items selected number of editable items
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• if you use the item’s local command Properties, you see a temporary dialog. Again the
properties can be viewed in categories, by selecting the required tab:

For a non-editable dataset, these properties are for information only. With an editable data-
set, you can change some of the properties.

◆ Measuring distances

The Measure>Distance command measures the distance between any two positions, or
alternatively the cumulative distance from one position, through a series of subsequent
positions, to the last position chosen. The positions can be three-dimensional. 
In Cadcorp SIS Map Viewer, the route-finding option is not available.
After clicking a position to measure from, as you move your cursor, the Horizontal (X,Y)
and Vertical (Z) panes give a constant read-out of these distances from the first point. The
horizontal distance is the direct distance between the points on the XY plane. The vertical
distance is the Z height.
When you click the point to measure to, the distance between them is given in the Total
pane. You can keep clicking positions to measure to, until you double-click or press the
Enter key to end. The Total pane then shows the cumulative total from the first position to
the last.
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Distances are reported in the current set units and with the set precision.

Use the Simple option to measure the direct distance between any positions in the map
window, pressing Enter or double-clicking to finish. 
Use the Trace option to measure the distance between two positions on a linear feature.
ghis could be a line, a closed line or a link item, or the perimeter of an area or polygon
item. If you are measuring a closed item (line, area, or polygon), the shortest path between
the two points is taken.
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Use the Find Route option to carry out the same operations but on multiple items, if they
are intersecting. If used an a single item which self-intersects, it does not trace the item, but
uses intersections as turning points.

✐ How Distances are Calculated
If the current co-ordinate system is spherical, this command calculates the Great 
Circle distance. The Great Circle distance is calculated accurately in radians using 
the haversine formula. The angular distance is then converted to metres using an 
approximation for the local radius of curvature of the Earth.
If the current co-ordinate system is Cartesian, the 3D straight line distance is 
measured. If the co-ordinate system projection is Transverse Mercator, the 
measuring is done within the projections, so the answer will not take account of 
the projection distortions.

◆ Measure Fence

Use the Measure>Fence command to define a temporary area and measure it. Click on the
screen to define the area. The area is shown in the current area units (to set these, use the
Map>Co-ordinate Systems… command). The value can be copied to the clipboard and
pasted as a text item at the centre of the current map window, or in the text dialog box, as
appropriate.

◆ Route Finding

Using the Measure>Route command you can find the distance between two points on line
and link items and the perimeter of area or polygon items. You see a route drawn between
the points. The items must intersect and must be on an editable or hittable overlay for this
command to operate.
This command is available only in Cadcorp SIS Map Editor and Cadcorp SIS Map Modeller.
Route-finding can be carried out on Line items on hittable and editable overlays: 
• Routes can be measured on external data such as Ordnance Survey LandLine (although

due to the way it was digitised, you will often find that what appears to be a single Line
item is in fact made up of several shorter Line items). 
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• You can also route find on the following 2D geometry: line items created with the
Line... and Freehand Line commands, and on the outlines of closed area items. 

Route-finding is especially powerful with topology, where routes can be found across a link
and node network. The route can also be based on a chosen formula.
1 Select the Measure>Route... command.
2 In the Route dialog box, select how the route should be measured:

The Shortest option can be used to route-find on any line items (in which case Cadcorp
SIS uses the Length property of the items along the route). Formulae can only be used
with link and node topology, when the route is worked out using the “cost” of each
link/chain using a formula. 
The formula could look for a simple property, eg the shortest length, or an attribute such
as Time (if such a property existed on each item on the route). Alternatively, the formula
could be a calculation. 

3 Click the start and end positions between which you wish to find the route. These posi-
tions must be on the same line item on an editable or hittable overlay. 
The route is displayed as a thick black line, and a dialog box displays the distance in the
current units of measurement.

4 Either:
• click OK or Cancel to remove the message
• click on Copy to copy the result to the clipboard as text. It can then be pasted into any

other application or back into Cadcorp SIS, where it is placed as a point text item at the
centre of the current map window. (When you do this ensure that your current pen is
not a multi-level pen, or you will get “double” text appearing.)
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◆ Finding an area value

To find the area value of one or more area items, first select the item(s), then the Meas-
ure>Area command.
The area value is shown in the current area units. The value can be copied to the clipboard
and pasted as a text item at the centre of the current map window, or in the text dialog box,
as appropriate.

◆ Measuring the lengths of items

Select the item or items whose length you need to know, then the Measure>Length
command.
The result given is the length of one item selected, or the total length if more than one item
is selected, and is in the current linear units. 

To set the units, use the Map>Co-ordinate systems... command.
You can copy the value to the clipboard. When pasted back, it is placed as a text item at the
centre of the current map window or in the text dialog box, as appropriate.
The length of an item is also a property, and can be inspected: 
• in the property view tab of the workspace window 
• by using the local command Item Properties...
• by using the Edit>Properties... command
The value of the Length property is reported in metres.
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◆ Measuring angles

Using the Measure>Angle command you can measure the angle formed between two line
items or line segments. If the lines are not connected, you are given the angle which would
be formed if they were extended to meet:

You are given the two angles formed by the lines (the inside and the outside):

The result can be copied to the clipboard. It can then be pasted into a text dialog box, or
into the map window, where it is placed in the centre of the window as a text item.

◆ Finding a position

Using the Measure>Position command you can find the co-ordinates of any position you
click on the screen. The co-ordinates can be copied to the clipboard. When pasted back,
they are placed as a text item at the centre of the current map window or in the text dialog
box, as appropriate.

◆ Measuring a radius

Use the Measure>Radius command to find the radius of any circle, arc or curve.
First select the command, then click on the curve to measure. The value shown is in the
current set linear units, and can be copied to the clipboard. When pasted back, it is placed
as a point text item at the centre of the current map window.
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■ Finding grid references
To find a grid reference, use the Map>Zoom>Grid Reference command. This displays a
dialog into which you can type a grid reference. Cadcorp SIS zooms the map window to
show the position, if it exists.

◆ Zooming using grid references (UK specific)

National Grid references specify an extent on the map base. They can be used to find and
zoom into any area of your map base, whether you are viewing Ordnance Survey data or
any other.
1 Select the Map>Zoom>Grid Reference... command.
2 Type in the National Grid reference in the input box.
3 Click the OK button. 
Cadcorp SIS zooms the map window to show the position, if it exists. The area shown
depends on how precisely you specified the position (see below).

About National Grid references
The National Grid referencing system is based upon the division of Great Britain into
100km squares, each assigned a two-letter code, eg, TQ, SS, NY, etc. References to posi-
tions within any square may be made by means of the eastings and northings in metres
from the bottom left hand corner of the square.
For example, SS 78382 87596 refers to a point 78382 metres east and 87596 metres north
of the bottom left of the SS square.
When using National Grid references, the reference you give not only specifies a position,
but also the extent of the map to be displayed (the precision).

Precision of National Grid references
The number of digits in the easting and northing give the precision. 
The position used in the example above (SS 78382 87596) could be approximated to the
nearest kilometre as: SS 78 88.
Alternatively it could be specified to the nearest millimetre by adding three further digits:
SS 78382452 87596584

SS 78 382 452 87 596 584

100km square km m mm km m mm
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Precision of National Grid references

SS zooms to show a 100km square

SS 7 8 zooms to show a 10km square

SS 78 88 zooms to show a 1km square

SS 784 876 zooms to show a 100m square

SS 7838 8760 zooms to show a 10m square

SS 78382 87596 zooms to show a 1m square
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■ What is the workspace window?
The workspace window displays information about the current session. It also allows you
to change settings and properties, and it provides access to many commands and
operations.
There are five tabs on the workspace window:

In Cadcorp SIS Map Viewer, only the display and property tabs are provided. Each tab
allows access to different functions.
All the workspace window views work in the same way. They are modelled on Windows
Explorer, and provide a ‘tree’ structure. Click on the plus sign next to each SWD or overlay
to extend the tree, and click on the minus sign to minimise the tree. You can toggle items
between visible and invisible by clicking on the icon for the overlay. To rename the overlay,
either press F2 when an overlay is selected, or click once on the overlay to select it and then
click once again (two clicks rather than a double-click).

◆ Using the workspace window with the map window

Keyboard commands in Cadcorp SIS work differently depending on whether the focus is on
the workspace window or on the map window. 
To get the focus on the relevant window you need to click somewhere on that window. 

Display
View

Theme
View

Library View

Property 
View

Table 
View
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For example, the F2 button renames an overlay in the workspace window, but in the map
window it displays the Overlays dialog. If you press the asterisk key (*), this zooms out
when the focus is in the map window, but maximises all the overlays from the selected
overlay downwards on the workspace window (there is no minimise button to undo this).

◆ Local menus

Every object in each workspace window has a local menu. ➲page51, Local menus and
the item menu

Some of these local menus are standard, and are the same on all workspace windows (the
local menu for SWDs, the local menu for Map 1 (overlay name), for example). Some are
specific to different views (for example, the local menu for overlays).
The local menu for the Saved Window Definition allows you to open or close SWDs, add
overlays to the SWD, change the system preferences, and hide the workspace window
entirely.

The local menu of individual SWDs allows you to do the following:
• choose that particular SWD from many to be current (ie the one being examined)
• access the Add Overlay Wizard
• paste copied overlays
• access the Overlays dialog
• save the SWD (including saving with a new name)
• close the SWD
• display the SWD’s properties

Further down the tree, the overlay’s local menu gives you access to many of the functions
found on the Overlays dialog.
90 Cadcorp SIS V6 Getting Started



 Chapter 8 ● The workspace windowwww.cadcorp.com
■ Displaying the workspace window
You can choose not to have the workspace window open. This allows you to see more of
the map window. When used, the workspace window appears to the left of the map
window.
The Tools>Workspace Window command controls whether or not the workspace win-
dow is displayed. The command toggles the window on and off.
You can hide the workspace window using the Hide command on the Saved Window Defi-
nitions’ local menu (which is visible on the display, theme, and library tabs, but not on the
property tab).

■ Display view tab
In the display view of the workspace window you can alter how you display the map. The
local menu for an overlay in the display view is as shown:

Many of these commands are duplicated in the Overlays dialog.
If you click on the plus sign next to the name of the overlay, you see further options.
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If there is no feature table applied to the overlay, or, if there is a class-based filter in use,
you see the item classes shown as below. You can click on the class icon to make the classes
and its subclasses visible or invisible.

If there is a feature table applied to the overlay, or if there is a feature filter in use, you see
the feature types shown as below. You can click on the type icon to make the classes and its
subclasses visible or invisible.

If there is a compound filter applied to the overlay, you see details of the filter.

With a property filter you will see no further tree structure.
The local menu on the display view allows you to control the status of the overlay; whether
it is editable, hittable, visible, or invisible. You can also change filters and loci.

■ Property view tab
This tab displays the properties of the item or items currently selected in the map window.
If no items are selected, the overlay’s default properties are shown.
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The properties are divided into several categories. Using the drop-down list at the top of the
window, you can choose to display any of these categories, or all properties. 

You can change editable properties here. Properties on a grey background cannot be edited,
because they are derived from other data.
➲Chapter 14: “Properties”
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■ Theme view tab
The main function of the theme view tab is to allow you to add themes to an overlay, and
you can use the local menu of a theme to access many of the theme operations (which are
also found on the Themes tab of the Overlays dialog).

The theme view tab includes a legend area where the theme(s) of the selected overlay are
displayed. If the selected overlay has no themes, the overlay styles are shown (pen, brush,
shape, font, and colour). ➲Chapter 15: “Thematic mapping”

■ Table view tab
The table view tab allows you to connect to databases. Using X and Y co-ordinates, Cad-
corp SIS can view database data as an overlay. However, when an overlay has no X and Y
co-ordinates, a table can be brought into Cadcorp SIS and joined to an overlay. You can do
this in the table view tab. ➲Chapter 17: “Table windows”
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■ Library view tab
You can create new named object libraries using the local menu of the library view tab. You
can also connect to existing libraries. Use the New Object command on the local menu of
an individual library to create a brush, colour-set, feature table, pen, or toolbar definition. 

On the local menu of the library workspace window (on the word Libraries), there is a
command Toggle ‘*’ Objects.

This allows you to control the visibility of all the objects in the libraries which are prefixed
by an asterisk. Items prefixed like this are usually used in wizards, such as the Print Wizard.
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■ What is an overlay?
The term overlay is used to describe a view of a dataset. A dataset can be: 
• a read-only graphical file (eg NTF, DXF, BMP file)
• a user dataset (BDS file)
• stored within the SWD file (internal dataset or index dataset)
• graphics stored in an ODBC database
• an internal Blobs dataset
For a full list of datasets which can be included as overlays, ➲Chapter 4: “Loading exter-
nal data”.

■ The Overlays dialog 
You can use the Overlays dialog to: 
• select which datasets are used in the current SWD
• add further overlays to those used in the current SWD
• set up and control the properties of overlays, eg to assign overlay pens and brushes, to

rename overlays, to assign notes to them, to control the display of items on the overlay,
etc

• create user overlays 
• create schemas and themes
Some functions of the Overlays dialog can also be accessed from the Overlay local menu
on the display view, theme view, or table view tabs in the workspace window.

◆ Accessing the Overlays dialog

To display the Overlays dialog, do one of the following:
• click on the Overlays icon in the Standard toolbar
• select the Map>Overlays... command
• press F2 when the focus is in the map window
• select the Overlays... command from the default local menu (shown when right-click-

ing in the map window if no items are selected) 
97



Chapter 9 ● Working with overlays www.cadcorp.com
• select Overlays... from the local menu of an SWD on the display view tab in the work-
space window

The Map>Overlays... command is not available in Cadcorp SIS Map Viewer.

◆ The Overlays ddialog for a typical session

The Overlays dialog shows all the overlays in the current SWD and these are listed in the
panel on the left hand side.  ➲Chapter 4: “Loading external data”

This panel is shown on all six of the tabs on the Overlays dialog: General, Include, Styles,
Schema, Themes and Dataset. When applying changes using the Overlays dialog, you must
select the relevant overlay prior to changing it. You can also access the properties of the
SWD from the left hand panel. Use the Up and Down arrows to change the ordering of the
SWD. This can be important, depending on what types of datasets are being displayed.

Tab Function

General controls common functions such as renaming overlays, deleting overlays,
cutting, copying, and pasting overlays, changing the status of an overlay,
and so on ➲page100, Overlay status

Include controls what is included on the map, ie whether there are filters or loci in
place, or whether item(s) have a scale threshold applied to keep certain
ones visible, and certain others invisible 

Styles controls styles for the whole overlay, and if you tick the Override tick box
it will force the whole overlay (including any themes) to the colour
selected. You can also override the dataset scale here. 
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The Overlays dialog shows the various different datasets that have been loaded. ➲Chapter
4: “Loading external data”

■ Overlay functions

◆ Including datasets as overlays

You use the New Overlay Wizard to add more datasets as overlays to your SWD. To access
the New Overlay Wizard:
• click the Wizard... button in the Add Overlay area in the Overlays dialog, or 
• select the Add Overlay... command, which is found:

• on the main Map menu
• on the default local menu in the map window, with no items selected
• on the SWD local menu in the workspace window (display view, theme view and table

view tabs)
➲Chapter 4: “Loading external data”

◆ Creating user datasets

Use the New Overlay Wizard to create user datasets (internal datasets and BDS files), index
datasets and internal Blobs datasets.

◆ Copying overlays

There are two different methods of producing multiple copies of an overlay:

Copying overlays from one SWD to another
You can drag and drop overlays in the workspace window. To move an overlay from one
SWD to another, drag it to the required location. To copy it, hold down the Control key
while dragging.
You can access the Overlays dialog for the source SWD, select the overlay and use the
Copy/Cut buttons on the General page. Then access the Overlays dialog for the destination
SWD and use the Paste button.
You can use the display view tab in the workspace window. Use the overlay’s local com-
mands to cut or copy the overlay, and the SWD local command to paste.

Schema allows you to add columns to the overlay schema, to access the Formulae 
dialog box which allows you to carry out complex calculations based on 
your existing data. You can also store schemas to be used on other overlays.

Themes allows you to access the Add Theme Wizard; it allows you to edit themes;
and to remove themes ➲Chapter 15: “Thematic mapping”

Dataset shows information regarding the dataset, its projection, its dataset scale,
any feature tables associated with it, and the number of items open on that
overlay 

Tab Function
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Creating multiple references to an overlay in a single SWD (Phasing)
Selecting an overlay then clicking the Phase button (General page of the Overlays dialog)
creates a second reference to it, causing it to be drawn twice. Where you create multiple
copies of a dataset in this way, it is called “phasing”. 
Each phase of the dataset can have different criteria set. For instance, one phase of the data-
set could contain a filter so that only building outlines are shown, whereas another might
display only roads. By making the different phases visible or invisible, this gives a fast
method of looking at certain details in a dataset.
Each phase can be given a descriptive name to distinguish it from another phase, by renam-
ing it in the Name box.
When you are using phases of editable overlays, if you edit any of the phases, this updates
the original dataset.

◆ Overlay status

The status of an overlay governs whether the data on it can be edited, selected but not
edited, or simply viewed. The status options appear on the General tab of the Overlays dia-
log, and on the overlay’s local menu on the display view tab of the workspace window. 

An Overlay’s status can be changed using the display view’s local menu. You can also click
on the overlay icon in the workspace window (display view, theme view, or table view) to
toggle its status between its minimum (invisible) and its maximum (set by the user).
External datasets such as Ordnance Survey NTF cannot be edited (unless a copy has been
made by using the Imported File option) and therefore can only have a maximum status of
hittable.
User overlays can have any status. However, in the case of BDS files, which can be shared,
only one user may have editable access at any one time. Other users will find access limited
to hittable until the first user releases ownership.

editable full access to add, modify and delete information. This option applies only to
user datasets (SDS and BDS files, internal datasets and Blobs overlays). 
In the case of BDS files (which can be shared via a network), only one user at a
time can have Editable access to them.
In the case of Blobs overlays (which can be shared via a network), individual
item locking is used.

hittable the ability to snap the cursor onto graphics to measure, query, trace and copy
data
You cannot move, delete or add data.

visible graphics appear on screen but cannot be queried (snapped to). The image is
purely a backdrop.

invisible no graphics appear on screen. This is useful for temporarily excluding informa-
tion from the view.
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◆ The order of the overlays

The order in which the overlays appear in the Overlays dialog is important in the following
circumstances:
• Data is drawn on the screen in the order in which the overlays appear in the Overlays

dialog. You may want to control this. For example, if you are using raster data, you will
normally want to ensure that this gets drawn first, with the vector data over the top (if it
were the other way round the raster data would obliterate everything that was previ-
ously drawn).

• If you have more than one user overlay, and none of them is currently selected, new
data that you create or import is put on the first editable user overlay in the list.

To change the order of the overlays
On the display view tab of the workspace window, either:
• select the overlay name, and drag it to the new position, or
• select an overlay to move in the list, and use its local commands Promote and Demote
Alternatively, use the Overlays dialog:
1 Select the Overlays dialog (overlays can be re-ordered on any tab).
2 Select an overlay to be moved.
3 Click the up arrow or down arrow as required to move the selected overlay up or down

one place in the list.

◆ Making an overlay current

The current overlay is the one to which changes are made when you carry out operations in
the Overlays dialog, such as changing the overlay pen or setting the status.
When you create your own data, you should make sure it is put on the overlay you require
by first making that overlay current.
You can make an overlay current by doing one of the following:
• select the Map>Set Current Overlay... command, then select an overlay from the

dialog
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• click on it in the Overlays dialog, or use its local command Make Current (display
view, theme view, or table view tab in the workspace window). In the Overlays dialog,
the current overlay is the one in which new data is stored. Its name is displayed in bold
type in the workspace window.

◆  Renaming overlays

You can rename an overlay by doing one of the following:
• select it in the display view, theme view, or table view tabs in the workspace window,

click on the name (or press F2), and type a new name
• select it on the General page of the Overlays dialog and type a new name in the Col-

umns box
• use the overlay’s local Rename command in the display view, theme view, or table

view tabs in the workspace window
This facility is particularly useful when you are using phased overlays, when it allows you
to give a different name or number to each occurrence of the dataset.
When renaming BDS files and other datasets stored on your disk (eg Ordnance Survey
data, DXF files, PAF files) in the workspace window, Cadcorp SIS changes only their name
shown in Cadcorp SIS; the name of the file on the disk is not affected. 

◆ Removing overlays from the SWD

The Delete button on the General page of the Overlays dialog removes the selected overlay
or overlays from the SWD. 
Alternatively, use the overlay’s local command Delete (on the display view tab or theme
view tab in the workspace window).
• removing external datasets has no effect on the existence of the file or on the data

within it
• removing a BDS file does not affect the existence of the file on the disk. However, all

changes made to the BDS during this session will be lost. You are therefore given the
choice of saving changes to the file before you remove it:
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• data created on an internal dataset is saved only when you use the File>Save command.
(An internal dataset is saved as part of the SWD file.) Therefore, if you remove an
internal dataset, all data on it will be lost. You will be reminded of this by the following
prompt:

◆ Adding notes to an overlay

Each overlay can have some descriptive text associated with it.
You can create notes for an overlay, or edit existing ones, by either of these methods:
• on the display view, theme view, or table view tabs of the workspace window, choose

the Overlay Notes... command from the overlay’s local menu. You can then type the
notes required:

• select the overlay on the General tab of the Overlays dialog. Type the required text in
the box at the bottom of the tab: 

The overlay notes are saved with the SWD and are not attached to the dataset itself. 
Each time you select the overlay on the General tab of the Overlays dialog, you will see the
notes displayed.
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◆ Restricting the display of items on the overlay

Use the Include page of the Overlays dialog to carry out the following tasks. 

Filter
Filters control which items on the overlay are displayed and which are not, based on crite-
ria you have chosen. For example, you can exclude certain classes of items from the
display, or choose to display only selected features, or only those items which have a cer-
tain property.
Once applied to an overlay, a filter stays in force until you clear it. To clear a filter, use
either:
• the overlay local command Reset Filter in the display view tab of the workspace

window
• the delete button next to Filter on the Include tab of the Overlays dialog

Locus
You can select a locus to use on the overlay. A locus is an item used to carry out a variety of
spatial tests. Items on the selected overlay will be displayed only if they pass the locus test.
For instance, if the locus were an area item or closed line item, it could exclude from the
display all items which lie outside it; if it were an open line item, it could display only
those items which intersect with it; if it were a point item, it could display only those items
which contain it; and so on. 
Loci can be used once, or stored for later use as named Objects in libraries. Loci are also
used to restrict which items may be selected for editing.
Once you have applied a locus to an overlay it stays in force until you clear it. You can do
this on the Include tab of the Overlays dialog, or by using the overlay local command Reset
Locus in the display view tab of the workspace window.

Scale thresholds
Each overlay has minimum and maximum scale settings, and the overlay is displayed on
screen only when the display scale is between these two settings. 

◆ Ownership of BDS files

When you create a BDS file, or are the first person to open an existing one, you are given
ownership of it. The owner of a BDS is the only user who can edit it, although other users
may have simultaneous read-only access. 
If you are the owner of the overlay, clearing the Owned checkbox on the Dataset page of
the Overlays dialog allows you to disown it. If you are not the owner, clicking this box
allows you to become the owner, as long as no-one else owns it at the time.
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◆ Default overlay styles for pen, brush, shape, text and colour

Each overlay has a default pen, brush, shape (symbol), and font, which are set on the Styles
tab of the Overlays dialog. 

These are the pens, brushes, and shapes used by graphical items whose values are set to
(By Overlay).
When an overlay is created, either using an internal dataset, a BDS file, or an SDS file, it is
automatically assigned a pen and brush which are different from those assigned to other
overlays. This is to differentiate it from other overlays, but you can change the pen and
brush of any overlay whenever you wish. Likewise the default shape, called (dot) and the
default font (Arial) can also be changed.
You can force all items on the overlay to display in the selected colour, while leaving their
other characteristics (linestyle and line thickness) to be determined by their assigned pen.
To do this, check the override checkbox next to the Colour setting, then select a colour. 
A scale can also be set for the overlay here. 

◆ Dataset information

The Dataset page of the Overlays dialog allows you to see and sometimes change various
features of the dataset to which the overlay refers. For example, it contains a Co-ordinates
button allowing you to see details of the dataset’s co-ordinate system (and change it if it is
an editable dataset).
The Details button gives access to other parameters of the dataset, such as its scale, preci-
sion, etc. Further information shown depends on the type of dataset. For example, for an
index dataset, the indexing details will be shown; for a database, such details as its record-
set are shown. This information can also be displayed using the Dataset Details...
command on the overlay’s local menu on the display view tab or theme view tab in the
workspace window. ➲Chapter 7: “Querying the data in the map window”
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◆ Feature table (user overlays)

When using user-owned overlays, you can assign a feature table, using the Feature Table
option on the Dataset tab.
When using non-editable datasets, this option is for information only.

◆ Overlay properties

Most of the properties you assign to overlays in the Overlays dialog can also be changed in
a Property Window in the normal way.

The overlay properties can be accessed from any tab in the Overlays dialog, and from the
overlay’s local menu on the display view, theme view, and table view tabs in the workspace
window.

◆ Using data: creating schemas

A schema defines a sub-set of data, and is used to control the display of the data-oriented
parts of the user interface, notably the table window, themes and Map Tips. A schema con-
sists of a list of the data columns for the overlay. 

◆ Using data: thematic mapping 

Thematic mapping is the use of symbols, shading, labels, dot density, or graphics such as
bar charts, pie charts, graduated colours etc, to indicate visually on the map various types
of information. This could be the distribution of data (eg population information), height of
contours, or flow directions, etc. ➲Chapter 15: “Thematic mapping”
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■ User datasets
As you construct your own data it is placed in a user dataset. A user dataset is an internal
dataset, a BDS file, or an internal Blobs dataset. 
Before creating graphics you should select the user dataset where you want to save them, or
alternatively, create one. Having created or selected the dataset, you can then add data of
your own. 

■ Levels
Each overlay has 256 levels, numbered between 0 and 255. Each graphical item within the
overlay is assigned to one of these levels. When drawing items on the screen, Cadcorp SIS
starts with the first overlay listed and draws all items on its level 0, then its level 1, then its
level 2, etc. It then draws the second overlay, starting with level 0, then level 1, and so on.
This sequence is followed for all visible overlays. This means that items with an opaque fill
on higher levels can obliterate other items already drawn on lower levels. To avoid this, you
can change the level of an item.
When you create an item it is first placed on level 0. To change this, use the Level property.
Pens can also be multi-level, which further affects the sequence of drawing on the screen.

■ Which pens and brushes are used
Pens are used to draw line items and text items, and the outlines of area items. A pen
defines the style in which the items are drawn, having a colour, a thickness, a linestyle and
several other optional properties. Brushes are used to fill area items, and have a colour, an
opaque/transparent property and may use hatch patterns or other graphical fill patterns.
When you start to draw, the new item uses the pen and brush shown in the Styles toolbar. If
you cannot see the Styles toolbar, select it by using Tools>Toolbars... or from the local
menu in the toolbars area of the screen. If you want to use a different pen or brush, select it
here before starting to draw (although you can also change these properties later if you
wish).
Pens and brushes are named objects, stored in libraries. Cadcorp SIS comes supplied with a
number of pens and brushes, and you can also create your own.
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■ The Geometry 2D commands
The Geometry 2D commands on the Construct menu provide typical CAD functionality for
drawing basic lines and shapes.

◆ Using the Draw toolbar

The Geometry 2D commands are also on the Draw toolbar:

You might find using the Draw toolbar faster than using the main menu. (If the Draw tool-
bar is not displayed, select it either by using Tools>Toolbars..., or from the local menu of
the toolbar area of the screen).

◆ Using the Geometry 2D commands

When you have one of these commands selected, you will notice that the cursor changes to
an arrow with a spanner beside it (indicating a toolbox operation). When you have finished
drawing an item the cursor continues to display the spanner icon. The command is still
active, and you can go on to draw further items of the same type without re-selecting the
command. 

◆ Ending a Geometry 2D command

Some commands, such as the Construct>Geometry>2D>Line... command, require use of
the Enter key to complete the operation.
To finish any of the Geometry 2D commands, press the Esc (escape) key, or select another
command. The use of Esc throws away any constructions still in progress.
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◆ ‘Transparent’ commands

On the Options tab of Preferences dialog (Tools>Preferences...) you can select the ‘Trans-
parent’ Zoom commands option. With this selected you can use the Zoom commands in the
middle of Geometry 2D commands.

■ Snapcodes
Sometimes you want to select graphics by an exact position, such as the end of a line, or
you may want to draw to an exact location, such as the centre of a circle.
By using snaps you can draw to precise points on existing graphics, such as ends of lines,
midpoints of lines, centres of circles, etc.
Some snapcodes such as Line and Area appear at the cursor position when your cursor is in
the correct location. By clicking when you see these snapcodes, you know you are snap-
ping to the Line or Area.
The available snaps, with their keyboard shortcut shown, are shown in the following table.
Some are used only for selecting graphics, not in situations where you are creating graph-
ics: 

❏ Snapcodes  
Area A Snap to the centre point of an area item.

In the situation where several area items are found, the area with the
smallest extent is selected (unless the Select dialog is in automatic mode
- see below).

Box B Snap to one of the justification points of a box text item.

Centre C Snap to the centre of an arc or circle.

Dot D Prevent snapping. The exact position of the cursor is used.

End E Snap to the nearest end of a line.

Grid G Snap to the nearest snap grid intersection point. This snapcode is availa-
ble only if the snap grid is displayed and enabled for snapping (see the
Map>Snap grid... command). 

Hook H An item’s hook point is the centre of a rectangular box drawn around it. It
does not work with all item classes, for instance, not with point items.

Line L Snap to the nearest geometric point on the nearest line item.

Middle M Snap to the mid-point of a line segment.

Normal N Snap to the nearest line, correcting to perpendicular. 

Point P Snap to a point or point text item.

Query Q Show the Map Tips for that point.

Raster Snap to a raster pixel. This snapcode is available for both un-compressed
and compressed raster data.
This snap is the only one which cannot be typed from the keyboard.
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◆ Forcing snaps

Except in the case of the Raster snap, you can force the cursor to a snap by typing the key-
board shortcut. 
To prevent the cursor snapping to a point, press the D key (for digitised) and the exact posi-
tion of the cursor is used, with no correction.

◆ Forcing the Select Item dialog

In the Preferences dialog (displayed by the Tools>Preferences… command), there is an
option called Automatically show Select Item dialog. When this is ticked, the Select Item
dialog shows whenever you click on the map window, if there is a choice of items to select. 

◆ Precision drawing

The Cadcorp SIS User Guide describes how to use:  
• units
• snap grids
• axes
• typed co-ordinates
for precision drawing.

Select S When you are using the Edit>Select command, this snap allows you to
choose which item you require in ambiguous snapping situations. The
Select Item dialog opens:

Vertex V Snap to the nearest vertex point. This could be the end of a line, corner of
a polyline, vertex point on a circle, etc.

X-Cross X Snap to the nearest intersection of two lines.

❏ Snapcodes  (Continued)
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■ Line items
A line item is made up of vectors (line segments), each vector having a vertex point at its
beginning and its end. It may have curved segments, and it may be a closed item. Straight
lines, arcs and curves are all examples of line items.
Line items can be 3D lines, ie their co-ordinates can lie in three-dimensional space.

◆ Using the Line... command

This command is used for drawing line items consisting either of just a single segment, or
of a series of connected segments (known as a polyline). 

With all line types, the procedure for creating lines is as follows:
1 Type in offsets if required and, if constructing multiple lines, select the Cap Ends

option if you require closed ends.
2 Click a point on the screen where you want the line to begin. You will see a line start-

ing at the point you clicked, the other end being attached to the cursor. 
3 Click a point on the screen to fix the other end of the line. Notice that a “rubber band”

line is still attached to the cursor, allowing you to input further points if required. 
4 If you wish to delete a point you have just input, press the Backspace key. 
5 When at least two line segments have been drawn, it is possible to join the first point to

the last to form a closed line item. Press the Ctrl and Enter keys together to close the
shape.

6 Otherwise, continue to click positions to create a chain of line segments, called a
polyline.

7 Press the Enter key or double-click at any time to finish.

line polyline
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◆ Simple, orthogonal, and right-angled lines

Orthogonal lines are drawn parallel to the current axes. You can draw orthogonal lines at
angles other than 0°, 90°, 180° and 270°, by changing the orientation of the axes before you
construct the line segment(s). 
Right-angled lines are constructed so that each line segment is 90° to the previous line
segment.

◆ Trace

This option creates a new line traced over any part of an existing line or outline on an edit-
able or hittable overlay. Alternatively, the new line can be offset from the traced data.
1 Click a point to start tracing, which should be a point on the graphics to be traced.
2 Click the next point to be traced to. Cadcorp SIS searches for a continuous path

between the first and second point. If no continuous path is found, you must try again.
3 Continue clicking points to be traced to. If you want to delete the last point clicked,

press the Backspace key. While clicking points you may use the following key
combinations:

4 Press Enter to finish tracing, or Ctrl + Enter to close by drawing to the first point
snapped.

1
2
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4
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line constructed as a simple line same line constructed as an orthogonal line

(Ctrl + Enter to close)

Shift + snap to draw to the snap point, even if it is not on the graphics (this is
called jumping)

Ctrl + snap to trace to the end of the line on which you snap, rather than to
the snapped position

Shift + Backspace to go back to the last vertex point on the traced data, even if you
jumped over it
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Difficulties you may encounter when tracing external map data
Vector-based maps such as those supplied by Ordnance Survey have been created by digi-
tising existing paper maps. These paper maps are supplied in tiles. Where a feature such as
a road centreline or road edge comes to the edge of one of these map tiles, the graphics
stop, starting again on the adjacent map. The digitised line will therefore stop at an unex-
pected place. 
The person digitising the original data may have stopped the line at a position which
seemed appropriate, but does not suit you.
Graphics may have been digitised using lots of points, which will have resulted in many
vertices.

■ The Freehand command
A freehand line is created by placing vertices at short time intervals. Slow movements of
the cursor places more closely spaced vertices than fast movements and therefore produces
smoother curves.
1  Select the Construct>Geometry 2D>Freehand command.
2 Hold down the left-hand mouse button down while dragging the cursor along the path

you want. A line will be constructed which follows the path of the cursor. 

This line may appear curved, but it is actually made up of many small line segments. A sin-
gle click creates a point item.

■ Area items
An area item is a distinct class of item with its own set of properties. Area items include: 
• simple areas
• multi-areas
• photos
• topological polygons
• QZones 
• buffer zones
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Closed line items created with the Construct>Geometry 2D>Line and Freehand Line
commands are not area items. However, any line item, whether it is closed or not, can be
converted into a simple area using the line item command Convert to Area, or the main
menu command Alter>Fill Geometry.
Simple areas can be created using the Area, Circle, Ellipse and Rectangle commands.
(They can subsequently be converted to line items using the Alter>Unfill command.)

◆ The Construct>Geometry 2D>Area command

The operation of the Construct>Geometry 2D>Area... command is similar to that of the
Line command.
1 Select the Construct>Geometry 2D>Area... command.
2 In the Area dialog, choose one of the options for drawing the area’s outline:

3 Input points to construct the boundary of the area. Press Enter when you have finished.
This dialog is not available in Cadcorp SIS Map Viewer and Cadcorp SIS Map Manager.

■ Circles
With the Construct>Geometry 2D>Circle commands you can construct circular area
items using any of five methods. 
To create a circular line item, first create the circular area item, then select it and use the
Alter>Unfill command.
These commands are not available in Cadcorp SIS Map Viewer and Cadcorp SIS Map
Manager.

◆ Circle>2 Points

This command enables you to draw a circle by giving two points on the circumference, and
can be used when you know two points through which the circumference of the circle must
pass.
1 Select the command.
2 Click one point through which the circumference must pass.
3 Click a second point through which the circumference must pass.

first point second point
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◆ Circle>3 Points

The Circle>3 Points command enables you to construct a circle by giving three points
anywhere on the circumference of the circle. It can be used to create a circle which passes
through three known points.
1 Select the command.
2 Click the first point through which the circumference will pass.
3 Click the second point through which the circumference will pass. As you move the

cursor around you will now see a circle which is attached to the cursor and fixed to the
first two points you clicked.

4 Click a position for the third point on the circumference. This point determines the size
and the location of the circle.

The following diagram shows four circles constructed using the Circle>3 Points com-
mand. In all cases, points 1 and 2 are the same. Point 3 then fixes the size and location of
the circle.

◆ Circle>Centre Point

Use this command when you know the position of the circle’s centre, and a point through
which the circumference passes.
1 Select the command.
2 Click the position of the centre of the circle. You will now see a circle centred at this

point. This circle changes size as you move the cursor. 
3 Click a point on the circumference (this fixes the radius of the circle).

◆ Circle>Radius Centre

Use this command when you know the radius of the circle and where its centre is. It can
also be used to create concentric circles.
1 Select the command.

1 1 1 1
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2 On the prompt bar, type in the radius of the circle. A circle of this radius is then
attached to the cursor. 

3 Click a position for the centre of the circle.

To draw concentric circles 
1 Select the Circle>Radius Centre command.
2 On the prompt bar, type in the radius of the smallest circle, followed by a space, fol-

lowed by the distance to the next circle, followed by a space, followed by the distance
to the next circle, and so on. 

3 Click a position to locate the centre of the circles.
Example To draw concentric circles of radii 100m, 200m, 300m, 400m and 500m, enter
100 100 100 100 100. 
A shortcut to this is to use the repeat facility. The above circles could be constructed by
entering 100 r 5 or 100 REP 5.

◆ Circle>Radius Point Point

Use this command when you know the circle’s radius and two points on its circumference.
1 Select the command.
2 Type in the radius of the circle.
3 Click a point on screen through which the circumference will pass. A circle of the

required size is attached to the point given. As you move the cursor, you see the poten-
tial circle rotating around the fixed point.

4 Click a second point to fix the location of the circle. The diagram shows such a circle,
with other circles indicated which could have been created with a different second
point:

5 As there are still two possible locations for the new circle, click close to where the cir-
cle’s centre will be to finally fix it (this third point could be either of the positions
shown here): 

1
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■ Rectangles 
The Construct>Geometry 2D>Rectangle command creates a rectangular area item. 
To construct a rectangular Line item, first create the rectangular area item, then select it and
use the Alter>Unfill command. Alternatively, use the Line or Line Ortho command to
draw a rectangular line item.
Rectangles are constructed orthogonal to the current axes. If you have rotated the axes, you
will find that the rectangle is rotated as well.
1 Select the Construct>Geometry 2D>Rectangle command. 

2 If you want to draw a square, click the Force X equal to Y checkbox.
3 Click a position on the screen to locate any one of the rectangle's four corners. You will

now see a rectangle rubber-banding on the cursor from the point you started. 
4 Click the cursor to fix the location of the opposite corner.

◆ To draw a rectangle of a specific size 

You can either input one value (X or Y), and use a screen snap for the other, or you can
define both the X and Y values, as described here:
1 Select the Construct>Geometry 2D>Rectangle command. 
2 Type in the sizes for the X dimension and the Y dimension.
3 You will see a rectangle of the chosen size centred on the cursor. Click a position on

screen. One of the nine points on the rectangle will be placed at that position:

click here
118 Cadcorp SIS V6



 Chapter 11 ● Creating basic geometrywww.cadcorp.com
4 As you move the cursor towards the second point, before clicking it, you see alternative
locations for the rectangle. Click a second screen position. The direction of this posi-
tion from the first determines which rectangle you choose. 

5 If you proceed to draw further rectangles in the current session, the sizes you entered
will be remembered.
If you want to change the rectangle size, click in the Rectangle dialog and change the X
and Y dimensions. If you want to create a rectangle using snapped positions, remove the
X and Y entries to leave them blank.
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■ Ellipses
The Construct>Geometry 2D>Ellipse command creates elliptical area items.
To create an elliptical Line item, first create the elliptical area item, then select it and use
the Alter>Unfill command.
1 Select the Construct>Geometry 2D>Ellipse command.

2 If you want to draw a circle, click the Force X equal to Y checkbox.
3 Click to define two diagonally opposite corners of an imaginary rectangle bounding the

ellipse. As you do so you will see the ellipse rubberbanding into shape.

◆ To draw an ellipse of a specific size

1 Select the Construct>Geometry 2D>Ellipse command.
2 Type in the sizes for the X dimension and the Y dimension, and press Enter. (In the

case of an ellipse, these dimensions are the semi-major and semi-minor axes.) 
Alternatively, enter just one dimension, leaving the other as Use Snaps. This enables you
to draw an ellipse with one dimension fixed, the other defined by the second screen
position you click.

3 You will see an ellipse of the chosen size centred on the cursor. Click a position on
screen. One of the following nine points on the imaginary bounding rectangle will be
placed at this point:

4 Click a second screen position. The direction of this position from the first is used to
locate the ellipse (you will see this happening as you move the cursor towards the sec-
ond point before clicking it).

first position

second position
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5 If you proceed to draw further ellipses in the current session, the sizes you entered will
be remembered.
Alternatively, if you do not want an ellipse of this size, click in the Ellipse dialog and
change the X and Y dimensions. If you want to create an ellipse using snapped positions,
remove the X and Y entries to leave them blank. 

■ Points and shapes
A point is a single vertex which itself has no dimensions but can be positioned in 3D space.
Points usually have a shape assigned to them. A shape is a pre-defined symbol. Cadcorp SIS
provides a number of pre-defined shapes which are named objects stored in the (standard)
library. You can also create your own shapes, which can consist of any group of line, area,
bitmap, or box text items.
Points can also be seeds for polygons and chains.

◆  Placing points and shapes

When constructing point items, if the dataset scale is inappropriate, Cadcorp SIS normally
warns you and gives you the opportunity to change it. This is most likely to happen when
constructing points on an internal dataset, because these take an initial dataset scale of 1
when they are created.
If you do not want to see the scale warning, use the system option Suppress scale warnings
(Options tab, Tools>Preferences...).
1 Select the Construct>Geometry 2D>Point... command. 
2 If you are using Cadcorp SIS Map Editor or Cadcorp SIS Map Modeller you see the fol-

lowing Point dialog:

If you want to place the point in 3D space, type in a Z height (otherwise points are placed
on the XY plane).
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Select a shape from the drop-down list by double-clicking its name. Shapes are listed
here by name. As you select one, you are shown what it looks like:

If you do not want a point to be visible, assign the Blank shape to it. This shape is not
displayed on the screen (except when selected), nor is it printed. Alternatively, you
could use any shape with a blank or invisible pen and brush assigned to it. 
If you want to select a shape by its graphical appearance, click the More... button:
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If you are using Cadcorp SIS Map Viewer or Cadcorp SIS Map Manager, the Point dialog
is not displayed. Place your points and then alter their shape by selecting them, and using
the Styles toolbar.

3 Click a position on the screen to locate the point, or type in the co-ordinates of its posi-
tion (using this method you can place the point in 3D space).

4 Continue placing points. If you want to change the shape used, or the Z height, do so in
the Point dialog before placing the point.

◆ Multi-point items

A multi-point item is a single item consisting of more than one point, all the constituent
point items having the same shape and style. You can create a multi-point item by first
selecting a point item, then using the Alter>Add Geometry command to add further
points to it.
A multi-point item can be manipulated as a single item. The shape used to display the
points in the multi-point item is that of the original point item (the one to which other point
items were added). 

◆ Creating shapes

A shape may consist of any combination of line items, area items, box text and bitmaps
(but not point text and topological structures; although you can use these items, they will
not be displayed).
1 Open a new, empty SWD.
2 Change the projection to the Paper Projection using the Map>Co-ordinate systems...

command, or the Position toolbar.
3 Create the graphics that make up the shape. You could use the Construct 2D commands

to create the shape, or you could use a bitmap. If you are using a bitmap for a logo, you
may wish to resize the bitmap using the Alter>Move Items command, so that it is the
correct size. Use the measure functions to obtain the correct size.

4 Select all the graphics which make up the shape. 
5 Select the Construct>Shape... command. 
6 Click a position for the centre of the shape. The centre is the position by which you will

later place the shape. 
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7 In the Save Shape As dialog, type in a folder name if you want to create a new folder
(you will need to do this if there are no other shapes in the enabled libraries), or select
an existing folder name if appropriate. All shape folders in all enabled libraries are
listed.

8 Enter a name for the shape. Shapes are named objects.
The shape is then stored in the current library. 

9 If you wish, you may delete the graphics used to form the shape, as these are no longer
required.

◆ Creating complex shapes

Shapes can be extremely complex objects, making extensive use of the advanced capabili-
ties of Cadcorp SIS such as scale thresholds and levels. For example, it is possible to create
shapes which appear differently at different scale thresholds. 

◆ Ordnance Survey symbols (UK specific)

Ordnance Survey files contain locations for symbols of ordnance benchmarks, pylons, flow
arrows, etc. These Ordnance Survey shapes are stored with appropriate names (eg Bench
Mark, Pylon, Flow Arrow) in the OS DNF, OS NTF and OSNI NTF folders in the (stand-
ard) library.
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■ Text
There are four different types of text item:

Cadcorp SIS Map Viewer can create only point text items. Line text items can be created
only in Cadcorp SIS Map Editor and Cadcorp SIS Map Modeller.

◆ Creating point text

When constructing point text, Cadcorp SIS normally warns you if the dataset scale is inap-
propriate and gives you the opportunity to change it. (This is most likely to happen when
you are constructing point text on an internal dataset, because these take an initial dataset
scale of 1 when they are created.) 
If you do not want to see the scale warning, use the system option Suppress scale warnings
(Options tab, Tools>Preferences...).
1 Select the Construct>Text>Point... command.
2 In the Properties of Text dialog, you can set the following properties (any of these can

be changed later):
• font to use
• height in points (➲page127, Point text height)
• whether bold, italics or underlining is required

point text point text is given a height in point sizes. It always appears at a given point
size when printed.

box text box text is created in real world units. When printed it maintains its propor-
tions to the surrounding graphics.

label text label text provides a means of labelling items, being placed with a line
drawn to the item it is labelling. It is created in real world units, like box
text, and when printed maintains its proportions to the surrounding
graphics.

line text line text follows the path of a line item.
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• alignment (whether left, centre or right justified)

3 In the Text dialog, select whether the chosen font, height and horizontal alignment
should be used. If you choose not to use them, the text is displayed here using defaults,
but it will still use the selected properties when the completed text item is placed in the
map window.

4 Type in the required text, using the Enter key for a new line. You can also paste text
from the clipboard into this box using the Ctrl+V key combination, or Paste on the
local menu.

5 Click OK when you have finished entering text. Attached to your cursor is the text
item. If the zoom factor allows it, you will see a box indicating the size the text item
will be.

6 Click the screen position where you want to place the alignment point of the text item.
7 Either:

8 If you cannot see the text item on the screen, it is because it is too small or too large for
the current display scale. The Map>Zoom>Selection command will display it. You
may have to redraw your screen (Map>Redraw or F5) before the text appears.

• press Enter to place the text string 
horizontally

• click a second point, which defines the 
angle of rotation of the text

Point text

Point te
xt

P1

P2
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◆ Point text height

Point text height is set in point sizes, like text in word-processing. There are 72 points to
the inch. One point is approximately 0.01389 inches, or 0.353 millimetres. 

Height of point text and dataset scale
Point text always appears at the same size (its point size). Dataset scale does not affect it,
but as dataset scale does affect most other graphics on the overlay, you must consider it
when using point text. Consider these two examples:
• If the dataset scale was 1 (1:1), buildings might be something like ten or twenty metres

long. 10-point text would still be only 3.5mm high, and so would appear tiny next to
the buildings.

• If the dataset scale was 1250, a 20m long building would be scaled to 16mm. 10-point
text would still be 3.5mm high, and so would appear more in proportion.

To give point text a fixed screen height
Point text with a fixed screen height remains the same height (in pixels) on the screen, no
matter how much you zoom in or out. Fixed height text (or “zoom independent text”) is
useful in such circumstances as labelling a keymap, or labelling symbols.
To make your point text fixed height, use a negative value in the Height (pts) box. For
example, a value of -10 would produce text at point height 10, irrespective of scale.
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■ Selecting and editing items
There are many ways to select items. You can click on single items to select them,
Shift-click to build up a multiple selection, or draw a rectangular area to select all items
inside. More powerful selection techniques include:
• fence - selects items within a polygonal fence
• buffer - selects items within a certain distance of a line
• class - selects items of the same type
• locus - selects items that pass spatial tests
• formula - selects items with particular values for certain attributes
• filter - controls which items on an overlay can be selected
When editing items, they must be editable or hittable, depending on the editing function
chosen.
See the Cadcorp SIS User Guide for full details.

■ Deleting items
1 Select the items to be deleted. They must have a status of editable.
2 Either select the Edit>Delete command or press the Delete key on the keyboard. 
If the selected items are a mixture of editable and hittable items, only the editable items
will be deleted.

■ Moving, rotating, scaling, and mirroring items

◆ Moving single or multiple items 

1 Select the items.
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2 Select the Move Items command (local menu or Alter main menu). This causes 9 han-
dles to be superimposed over the selected item(s). These handles can be used to pick up
and move the selected item(s).

3 The Move Items dialog box also opens. You can use this to:

• scale the item(s). A value greater than 1 increases the size, less than 1 decreases the
size.

• create a mirror image of the item(s) around its/their Y axis
• rotate the item(s). A positive value will rotate it anticlockwise (in degrees), a negative

value will rotate it clockwise (in degrees). 
This command is not available in Cadcorp SIS Map Viewer.

◆ Rotating items: Alter>Rotate

Use the Alter>Rotate command to rotate selected items.
1 Select the item(s).
2 Select the Alter>Rotate command.
3 Click the first position. 
4 Drag the item(s) about their centre point.
5 Click a second position to fix the item(s) in their new location.

◆ The Alter>Stretch command (rotating and scaling)

Use the Alter>Stretch command to rotate selected items, or rotate and scale them at the
same time.
1 Select the item(s).
2 Select the Alter>Stretch command.
3 Click the first position.
4 Click a second position to fix the item(s) at their new size.

■ Copying items

◆ Copying editable items

1 Select the items.
2 Select the Move Items command (local menu or Alter main menu).
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3 Use the Move Items dialog box (➲Chapter 12: “General editing techniques”, Moving
single or multiple items, page129), but while carrying out the command keep the Ctrl
key pressed down. This creates a copy of the item(s) on your map.

4 Keep the Ctrl key pressed down and repeat the command(s) for multiple copies.

◆ Replicating items

Both editable and hittable items may be copied using the Edit>Replicate command. This
command creates an editable copy of the selected item(s) in a user-defined overlay without
using the clipboard. The new copies are placed in exactly the same spatial location as the
originals.
Edit>Replicate is useful for copying items between co-ordinate systems.
1 Select the item(s). 
2 Select the Edit>Replicate command. 
3 In the overlay to replicate to dialog, you can choose the overlay in which your repli-

cated data will be placed, or you can create a new internal overlay for the data.
4 The new copy remains selected until you carry out another operation, so you may

immediately reposition it if required.
The same result could be obtained by using the Edit>Copy and Edit>Paste commands.
However, when copying large amounts of data, it is preferable to use Edit>Replicate.

■ Merging geometry: creating multi-geometry
Multi-geometry items are a collection of point items, line items and/or area items. They are
created from existing items in the following ways:
• by adding existing items together using the Alter>Add Geometry command 
• by editing existing items, using a Boolean method, to produce a new item

■ Merging geometry: using Boolean methods
All types of geometry can be merged together using Boolean editing operations to produce
new geometric items. Some Boolean methods produce multi-geometry items.
The new item takes on the properties and attributes of the dominant item, so the commands
sometimes show a dialog for selecting which item should be dominant. This does not
appear if a choice is not necessary (for instance, if all selected items have the same style,
data and height).
The height of the new item is the height of the dominant item, or the height of the dominant
item’s origin if the dominant item does not lie on a plane parallel to the XY plane.

■ Breaking down complex items
Items with complex geometry can be broken down into simpler, separate items using the
Alter>Decompose command. You must first select the item(s) to decompose, then the
command. For example, multi-geometry can be broken down into separate items, or a TIN
can have each face converted to a separate area item.
Any attribute data stored with the original complex item will be lost.
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■ Simplifying items
The OpenGIS Simple Features specification contains rules for determining what can be
classed as simple geometry (these are summarised below). When Cadcorp SIS simplifies
geometry it follows the OpenGIS rules, changing the original geometry as little as possible.
It also keeps any data associated with the item, as far as it can.
Examples of when simple geometry may be required are:
• when exporting data for use in other programs. For example, lines with self-intersec-

tions can cause problems in other systems.
• when carrying out geometry tests. Many of these (for example, finding items which

intersect with the selected item) rely on the items tested being simple.
You must first select the items to simplify, then select the Alter>Simplify command. This
converts the selected item(s) to the OpenGIS “simple” form (eg by removing
self-intersections).
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■ Introduction
The Query Wizard helps you look for items on an overlay. You can look for:
• items with specific values for one or more attributes (eg house numbers in a certain

range, or only those items which are Road Centerlines) ➲Chapter 14: “Properties”
• items whose shape or location has a spatial relationship with the currently selected item

(eg inside or overlapping)
• a combination of the above
The Query Wizard can either:
• create a new overlay showing the results of the query (➲Chapter 9: “Working with

overlays”)
• set the overlay filter or locus so that items matching the query are included 
You can also have the query set a filter or locus, so that you can use the items found by the
query as the basis for further operations.

■ Query Wizard
Before you start the Query Wizard, select an item if you want to look for other spatially
related items. To start the Query Wizard, do one of the following:
• choose Edit>Query Wizard...
• choose Query Wizard... from the local menu in the display view tab in the workspace

window
• click the Query Wizard icon on a toolbar
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1 If you have not indicated the overlay, choose the overlay you want to query. (If you use
an overlay’s local menu, or you have only one overlay open, this step is not required.)

Then click the Next button. 
2 You can either:

• construct an attribute query, or
• construct a spatial query.
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Construct an attribute query by selecting a column from the list on the left, an operator
from the icons in the middle, and a value from the list at the right.

The Typical Values list shows some (but not all) of the values for the column you have
selected. Notice that your selection from the Columns list is converted into the correct
form for the query.
You can also type a query directly into the Query field.
If you selected an item or items before starting the query, you can create a spatial query
using the selection. Tick the checkbox next to The currently selected item must… and
then choose the test required. ➲table on page136, Geometry tests for finding items.
Choose also whether you want to test against the origin, extents, or geometry of the
found items. The geometry of an item is, for an area item, its area; for a line item, its
length; for a point item, its x and y co-ordinates. Some of the spatial tests operate
differently depending on which of the origin, extents, or geometry is used.

3 Click the Next> button.
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4 Review the results of the query, and decide how you want to use the results.

Choose the Create a new overlay radio button to create an overlay using the query as the
overlay filter and/or locus. The data will not be copied, just drawn again in another
overlay, whose name you supply in the text box.
Or choose the Set the overlay filter/locus option, to use the query as the overlay filter
and/or locus.

5 Click the Finish button to continue.
If you choose the Set the overlay filter/locus option, the query is dynamic: if an item’s
properties or geometry changes, it can drop out of, or become included in, the filter and/or
locus. To cancel the query, you will have to reset the filter and/or locus of the overlay.

■ Spatial tests
Use the following tests for finding items.

❏ Geometry tests for finding items  
Test Finds items if 
contain their interior is completely inside the selected item

be disjoint from they are completely separate from the selected item and their bounda-
ries do not touch

intersect if they have a point in common with the selected item (they must not
be disjoint)
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The following tables describe the spatial tests used in Cadcorp SIS.
For example, in the first row, you have selected the rectangular area item, and you want to
find the square area item which lies inside it. You can use the Contain, Cross, and Intersect
tests. In these tables, the double arrow (↔) at the top of a column indicates that the test
item is also returned in the results. So, if you use Contain or Intersect, the test item (a rec-
tangle in this example) is returned.

cross line items will be found if they intersect the selected item without
being tangential. Other items will be found if their interior intersects
with the interior of the selected item and the selected item goes out-
side the found item.

be equal to if their geometry is the same as that of the selected item

overlap If the selected item is a line item, another line item will be found only
if the two line items are tangential, and if neither contains the other.
With other item classes, an item will be found only if its interior inter-
sects with that of the selected item and neither contains the other.

touch if its interior is disjoint from that of the selected item and if their
boundaries intersect

be within if the interior of the selected item falls completely within it

be crossed by line items will be found if they intersect the selected item without
being tangential. Other items will be found if their interior intersects
with the interior of the selected item and the found item goes outside
the selected item.

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔

 

✔ ✔ · · · ✔ · · ·

❏ Geometry tests for finding items  (Continued)
Test Finds items if 

selection

looking for
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Selected item: area - candidates to find: areas
In this table, the selected item is an area item, and the tests are looking for area items.

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔

 

✔ ✔ · · · ✔ · · ·

 

✔ ✔ · · · ✔ · · ·

 

✔ ✔ · · · ✔ · · ·

 

· ✔ · · · ✔ ✔ ✔ ·

 

· · ✔ · · ✔ · · ·

 

· · · ✔ · · · · ·

 

· · · · · ✔ · · ✔
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Selected item: area – candidates to find: lines
In this table, the selected item is an area item, and the tests are looking for line items.

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔

 

✔ ✔ · · · ✔ · · ·

 

✔ ✔ · · · ✔ · · ·

 

✔ ✔ · · · ✔ · · ·

 

· ✔ · · · ✔ ✔ ✔ ·

 

· · ✔ · · ✔ · · ·

 

· · · ✔ · · · ·

 

· · · ✔ · · · · ·
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Selected item: area – candidates to find: points
In this table, the selected item is an area item, and the tests are looking for point items.

Selected item: line – candidates to find: lines
In this table, the selected item is a line item, and the tests are looking for line items.

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔

 

✔ ✔ · · · ✔ · · ·

 

· ✔ ✔ · · ✔ · · ·

 

· · · ✔ · · · · ·

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔

 
· · · ✔ · · · · ·

 
· ✔ · · · ✔ · ✔ ·

 
· · ✔ · · ✔ · · ·

 
· · ✔ · · ✔ · · ·

 
· · ✔ · · ✔ · · ·

 
· ✔ · · · ✔ · ✔ ·

 
· · · ✔ · · · · ·
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Selected item: line – candidates to find: areas
In this table, the selected item is a line item, and the tests are looking for area items.

 
· ✔ · · · ✔ · ✔ ·

 
· · · · · ✔ ✔ · ·

 
✔ · · · · ✔ · · ·

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔

· · · ✔ · · · · ·

· · ✔ · · ✔ · · ·

· · ✔ · · ✔ · · ·

· · ✔ · · ✔ · · ·

· ✔ · · · ✔ ✔ ✔ ·

· · · ✔ · · · · ·

 
· · ✔ · · ✔ · · ·

 
· · · · · ✔ · ✔ ✔

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔
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Selected item: line – candidates to find: points
In this table, the selected item is a line item, and the tests are looking for point items.

Selected item: point – candidates to find: areas
In this table, the selected item is a point item, and the tests are looking for area items.

Selected item: point – candidates to find: lines
In this table, the selected item is a point item, and the tests are looking for line items.

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔

· · · ✔ · · · · ·

✔ ✔ · · · ✔ · · ·

· · ✔ · · ✔ · · ·

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔

· · · · · ✔ · ✔ ✔

· · ✔ · · ✔ · · ·

· · · ✔ · · · · ·

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔

· · · ✔ · · · · ·

· · ✔ · · ✔ · · ·

· · · · · ✔ · ✔ ✔

· · · ✔ · · · · ·
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Selected item: point – candidates to find: points
In this table, the selected item is a point item, and the tests are looking for point items.

■ Other techniques for finding items
You can also use the Find command to look for and select items.
If you want to find grid references, use the Map>Zoom>Grid Reference... command. 
➲Chapter  7: “Querying the data in the map window”, Finding grid references, page86

Test Contain Cross Touch Disjoint Equal Intersect Overlap Crossed by Within

↔ ↔ ↔ ↔

✔ · · · ✔ ✔ · · ✔

· · · ✔ · · · · ·
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■ What are properties?
The properties of an item contain information that describes that item. Every item in Cad-
corp SIS has properties that are shown in the workspace window property view when you
select an item.
Every property has a name, a description, and a value.

Name
The name of a property follows the rules used for computer language variables. The prop-
erty name always ends in a special character indicating its type: either “$” (string property),
“#” (floating point property), or “&” (integer property).

Description
The property description is a word or phrase that indicates its meaning in normal language.
When you use the Cadcorp SIS user interface you are shown the property description, but if
you are programming, you must use the property names to avoid ambiguities.

◆ System properties

The system automatically supplies properties for every item. These properties are called
system properties and you can recognise them because their names always start with an
underscore character.
These properties hold such information as the pen to draw the item with, the length of a line
item, and the point height of text items. 
Properties, both system and user-defined, are used when building formulae.

◆ Creating and editing properties

You can also add your own properties to any editable item as attribute data. To avoid confu-
sion you cannot use the underscore character as your property name’s first character.
Some system properties can be edited, eg an item’s pen. If the property is editable it will
appear with a white background on the Property dialog (if using standard Windows colour
schemes). If not editable it will appear on a grey background.
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The Edit>Properties… command shows a tabbed dialog with advanced controls for edit-
ing Item properties.

■ How properties are displayed
To display the Properties dialog, select the item(s), and then do one of the following:
• choose Properties… from the local menu
• choose the Edit>Properties command
• click the Properties button in the Styles toolbar
The Properties dialog usually shows five tabs (except for some objects such as photo items
and text): Style, Schema, Attributes, Geometry, and All.

The Style tab details the pen, brush and sshape styles, if there are any feature tables associ-
ated with the data, and the feature code ➲Chapter 20: “Feature tables”. It lists the layers
present, their level and the minimum and maximum scale.
The Schema tab consists of a list of columns. Each of these will appear in the table window
and each has a formula that is used to evaluate values on items. The formula is listed in the
Property column.
The Attributes tab provides additional data to the system properties. Attribute data is
non-graphical data attached to graphical items. Attribute data can be added only to
unlinked datasets or copies of linked datasets. Original data cannot be altered.
The Geometry tab provides information relating to the geometry of the selected item.
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The All tab lists all the information available on the item(s) selected including the informa-
tion given in the Style, Schema, Attributes and Geometry tabs.

On the Schema, Attributes, Geometry, or All tabs, the property description and value are
listed. To see the name of the property, select the property description, and choose Proper-
ties from the local menu. A dialog shows the property’s description, property, and value,
which you can copy for other uses (eg when using formulae).
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You can access the properties of the overlay from the Overlays dialog: 

This operates in the same way as the Attributes tab of the Properties of Item dialog.

■ Editing properties
You can edit properties in the Value column using the following methods:
• double click. This is available where there are two options (eg True/False).
• click, then type in a value (eg the Maximum scale property)
• click, then click on the More button which appears, then select an option from the

drop-down list (eg the brush property)
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■ What are themes?
Themes use graphic techniques to indicate visually on the map base the distribution of data.
These techniques include bar charts, pie charts, labels, colours, and symbols to show popu-
lation information, size of housing, residential or commercial properties, and so on. If the
data includes height information, the theme might show direction of flow, or ground relief.
Themes in Cadcorp SIS use information taken from item attributes or properties, or from
formulae that use items or properties. When these attributes or properties change, the
themes show the change.
The different types of theme are listed below and described later in this chapter. Except
where indicated, the themes are annotation themes, ie they annotate, or add graphics to,
items.
• Themes which illustrate the value of a single property value (eg their size).

• dot density 
• extrude 2D items in 3D views
• graduated 
• individual values (a styling theme)
• labels 
• ranges (a styling theme)

• Themes which compare multiple attributes (such as the male population against the
female population).
• bar charts
• pie charts 

• Themes which are specialised for use with certain item classes. See the indicated chap-
ter for details.
• Contour (creates contour lines over TIN items) 
• Flow (draws flow arrows over TIN items) 
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• Relief (a styling theme used to indicate ground relief on grid items) 
• Feature code (creates an Individual Value Theme based on the feature code) ➲Chapter

20: “Feature tables” 
• Topology (shows the structure of topology, including flow directions and turning rules

at junctions) 

■ The New Theme Wizard
The New Theme Wizard is accessed by:
• the Map>Add Theme... command, or its icon 
• the Add... button on the Themes tab in the Overlays dialog (select the required overlay

first)
• the Add Theme... command on the default local menu (accessed by right-clicking in the

map window when no items are selected)
• the Add Theme... command, found on the SWD local menu and the overlay’s local

menu on the theme view tab of the workspace window
In the New Theme Wizard you should select an overlay to theme, then select the type of
theme to use. 

The different types of theme are described in the following sections. 
Each overlay can have an unlimited number of themes.

■ Using formulae
Themes use the properties of items to annotate those items. Sometimes just the value of a
single property is used, but often you will want to base your theme on a formula which
combines properties or carries out a calculation on the properties.
You will be offered a choice from the properties or formulae contained in the overlay
schema, but you can also create your own formulae. 
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■ Bar charts
This theme uses bar charts to compare the values of several properties. The height of the
bar chart blocks are proportional to the value of a chosen property or formula.
The following example uses some Australian census data to compare the numbers of differ-
ent ethnic groups in each state. 
1 Start the New Theme wizard using one of the methods described in the earlier section,

and select the theme type Bar Charts.
2 In the Select Properties/Formulae dialog, either: 

• from the list on the left, select the properties to compare, clicking on the right chevrons
button to add them to the list on the right

• in the field at the bottom left, type in a property or formula (using the Formula button
to access the Formula dialog if required). Click on the right chevrons to add this to the
box on the right.

In this case we have chosen to compare the number of Aboriginal, Asian, and Caucasian
people in the population.
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3 In the Bar Chart Styles dialog, choose the parameters for the bar chart’s appearance and
placing:

4 The Alignment option allows you to choose where the bar chart should be placed in
relation to the item’s centre, or hook point (the default is Middle Centre). Use the Hori-
zontal checkbox to align the blocks horizontally.

5 Choose a width for the bars in millimetres (all bars use this same width), and a method
by which their height, in millimetres, is determined.

6 In the Block styles area, choose a title for this entry in the Legend (Title option), and
the pen and brush to be used for displaying each selected block.

7 The Scales... button allows you to choose the scale thresholds between which the theme
is displayed.

At Value This is the base value around which the block is scaled up or down. So
if an item has this value, it will be represented by a block of the height
shown in the Height field. If the value is less than this, the block will
be shorter; if greater, the block will be taller. The means of scaling the
block height is determined by the chosen Graduated by option.

Graduated by

• Square root The block height is proportional to the square root of the ratio (this is
the ratio of the evaluated block value to the At Value). 

• Linear The block height is proportional to the ratio. 

• Log (base 
10)

The block height is proportional to the log (base 10) of the ratio when
the value is greater than or equal to the value given in at value, and is
proportional to the ratio when the value is less than the value given in
At Value. 
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8 If you are using a legend, ➲page 157, Legends. 

■ Graduated
This theme uses shape items, graduating their size to indicate the value of a given property
or formula - the higher the value, the larger the shape. 
The properties of any class of item can be used to create a Graduated theme. If the items are
point items, the shapes are placed at the point. If the items are not point items, the shapes
are placed at the item’s origins.
As with the worked example for the Extrude 2D items in 3D views theme, we are going to
use the area value of some buildings. This time, the area value will be indicated by the size
of the shape - the larger the area value, the larger the shape.
1 Start the New Theme Wizard using one of the methods described in the earlier section,

and select the theme type Graduated.
2 In the Select Properties/Formulae dialog, put in either: 

• a property name (typing it in or selecting from those offered in the box below) 
• a formula (using the Formula button to access the Formula dialog if required)
In this case we are using the formula Sqrt(Abs(_area#)).

3 In the Graduated Style dialog, choose a shape to represent the area value, and the pen
and brush to be used for it.
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4 Use the Settings section to determine how large the shape will appear. The options are:

5 If required, use the Scales... button to set the scale thresholds between which the theme
will be displayed.

6 If you are using a legend, ➲page 157, Legends.

■ Labels
The Label theme attaches a text label to all themed items. The text of the label is the value
of a property or formula. 
When labelling line items, you can choose where on the line item to place the label, and
whether or not the label should be rotated (either the complete label, or each individual
character). In this way you can label contour lines.
If you explode a label theme, you can edit each label individually. The Explode command
is on the local menu of the theme in the theme view. Any exploded theme will become an
internal overlay.
In this example Ordnance Survey Address Point data is used. A label will be put against
every business address on the map base, using the property Organisation Name, or ON$
(residential properties do not have an Organisation Name).
1 Start the New Theme and select the theme type Labels.
2 In the Select Properties/Formulae dialog, put in either: 

• a property name (typing it in or selecting from those offered in the box below) 
• a formula (using the Formula button to access the Formula dialog if required)

For value This value is the base value around which the shape is scaled up or
down. So if an item has this value, it will be represented by the
shape at its normal size. If the value is less than this, the shape will
be smaller; if greater, the shape will be larger. The means of scaling
the shape is determined by the chosen Graduated by option.

Graduated by

• Constant All shapes are the same size, ie, the size of the shape itself. 

• Square root The shape size is proportional to the square root of the ratio (this is
the ratio of the evaluated formula value to the For value).

• Log (base 10) The shape size is:
• proportional to the log (base 10) of the ratio when the value is

greater than or equal to the value given in For value
• proportional to the ratio when the value is less than the value

given in For value.
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In this case we select Organisation Name from the list: 

You will see the Label Styles dialog, which defines how the labels will look: 
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3 In the Label style area, select the properties of the text; its font, alignment, height, style
(bold, etc) and pen. If you choose opaque text, you can select a brush for the back-
ground. You can also make the text fixed height (ie it always appears the same size on
screen no matter how much you are zoomed in and out). 

4 In the Label settings area, give an offset (in text points) to offset the label from the
item. A connecting line is drawn from the label to the item. You can also choose
whether or not labels may be allowed to overlap.

5 When labelling line items, set the parameters in the Label settings for lines area. You
can choose where on the line the label should appear, and whether the label should be
rotated to follow the line.

6 In the following example, the line item’s _dataset$ property is placed at the start of
each line. In the second case the label is also rotated:

If you choose the Along option, each individual character in the label is rotated as it is
placed along the line (as it is with line text).

7 If required, use the Scales... button to determine the scales between which this theme
will be displayed.
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You will now see that all buildings with an Organisation Name property have a label show-
ing that name.

■ Legends
A legend can be created with the following theme types:
• Bar Charts
• Contour
• Dot Density
• Flow
• Graduated
• Individual Values
• Pie Charts
• Ranges
• Relief
• Topology

◆ Styling a legend

Legends are created automatically for the theme types listed above. Use the Legend button
as you create or edit a theme to specify how the legend will look.
In the Legend dialog you can create a title and subtitle for the legend, and define how the
text throughout the legend will look (font, height and styles). Use Pen to define the colour
of the legend text, and if you are using the Opaque style, use Brush to determine the back-
ground colour for the legend backdrop. 
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All print template ‘furniture’ (scale bars, legends, north points, and so on) has a default
Level value of 1. The photo item in the print template has a default Level of 0. This means
that, by default, any items you add to the print template should appear on top of it when
you print. Therefore, when you are styling a legend to add to a print template, if you leave
this as (implicit), it means that the Legend box should always be drawn on top of the map
graphics. ➲Chapter 10: “Overlays, levels, and commands”

◆ Where you use a legend

A legend is shown at the bottom of the theme view tab in the workspace window. It can be
placed on a print template which contains overlays that are themed. 
➲Chapter 19: “Printing: print templates”

■ Using your themes
Themes can be manipulated on the Themes page of the Overlays dialog (first select the
overlay and the theme concerned), or on the theme view tab in the workspace window.

◆ Viewing a theme

Use the local command Visible in the workspace window, or the Disabled option on the
Overlays dialog, to determine whether or not the selected theme is displayed. Alternatively,
click on the theme icon in the theme view to turn it on and off.

◆ Editing a theme

To edit a theme, use the Properties... local command in the workspace window, dou-
ble-click on the theme in the workspace window, or use the Edit... button in the Overlays
dialog.

◆ Deleting a theme

To delete a theme, use the local command Delete in the workspace window, or the Remove
button on the Overlays dialog.
If it has been saved, you can recall it later.
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◆ Changing the order of themes on an overlay

Use the Promote and Demote local commands in the workspace window, or the up and
down arrow buttons on the Overlays dialog. 
The order of themes is important because, when Cadcorp SIS decides which pen, brush and
shape to use when drawing an item, the themes are checked in order. So you could, for
example, theme polygon items using a Range Theme for the brush (which does not change
the shape) and use an Individual Value theme to set the shape.

◆ Converting a theme to editable items

The local command Explode in the workspace window, or the Explode button in the Over-
lays dialog, can both be used to convert Bar Charts, Pie Charts, Labels and Graduated
themes into editable items. These items are put on a new internal dataset.
Bar Chart and Pie Chart Themes form group items, Label themes are converted to label text
items, and the Graduated theme forms point items. These items are no longer linked to the
overlay, and will not update if the data is changed.

◆ Saving themes

Themes can be saved by using the local menu on the theme view tab. You will be prompted
for a folder and name for your theme and it will be saved as a named theme in the current
library. Once saved, its properties can be edited and it can be applied to other overlays
using the New Theme Wizard.
You can see the Saved Theme icon if you scroll down to the bottom of the Select Theme
options. Double-click on the Saved Theme icon to access all the themes that you have
created.

◆ Copying and pasting themes

Themes displayed on the theme view tab can be copied and pasted from one overlay to
another using the commands on the local menu. To do this, choose Copy from the theme’s
local menu, then choose Paste Theme from the target overlay’s local menu.

◆ Save colour-set

For themes which use colour-sets (the Relief Theme) you can save the colour-set for use on
another occasion. Use the Save Colour-set command on the local menu. It will be saved as
a named theme in the current library. Once saved, its properties can be edited, and it can be
applied to other overlays using their properties.
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■ Introduction

◆ Flat file storage

Traditionally, ‘flat files’ were used to store geographical data. The lack of an agreed indus-
try standard for flat file storage allowed GIS vendors to develop their own mutually
exclusive formats. Over time, some of these formats became more popular than others and
were accepted as de facto standards for transferring geographical data within the GIS com-
munity. As the use of GIS and data volumes increased, the flat file formats were pushed to
their limits.
The inherent drawback with flat files is that they are not scalable and impede data sharing
in a multi-user environment. The flat file structure is not suited to allowing users to access
part of the data; the entire file has to be opened. This aspect limits the maximum size of the
flat file (within the limits of the PC’s RAM) and does not allow for efficient memory usage
on the computer that is used to open the file. Some of these problems have been partially
alleviated with the introduction of hybrid flat files. These are flat files which behave in a
way similar to databases, in that they allow multi-user access and multi-user editing, but
they cannot match databases for performance and scalability.

◆ Databases

Databases were the answer to the corporate data sharing dilemma and limitations of the flat
file’s size and data access. Data is stored in a centrally-managed repository known as a
relational database management system (RDBMS). The RDBMS manages multi-user
access to the data and allows concurrent users to manipulate data. Client machines retrieve
only the portion of data that is actually required. 
Databases have advanced significantly over the previous decade, and are now capable of
managing complex data types such as graphical data. Most databases are capable of storing
graphical data in a data type commonly referred to as a Binary Large Object (Blob). In this
situation each geographical item is stored as row within a database table, which allows the
RDBMS to manage it in a multi-user environment. Some databases have advanced further
and can store geographical items in an intelligent manner. The ‘intelligence’ lies in the
database’s capability to ‘understand’ the nature of the spatial item being stored and allow it
to be manipulated within the RDBMS. 
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Oracle Spatial is one such example. Oracle Spatial has built-in GIS functionality which
allows for spatial computations such as calculating the area of a geographical feature
known as a polygon, or calculating the distance between two real-world features stored in a
database.

■ Cadcorp SIS
Cadcorp SIS provides you with the ability to store, retrieve, and manipulate geographical
data in a variety of industry-standard databases such as Oracle, Microsoft SQL Server,
Microsoft Access, Informix, and so on. This ability brings the added power and security of
a RDBMS to GIS. Also, Cadcorp SIS can read alphanumeric data associated with geo-
graphical items.
Attribute data associated with geographical data can be stored within the feature itself or as
a separate column within the same database table row. Storing the attribute data in a sepa-
rate field allows the data to be interrogated using the industry-standard database query
language SQL (pronounced ‘sequel’).
Corporate users may want to interrogate alphanumeric data without needing to reference
the actual geographical feature associated with the data. In this situation it may be advanta-
geous to keep the geographical data separate from the attribute data and link the two via
unique keys (unique keys are columns in database tables that contain unique values and are
designed to allow to set of data to be linked in a way which maintains relational integrity).
Cadcorp SIS allows users to bring attribute data from one table and join it to geographical
data from another table. ➲page166, Linking table data to overlays

◆ Accessing attribute data – the named table 

Cadcorp SIS can read in alphanumeric data from a variety of databases. Check with your
database administrator to ascertain which database your data is stored in and whether the
appropriate database connectivity software has been loaded onto your client.
Data is made available as a read-only object called a named table. The data held within a
named table is a copy of the database table. For ease of use, data in named tables can be
viewed in a spreadsheet format (columns and rows).
Cadcorp SIS uses a wizard-style interface to guide you through the process of creating a
named table. You can create a named table from complete, partial or multiple database
tables. The wizard allows you to specify an optional SQL WHERE clause: this clause is
incorporated into the underlying SQL generated to retrieve the desired data. The SQL
WHERE clause can be used as a mechanism for filtering data. This reduces the amount of
data read from the database and ultimately transferred across the network to the client. The
SQL WHERE clause also facilitates the retrieval of data from multiple tables; a table join
has to be specified to enforce relational integrity between the database tables.
If you have to create named tables from multiple tables, you should consult your database
administrator to ascertain whether it would be expedient to create a database view for the
tables on the database.
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◆ Creating a table view

To create a table view:
1 Choose the New command from the File menu, select named table from the New dia-

log, then click Next.

2 You are now be presented with the Select Database Type dialog. Select the appropriate
type of database connection and click Next. 

In this example we are creating a direct connection to a SQL Server database.
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3 Enter the appropriate information to connect to your database and click Next. If in
doubt contact your database administrator.

4 You will be presented with the Recordset dialog, which displays all the tables that are
available to you. Select the desired table from the Database Table/Columns list and
click the Add button. This creates a named table from all the columns in the table. 

5 To create a named table from a limited number of columns, click the plus (+) sign on
the left hand side of the table name, then select the desired column and add it to the
Selected Columns section. We recommend that a column containing a unique identifier
for the data is included in the named table.

To restrict the number of rows in the named table, you can add a SQL WHERE clause.
For example, in a GIS system that stores all the land parcels in the UK, you may be
interested only in creating a named table based on land parcels that are used to grow
wheat. In this situation, an appropriately worded SQL WHERE clause will remove data
that is not required.
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The use of SQL WHERE clause ensures that system resources are used efficiently and
the impact on the database is kept to a minimum. You do not have to use the SQL
keyword WHERE or a SQL terminator such as a semi-colon (;).

6 Click Finish to generate the named table.

◆ Listing all named tables

To display a list of all named tables currently available in the SWD, go to the table view tab
in the workspace window.

You can view the columns within a named table by clicking the plus sign (+) on the left
hand side of the table name. To hide individual columns, click on the icon next to the col-
umn name.
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◆ Saving named tables

Named tables are stored as a part of the workspace. When a workspace is opened, the Table
Views are empty. The data is retrieved when you use the Map>Regenerate command.

◆ Refreshing named tables

To pick up edits that have been made to the tables on which a named table is based, regen-
erate the named table with Map>Regenerate.

◆ Functions for named tables

The following functions are available within a named table window display:

Place your cursor in the target column then click one of the buttons.

◆ Linking table data to overlays

In Cadcorp SIS, you can link named tables to overlay items. The unique column in the
named table should be linked to the unique identifier column for the overlay items. You
should check with your database administrator to find out which columns in the two sets of
data should be used to create a link that maintains relational integrity of the data.
When a named table is linked to overlay items, the data from the named table is copied into
the overlay schema. The additional columns are treated as attributes of the overlay items
and can be viewed in the table view for the overlay. This means that they can be used in that
same way as normal attribute data, eg they can form the basis of tool tips, thematic maps or
for queries (searching for map items).

To link named tables to overlay graphics
1 Before starting this process, make sure that your named table is open (but not necessar-

ily displayed). You must have focus on the table window of the target overlay. 

obtains statistical information, such as base table
name, number of rows, and mean values, from col-
umns containing numerical data types

sorts the data in each column

re-fills or refreshes the table

adjusts the widths of the columns within the view
of the named table to fit either the width of the
entire window, or the width of the column heading 
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2 Display the attribute data for the overlay you want to link to as a table view, using the
Window>New Table Window command. Select the overlay containing the data from
the drop-down list. 

You can view the map window and table view at the same time by tiling them
horizontally (using the Window>Tile Horizontally command).

3 Choose the Table>Join command, which displays the Display the Join Table Data to
Overlay Graphics dialog.

If you have more than one named table open, select the desired named table from the
Table drop-down list. The left-hand column of the dialog displays all the columns that
are available in the named table. By default all the columns are checked. This means that
all the columns will be copied across to the overlay schema. Un-check columns that are
not required. You also have the option to either append the named table or replace the
existing attribute data in the overlay schema. 
The right-hand section of the dialog handles the creation of links. In the Join Column
section, select the named table column that will be used for the link. In the To Property
section, select the overlay attribute column that will be used for the join (the drop-down
list can be expanded).
The joining columns from the two datasets can be of any data type (integer, decimal. or
text); however, both columns must be of the same data type.

4 Click OK to complete the linking process.
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The columns from the named table will be added to the overlay schema and are
displayed in the overlay table view.

■ Connecting to databases

◆ Overview

Cadcorp SIS offers a number of formats for storing graphical data in Relational Database
Management Systems (RDBMS). This allows organisations to choose a format that best
suits their business requirements. Some formats are generic and can be stored in any
RDBMS whilst others are specific to particular RDBMS vendors, such as Oracle Spatial
and Locator. Cadcorp SIS also provides an advanced proprietary storage model that allows
topological datasets to be stored in databases which support ODBC.
When choosing a data storage format, you should evaluate your GIS business requirements
and make your choice in the light of the database technology that is available in your
organisation.
The next section contains a brief overview of the database connectivity methods used by
Cadcorp SIS. This is followed by a discussion of each of the geographical data storage for-
mats in detail.
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◆ Connectivity methods

Database access technology has been going through a process of refinement for many
years; the current accepted standards, all of which are supported by Cadcorp SIS, include:

The Cadcorp SIS installation loads the Microsoft data access technologies MDAC 2.5 and
DAO 3.51.
Before attempting to create a dataset using the Cadcorp SIS software, make sure that the
appropriate drivers for the database you wish to connect to have been installed. 
Cadcorp SIS makes a logical distinction between databases that can be connected to
directly and databases that require some form of connection mechanism to be set up, such
as an ODBC connection. 

◆ Cadcorp SIS Direct Connectivity

Direct Connectivity has been added to simplify the database connection process. Direct
connections are available for the following databases, if their drivers have been loaded on
the client machines:
• Oracle8i /9i
• Oracle9i Spatial and Locator Only
• Microsoft SQL Server 7/2000
• Microsoft Access 2002/2000/97
• Microsoft FoxPro
• Lotus 1-2-3
Direct connectivity provides rapid and efficient access to remote databases. It also removes
the requirement to set up a Data Source Name (DSN) which is normally a step required
when connecting via ODBC/ADO.

ODBC Open Database Connectivity is an internationally recognised standard that
allows applications to access databases. All ODBC-compliant database vendors
will have an ODBC driver for their database. ODBC drivers are available for all
commercial databases such as Informix, Ingres, DB2 and Sybase. Drivers are
also available for Excel spreadsheets and CSV (comma-separated values) files.

DAO Data Access Objects was developed by Microsoft to allow efficient access to
Microsoft databases such as Access and, more recently, to data files such Excel
spreadsheets.

ADO Active X Data Objects is designed for high-performance data access. ADO uses
the latest generation of database drivers called OLE DB drivers. They provide
high performance access to any data source including relational and non-rela-
tional databases. ADO has a relatively smaller footprint and generates minimum
network traffic, thus making them more efficient than ODBC drivers. ADO driv-
ers are available for all commercial databases and must be loaded on the client.
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◆ Example 1: direct connection to Oracle9i

In this example, we make a direct connection to an Oracle9i database to create an editable
Blobs overlay.
1 Select Map>Add Overlay. The New Overlay dialog opens.

2 Select the Editable Blobs Dataset and click Next. The Select Database Type dialog is
displayed.
170 Cadcorp SIS V6 Getting Started



 Chapter 16 ● Using databaseswww.cadcorp.com
3 Select the target database type and click Next. The Oracle connection box opens. 

4 Fill in the appropriate connection information for your database and click Next. The
Oracle Net Service Name for the database should be entered for the server. If in doubt
contact your database administrator.

5 In this example, when a successful connection is made, the Editable Blobs dialog
opens. You can now create a new dataset or open an existing one.

6 Click Finish to display the editable Blobs overlay.

◆ Driver-enabled connectivity

To use driver-enabled connections, you must have the appropriate database drivers installed
on the client.
Some databases require additional client-side software to enable the data drivers to work.
For example, Oracle requires the Oracle Net to be loaded and configured. Check with your
database administrator for details.
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The following of types of overlays can be created using both direct and driver-enabled
connectivity: 
• Editable Blobs 
• OpenGIS SQL92
• View Points
These formats will be discussed in detail later.

◆ Example 2: creating an editable Blobs overlay using ODBC and Oracle9i

To create an editable Blobs overlay using an ODBC driver connecting to an Oracle9i data-
base, follow these steps.
1 Select Map>Add Overlay. The New Overlay dialog opens.
2 Select the Editable Blobs icon and click Next.
3 The Select Database Type dialog will be displayed:

Select ODBC Data Source and click Next.
4 The following standard Microsoft ODBC connection dialogs open.
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If a connection had been previously established within the same Cadcorp SIS session, it
will be listed here. In this example, we create a new connection.

5 Click the Connect... button to create a new Data Source Name (DSN). 
6 The Select Data Source dialog opens. Existing data source names which can be used for

this connection are listed. In this example, however, we will create a new DSN.

7 Click the New button. Select the appropriate database driver for your database and
click Next.

8 Enter a name for the DSN you are creating and click Next.
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9 Click Finish to complete the DSN creation process. The Oracle connection box opens:

10 Enter the correct information for establishing a connection to your database. Service
Name refers to the Oracle Net Service Name for the database. Check with your data-
base administrator if in doubt.

11 When you click OK, you will be returned to the screen displayed in step 6. The DSN
you just created will be listed.

12 Select your DSN and click OK. You will be presented with the Oracle connection box
again. Previously, it appeared so that the DSN could be created. It appears again
because an attempt to use it to connect to Oracle is being made.

13 Once the information has been entered and OK has been clicked you will be returned to
the screen in step 5 with the new connection string listed (this is based on the DSN you
just created) listed. Highlight the connection and click Next.
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14 Cadcorp SIS will now establish a connection to the Oracle database and display the
Editable Blobs overlay, from which you can either create a new dataset or open an
existing one.

15 Click Finish to display the new overlay.

◆ Example 3: creating an editable Blobs overlay using ADO and Oracle9i

To create an editable Blobs overlay in an Oracle9i database using ADO follow these steps:
1 Select Map>Add Overlay. The New Overlay dialog opens.
2 Select the Editable Blobs icon and click Next. The Select Database Type dialog opens.

3 Select the ActiveX Data Objects connection type and click Next.
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4 The Connect/Reconnect to ADO dialog opens. Existing ADO connections for the cur-
rent Cadcorp SIS session are displayed. In this example, we will create a new
connection. Click Connect… to proceed.

5 Select the driver appropriate for your database and click Next.
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6 Enter the connection information for your database.

Click OK to continue.
7 The Connect/Reconnect dialog is displayed again. It contains the connection string that

you just generated. Select the connection string and click Next.
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Cadcorp SIS establishes a connection with the database using the information provided.
Once the connection has been established, the Editable Blobs Overlay creation dialog
opens. You can either create a new editable Blobs dataset or open an existing one.

8 Click Finish.
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■ What are table windows? 
Table windows display properties, graphical attributes, and data from a database, in a tabu-
lar form. 

The table window and the map window are dynamically linked. If you select an item’s
attributes and properties in the table window, the item is automatically selected in the Map
Window. Similarly, selecting an item in the Map Window selects the  row in the table win-
dow. You can select more than one row by holding the Shift or Ctrl key down and clicking. 
179



Chapter 17 ● Table windows www.cadcorp.com
To select a column, click the heading cell, or a value in that column. The header changes to
bold to indicate the column is selected.

■ Viewing tables
To view these tables select the Window>New table window command. This command
creates a tabular view of the current SWD. The drop-down box at the top left corner of the
table window contains a list of overlays which you can select for displaying in the table
window.

■ Table window commands 
The Table menu contains commands specifically for use with a table window. These com-
mands can also be accessed via the Table/Data toolbar.

◆ Table>Join

This command creates a link between a graphical item and tabular data. ➲Chapter  17:
“Table windows”, Joining table rows and graphical items, page182

◆ Table>Fit To Header 

This command sets each column to be the same width as the heading of the column.
  

◆ Table>Fit To Window 

This command compresses or extends the column widths so that every column is visible
within the current window. If there are too many columns then the column names may be
difficult to identify. 

◆ Table>Refill

This command refills a table window from the overlay of the table being viewed. This com-
mand is also useful after sorting (to go back to the default sorting).

◆ Table>Sort>Ascending 

This command sorts the rows of the table based on the contents of the selected column. The
order is ascending alphanumeric: “1” before “9” before “A” before “Z”.

◆ Table>Sort>Descending 

This command sorts the rows of the table based on the contents of the selected column. The
order is descending alphanumeric: “Z” before “A” before “9” before “1”.

◆ Table>Sort>Advanced

This command displays the Sort dialog, which allows you to sort the table based on two
columns rather than just one.
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◆ Table>Statistics

This command displays a dialog containing statistics of the selected column, including the
number of rows, the minimum and maximum values, and the range, mean, variance and
standard deviation of the values in the column. The command is unavailable if you haven’t
selected a cell containing numbers.

◆  Table>Fill Column

A new column from an editable table can be filled with values from an existing column on
the same table if the data type in both columns is the same (floating point, integer or string).
New columns can also be populated using a formula. To do this, press the Formula button
on the Fill Column dialog. This option provides a useful method of adding attributes to
multiple items. Additional columns can be added using the Schema.
For example, using the Schema an integer column could be created called “Totals” and this
could be populated using the contents of two columns added together using Table>Fill
Column… Formula.

◆ Table>Scroll Dominant 

This command scrolls the table window to ensure that the table window containing the
dominant or selected item in the current selection is visible. This icon is greyed out until
the dominant or highlighted selected item is no longer visible within the table window. 

■ Other useful tools

◆ Query

You can use the Query Wizard to find an entry in a column (and the item on an overlay).
➲Chapter 13: “Queries”

◆ Zoom to selection

The map window and corresponding table window are dynamically linked. Therefore by
displaying both windows simultaneously you can highlight a row or rows from the table
window, then use Map>Zoom Selection command to zoom the map window to the extent
of the selected item or items.
Similarly if you select an item in the map window, the corresponding row in the table win-
dow will become highlighted (you may need to use the Table>Scroll Dominant command
to see it). Additionally, if Flicker Selection is on (see the Options page of Tools>Prefer-
ences...), the selected item flickers on the screen until deselected. 

■ Viewing named tables 
To view a named table, either:
• Select the File>New command, then select the Named Table icon which displays the

Select Database Type dialog.
or
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• Go to the table view of the workspace window. From the local menu of the Tables
entry, choose the New Table… command.

The method of selecting a database is exactly the same as explained in ➲Chapter 16:
“Using databases”.
When completed the named table will be displayed.
The window looks exactly the same as a graphical table window except that there is no
drop-down box in the top left hand corner. To work with named tables, use the Table View
tab in the workspace window and add the Table/Data toolbar. 

As you add more named tables they appear in the list. If you highlight the table name
and display the local menu, you can view that table, and cut, copy, and view the
properties of the table. 
A click on individual column names toggles the column visible or invisible. 
If you save the project workspace it will automatically reconnect next time the
workspace is opened.

■ Joining table rows and graphical items 
The Table>Join command allows you to create links between graphical items and tabular
data. You do this by linking columns in different datasets which have identical values. If
your datasets do not already have identical values, you will have to create a column in one
dataset and add column values which will provide links to the other. If your datasets do
have identical values, you can simply link the tables.
To link datasets which do not have identical values:
1 Open the overlays/named tables which are to be linked. 
2 In the Overlays dialog select the overlay which is to contain the data.
3 Select the Schema tab from the Overlays dialog and press the Add button.
4 Type the name of a column which will be used as the link. Give it a property type (inte-

ger&, floating point# or string$). The data columns in each dataset that you use in the
linking process must have the same property type (integer&, floating point# or string$).
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5 Click the Table button to display the following dialog.

If you have more than one named table you can select the one you want from the
drop-down list.
On the left side of the dialog check the columns from the table you wish to appear joined
to the overlay data/named table. On the right side of the dialog box select the column
name which you are using as the link and in the to Property column select the More
button to choose the overlay attributes which you want to link to. Click OK.
Troubleshooting When using a database file from Excel, all the data is treated as though
it is floating point data, irrespective of any cell formatting carried out within the
application.

6 In the Overlays dialog the columns section should now contain the additional column
names from the named table. Click Apply. Click OK to return to the map window.

7 Now all the items have attribute descriptions from both tables but the column content is
blank.

8 To fill the columns individually highlight the item (or select it on the overlay) and man-
ually input a value that matches one from the linked table. Press Return. The columns
matching that item will become filled with the appropriate data.

To link datasets which do have identical values:
1 Open the overlays/named tables which are to be linked.
2 In the Overlays dialog select the overlay which is to contain the data.
3 Select the Schema tab from the Overlays dialog and press the Table button.
4 Select the two columns to be linked as in step 5 above. Click OK.
5 The two tables should now be linked.
Again, ensure that the two data types being linked are the same property type.
The Join Tables dialog can also be accessed by right button clicking on the filename in the
table view.
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■ About printers
Any printer that can generate graphical output, and has a suitable Windows driver, can pro-
duce a print.
Printer device drivers are supplied by the printer manufacturer, and are installed using
Windows.
Raster data, colour-filled vector boundaries, thickened lines and Windows TrueType fonts
are printed at the resolution of the printer being used. In particular, some printers do not
support true colour output, therefore raster data may not appear as expected.

◆ Monochrome or colour printing 

By default, Cadcorp SIS queries the printer driver to find out whether the printer can handle
colours or not. 
If the printer cannot handle colours, Cadcorp SIS forces all printed colours to monochrome. 
Sometimes the printer driver does not pick up the capabilities of the printer. In this case,
you can force Cadcorp SIS to generate colour or monochrome graphics when printing. You
can use the File>Print Preview command to see what effect this option will have.

■ The Print commands
In common with many Windows applications, Cadcorp SIS has the commands File>Print
Preview, File>Print... and File>Print Setup....

◆ File>Print Setup...

This is a standard Windows feature. Refer to the Windows documentation if you require
help.

◆ File>Print Preview

This is a standard Windows feature. It allows you to see what the print will look like on the
piece of paper, before you go ahead and print it. 
1 Select the File>Print Preview command.
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2 You will see the Cadcorp SIS Print size dialog (the same one as appears during the Print
command):

3 When you are happy with the options here, click on OK. You will then be shown a pre-
view of what the print will look like.

4 Either choose to print from here, or go back and choose different options. 

◆ File>Print...

Select the File>Print... command (shortcut Ctrl + P) to print the view in the current win-
dow to the selected printer, whether it is a map window, a table window or a 3D window.
This command prints exactly what appears on the screen.
An alternative to using the File>Print... command is to print onto a print template in order
to include associated information such as notes, a grid, a north point, etc. ➲Chapter 19:
“Printing: print templates”

1 If you want to force monochrome or colour printing, use the option Print colour capa-
bilities on the Options tab of Tools>Preferences....

2 If required, use the File>Print Preview command to see what the print will look like.
3 Select the File>Print... command. A Windows Print dialog is displayed, where you

have options to select a different printer (if installed), set the number of copies, set the
print quality, etc:
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4 Click OK when you have finished setting the print parameters. The Cadcorp SIS Print
size dialog is displayed:

The title bar shows the map scale of the current window. 
This dialog shows the Paper size (width and height) and the View size (width and
height). The Paper size is the size of the paper chosen in the Print Setup. The View size
is the size of either the SWD window or the print template.

5 If the Paper size (width and height) is not the same (approximately - it should not be
exactly the same) as the View size (width and height), it is likely that the paper chosen
is not the same size or orientation as the SWD or print template. (The Paper size should
be slightly larger than the View size.) If you want to change any of the above, or the
scale of the print, do one of the following.
• Fit the view to the paper. Clicking the Fit button will cause the view to be scaled up or

down so that the selected graphics fill the available paper size. Only choose this option
if scale is not important.

• Crop the view. If you click the Crop checkbox, the desired scale (map scale) is kept.
However, only that part of the view is printed which fits on the paper (the centre of the
view being centred on the paper).

• Press Cancel. This allows you to go back to Print Setup. There, you can choose a
different size or orientation of paper, or change the scale of the map.

• Choose a different scale for the print. Print scale can be worked out by dividing map
scale by the Stretch by factor. Input a Stretch by factor to give you the scale you want. 

For example, if the area you had chosen was too large to print at 1:1250:
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you could set a Stretch by factor of 0.625, to give a print scale of 1:2000 (the map scale
of 1:1250 divided by 0.625 is 2000). At 1:2000 the view fits on the paper:

6 When you have decided how to fit the map view on the paper, click on OK.
Troubleshooting If your Paper size does not match the View size (you see the error mes-
age “View is bigger than available paper”), check that the orientation of the paper and the
orientation of the print template used match.
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Printing: print templates
■ About print templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 189
■ The Print Template Quick Wizard . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 189
■ The Print Template Wizard. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 192
■ Printing or saving a template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 206

■ About print templates
Print templates allow you to customise your prints, adding annotation such as titles, scale,
date, grids, notes (eg the Ordnance Survey copyright notice), north points, etc. 
The view to be printed (which can be in a map window or a 3D window) is placed onto a
pre-formatted sheet, called a print template. This can contain standard features such as
scale bars, titles, your company details, company logo, etc, and can be further customised
for each particular print (eg to include a legend or a north point).
Two wizards will help you with the process of creating and using print templates:
• the Print Template Quick Wizard
• the Print Template Wizard (not available in Cadcorp SIS Map Viewer)

■ The Print Template Quick Wizard
The Quick Wizard allows you to select a print template, choose its angle and scale, and
place it on the area to be printed. If you want further options, such as placing a graticule,
scale bar, north point, etc, use the Print Template Wizard instead.
Make sure the current window contains the view that you want to print.
1 Select the File>Print Template>Quick Wizard... command.
2 On the Select Print Template page, select the required print template from the tree

structure in the left-hand box. You will see an image of the chosen template in the
right-hand box, with its dimensions shown. 
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The inner rectangle on the print template is the area where your map will be placed (it is
called the photo).

3 Change the scale if required.
4 Change the angle of rotation if required. You may want to do this, for example, to align

a major road or building horizontally on the paper. You have two options:

Fixed Type in the angle required. North is 0˚, East is 90˚ etc. The print template is
rotated anti-clockwise. For example, if you type an angle of 90˚, East will be
pointing up. Note that when you come to place the print template on the map
base, it will appear to be rotated in the opposite direction. This is because the
map graphics are to appear rotated once the print template is aligned back
with the sheet of paper.

Snaps When you later place the template, this option will require you to give an extra
snap to indicate interactively the angle of rotation.
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View of map in the current window, showing the print template rectangle at 1:1250,
rotated 72˚:

The resulting print template:

5 Click the Next button.
If you see the Place Print Template page, proceed to step 6. 
If you see the Print Size dialog, the print template you have chosen does not fit onto the
current printer paper at the scale you have chosen. You can:
• go back a step to choose a different scale or another print template
• choose Print Setup to access the Print Setup dialog to change the paper used
• click on Fit to fit the template to the paper
• press Next to continue.

➲Chapter 18: “Printing: the Print commands”, File>Print..., page186
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6 On the Place Print Template page you will see the same area of the map base as in your
current view, and you should see a rectangle attached to the cursor. This rectangle
shows you the area of the map which will be displayed in the resulting print template. If
you typed in an angle of rotation, the rectangle will be rotated. This rectangle may be
outside the extents of the wizard view.
If you cannot see the rectangle, it is either bigger than the view or very small. Zoom out
or in until you can see it using the “+” or “*” keys, and the Up, Down, Left or Right
arrows, or return to the first page to choose a different scale or print size.

7 Click to place the centre of the template at the centre of the area to be printed. Alterna-
tively you can type the co-ordinates of a position. If you chose to rotate the print
template using snaps, you are required to give a second position to indicate the angle of
rotation.

8 If you want to change anything, go back through the Quick Wizard. If you want to
change the scale at any point during this process, type the new scale into the scale box,
and press Enter. If you are finished, press Finish, and a new SWD is created containing
the completed print template.
The photo is filled with the selected area of the map base. This view is dynamic, always
reflecting the current appearance of the overlays it contains. 

9 You can now save the print template as an SWD (File>Save As... command), or print it
using the File>Print... command. The File>Print... command prints only what is in the
map window, so before you print press Map>Zoom>Extent. This zooms the print tem-
plate SWD to its extents and ensures the whole of the map is printed.
In future, when you recall this file, the map view in the template (the photo) reflects the
current appearance of the original data (except in the case of an internal dataset).

■ The Print Template Wizard
Using the Print Template Wizard you can choose a print template for your print and then
add to it any of the following, customising each for the current print:
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• title bar
• key map
• theme legend(s) (if using themed overlays)
• scale bar(s)
• north point(s)
• orthogonal grid
• Lat/Lon graticule
• custom grid
Make sure the current window contains the view that you want to print.
1 Select the File>Print Template>Wizard... command.
2 Follow steps 2 - 7 of the Print Template>Quick Wizard... method. ➲page 189, The

Print Template Quick Wizard
3 On the Place Print Template page, click on the Next button.
4 On the Print Wizard Options page, select the options you want on the print:

Some of the options may be unavailable: it depends on the print template being used, the
SWD in the photo and the current library setup.

5 The Print Wizard will then step through the available options with each press of the
Next button. See the relevant following section for full details on each of these options.
On each page you have the opportunity of changing the photo scale. You can also
specify positions when placing the print template or creating other graphics.

6 At the end of specifying the options, you will see the Print dialog. See the later section
Printing or Saving a Template for details.
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The options are available only under the conditions shown:

❏ Availability of Print Wizard options
Option Available if 
Add Key Map One or more named items exist in the enabled libraries with a

name which starts “*km.”. There is a folder containing such
items in the (standard) library.

Add Theme Legend(s) The photo SWD includes overlays containing themes which
have a legend.

Add Scale Bar(s) One or more shapes exist in the enabled libraries with a name
which starts “*sb.”. There is a folder containing such shapes
in the (standard) library.

Add North Point(s) One or more shapes exist in the enabled libraries with a name
which starts “*np.”. There is a folder containing such shapes
in the (standard) library.

Add Orthogonal Grid The print template contains a photo item.

Add Lat/Lon Graticules(s) The print template contains a photo item.
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◆ Edit title bar text

The title bar text can contain your own information for the print. Examples are the name of
the department concerned or the project title, etc. Select the Prompt (eg Department), then
either press F2 or click below the Text title. Type the text values in the boxes. Press Enter
once finished.

◆ Add key map

A key map gives a visual indication of the spatial location of the area being printed. It dis-
plays a polygon representing the area of map printed, superimposed on a larger area (the
backdrop). 
Cadcorp SIS provides two backdrops for the UK: one based on 100 kilometre squares, the
other on 50 kilometre squares. These are stored as named items in the (standard) library. If
the scale of the backdrop is too large in comparison to the map being printed (eg a back-
drop with scale 1:10 000 000 and a print map with scale 1:3000), the backdrop will appear
as a blank rectangle in the print template.
1 Select the key map required in the top left-hand box. An image if it will be displayed in

the lower box.
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2 To place the key map, click two corners within the print template which define the
opposite corners of the key map.

◆ Creating your own key map

1 Open a Saved Window Directory containing the data for the key map (this can be vec-
tor or raster).

2 Select all the items to be used as the key map and choose the Edit>Store Item…
command.

3 In the Store Item dialog, name the file, and give the folder the name *KM. This means
that the file can be viewed only in the print template.

✐ If you have selected Toggle ‘*’ Objects (this local command is on the default 
menu of the workspace window, libraries view, libraries item), you do not see the 
*KM folder.
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◆ Creating your own backdrops for key maps

You can create your own backdrops for key maps, by storing an item or items (for example,
a larger map depicting a County) as a named item in a library. First, select the item(s), then
use Edit>Store Item. To be used as a key map backdrop, the named item must be inside a
folder called *KM. 

◆ Add theme legend(s)

This option is available only where you are using themed overlays. It allows you to place
theme legends on the template.
1 Select the theme required from the tree structure. As you do so, you will see its legend

displayed in the lower box.
2 Click on the template where you want to place the legend.
3 If the legend is the wrong size for the template, it can be edited using local commands

once the template has been created.
If you wish to add a theme legend to a previously created template you can do so using the
photo’s local command Legend.
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◆ Add scale bar(s)

1 Select the scale bar required from the tree structure. As you do so you will see it dis-
played in the lower box, together with its length in real world units relative to the
photo.

2 Click the position on the template where you want to place the scale bar.
3 If you make a mistake in placing the scale bar, click on Back to go back a stage, then

Next to return to this option, or you can edit it using local commands on the template
photo.
If you wish to add a scale bar to a previously created template, you can do so using the
photo local command Create Scale Bar.
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◆ Add north point(s)

1 Select the North point required from the tree structure. As you do so you will see it dis-
played in the lower box, together with its dimensions.

2 Click the position on the template where you want to place it.
3 If you make a mistake in placing the North point, click on Back to go back a stage, then

Next to return to this option.
If you wish to add a north point to a previously created template, you can do so using the
photo local command Create North Point.

◆ Add photo grid

This option allows you to show eastings and northings by means of grid lines and/or
annotation.
1 Select the photo to have a grid (a template can contain more than one photo).
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2 Click on the Add button, and in the Properties of Photo dialog give the parameters for
the grid:

This is the standard Properties dialog for photos, and allows you to change other
parameters as well as those of the grid. You can choose:
• which overlays will be shown in the photo
• the scale of the photo contents (Drawing scale), and optionally, a generalisation scale

(Threshold). The Threshold scale means that only those items which would be visible
at that scale on the map SWD will be visible in the print template photo item,
irrespective of the Drawing scale of the print template.

• to create a default grid using the current settings
• to clear the grid from the photo
When deciding how the grid lines should appear, you can choose:
• the pen to be used for both major and minor grid lines, and their spacing
• whether the grid lines are shown, or just the annotation (Show Lines)
• whether annotations are displayed along the edges (Edge Annotation), and whether the

special annotation given at the corners is shown (Corner Annotation)
• the appearance of the annotation text (Text Height and Font)
• whether annotations are shown in full, or abbreviated so that only the changing portion

of edge annotation is shown (Abbreviate annotation) 
• whether text, which would normally appear upside down when viewed from the

bottom of the photo, should be flipped (Flip inverted text)
Most of the options you specify here become properties of the photo and can be changed
later in the photo’s Properties dialog.

3 Click on OK, and you will see the grid applied to the print template.
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If the photo contents have been rotated, the gridlines will be correspondingly rotated.
Rotation angles between 0˚ and 45˚ will display eastings along the bottom and top of the
photo. Angles between 45˚ and 90˚ will display eastings along the left and right sides.
Grid lines will always be drawn on top of the photo contents.

◆ Add graticule(s)

This option enables you to display a graticule and define how it will appear. Each graticule
can consist of up to 8 levels, each level being a sub-division of the previous level. For
instance, level 0 (the first level), defines the appearance of the lines of latitude and longi-
tude, and that of their labels. Level 1 defines the spacing of the dicing, and how it is
labelled, and so on.
Graticule styles are named objects, stored in libraries.
1 On the Graticule page, select the photo which will contain graticules (a template can

contain more than one photo). If you have already created any graticules and saved
them as named objects, the Edit and Remove buttons are enabled. Otherwise, click on
Add.

2 On the Graticule Style page define each level in turn (defaults are set automatically). 

See the following section Graticule parameters for more detail.
3 When you have finished defining these parameters, click on OK.
4 Back on the Graticule page you now see the template with the graticule. Click on Next

if you are happy with it, or Back to go back and re-define it.
If you want to add a graticule to a previously created template, you can do so using the
photo local command Create Graticule.
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◆ Saving a graticule as a named object

Once you have created a graticule on a print template, you can save it for future use, using
its item command Store style.... You can select a graticule using the S snap.
Graticules are named objects, and are stored in the current library.

◆ Graticule parameters

Dicing
Here you choose whether or not to display dicing. This parameter can only be set in level 1.

Step 
These are the intervals at which the graticule lines will be drawn, in the current angular
units.

Span
The span determines how the graticule lines are drawn at this level. There are four options:
• None - no lines appear across the photo, but labels or ticks can still be drawn if required

(see the Label and Tick length options below)
• Grid - grid lines are ruled right across the photo
• Crosshair Grid - a crosshair is drawn at the intersection of lines
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• Crosshair Grid with Text - the position (in latitude and longitude) of each crosshair is
shown (the level text style and label format are used):

Margin
Use this option to determine whether or not a margin is drawn at this level.
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Tick length
This is the distance that the ticks which appear on the graticule border (at the step intervals)
extend beyond the graticule border.

Ticks are always drawn perpendicular to the graticule border (whereas span lines are drawn
along lines of equal latitude or longitude).
By selecting the Double-sided checkbox, the tick lines are drawn on both sides of the grat-
icule border. 
204 Cadcorp SIS V6 Getting Started



 Chapter 19 ● Printing: print templateswww.cadcorp.com

M
ap

 e
xt

ra
ct

 ©
 C

ro
w

n 
co

py
rig

ht
Label
Using this checkbox you can decide whether or not to have the graticule ticks labelled:

Label format 
At each level you can choose whether to show degrees, minutes, seconds and the compass
point. The options are:

%d, %D, %m, %M, %s and %S can be modified to print fixed width and precision. For
example, %4.2s will print at least 4 characters, with 2 decimal places. 

Pen
The pen used for the graticule lines and the labels. Use the More button to edit the current
pen using the Edit Pen dialog.

Text height
This is the point height of the label text and/or the graticule span text.

◆ Adding a custom grid

A custom grid is a Cadcorp SIS plug-in which enables you to create a grid for the photo
item. You, or your Cadcorp SIS supplier, can write a plug-in and customise the grid for the
intended photo. 

%d or %D print the degrees (%D appends a degrees symbol) 

%m or %M print the minutes (%M appends a ') 

%s or %S print the seconds (%S appends a ") 

%c or %C print the direction (N, S, E, or W) 
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It is possible to: change the number of levels on which graphics are drawn; add your own
labels in your choice of units; and add your own graphics to the grid.

The custom grid is, however, static. If you change the view in the photo item, the custom
grid graphics will be out-of-date and will have to be deleted and then re-generated.
This option should be used only when customising Cadcorp SIS Map Modeller, Cadcorp SIS
Map Editor or Cadcorp SIS Map Manager.

■ Printing or saving a template
When you have specified the parameters for your template (title bar text, key map, theme
legend, scale bar, north point, photo grid, and graticule), you see the Print page of the
Wizard.
1 The cursor is shown as a magnifying glass. Click to see the Roamer, with which you

can check small detail on the print template. Clicking again restores the magnifying
glass cursor.

2 If required, you can change the scale of the photo, or give a different position for it to
centre on.

3 Select whether to print the template now or save it as an SWD file for editing or print-
ing later.

4 Click on Finish.
If you chose to save the template, a new window is created containing the template, which
you can edit and/or save as an SWD. This window can then be printed using the
File>Print... command.
206 Cadcorp SIS V6 Getting Started



Cadcorp SIS V6 Getting Started

Chapter

Map Viewer Map Manager Map Editor Map Modelle
✔ ✔ ✔ ✔
20
r

Feature tables
■ What is a feature table?. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207
■ Inspecting the feature tables  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207
■ Importing and exporting feature tables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 209

■ What is a feature table?
A feature table details code-numbers that have standardised features (properties, styles,
scale thresholds, and so on) associated with them. These tables can be applied to data that
also contains these code-numbers. When selected, an item will show in its properties which
feature table is being used, and which code from the table it has. In the UK, Ordnance Sur-
vey data is an example of the use of feature tables and codes. All features with the same
feature code use the same pen, brush, shape, etc. 
The data types that use feature tables and codes are: OS Boundary-Line, OS Land-Form,
OS Land-line, OS Meridian, OS MasterMap, OSCAR, OSNI (Large Scale and Miscellane-
ous) RST, OS Strategi, TIGER/Line, and DLG (Large and Small Scale).

■ Inspecting the feature tables
In Cadcorp SIS, feature tables are named objects, stored in libraries. You can inspect the
libraries in the workspace window to see what feature tables they contain.
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◆ Library view tab of the workspace window

The (standard) library contains all the feature tables supplied with Cadcorp SIS. These are
read-only (but you can also create your own editable feature tables).

You can examine the details of each feature code in a feature table by selecting a feature
table and selecting Properties from its local menu.
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In the previous example, taken from the Land-Line feature table, all items with feature
code 1 (Building Outlines) are on a layer called Buildings, and will displayed only between
the scales of 1:1 (No limit) and 1:6253. 

■ Importing and exporting feature tables
You can import a feature table as a text file (*.txt). Use the Import Feature Table option on
the local menu of each editable library.
There is also an Export Feature Table option on the feature table’s local menu, which
allows you to create a text file (*.txt) of any of your feature tables.
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Internet products
■ Cadcorp SIS Active Server Component (ASC) . . . . . . . . . . . . . . . . . . . . . . . 211
■ Cadcorp SIS Map Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 214

■ Cadcorp SIS Active Server Component (ASC)

◆ What is the Cadcorp SIS ASC?

The Cadcorp SIS Active Server Component (ASC) allows you to embed spatial data and GIS
functionality into standard internet browsers1. It is a 32-bit COM server-side application
which allows programmers to create tools that can be used in internet browsers to perform
GIS functions such as ‘zoom in’, ‘select a record’, ‘show the nearest’, etc, and other appli-
cations as complex as they wish.
The Cadcorp SIS ASC is addressed using methods which are described in the Cadcorp SIS
Programming Reference Guide.

◆ Cadcorp SIS ASC Requirements

To install, run and begin developing with the Cadcorp SIS ASC, you need:
• a Cadcorp SIS desktop product capable of generating an SWD with data in it, ie Cad-

corp SIS Map Modeller
• an Cadcorp SIS ASC licence code and hardware key. These are found in the Internet

Developer Kit, the Enterprise Developer Kit and the ASC.
• a server computer running Microsoft Personal Web Server (Windows 2000) or Micro-

soft Internet Information Server (Windows NT, XP, or 2000). The server must have the
hardware key attached to its parallel port and the user must have administrator privi-
leges, or the equivalent.

• a client computer which can access the server via a Local Area Network (LAN) or the
World Wide Web (WWW) using an internet browser1

• an HTML editor such as Microsoft FrontPage or Macromedia Dreamweaver. Although
you can use Wordpad or Notepad to write HTML, these packages are not recom-
mended for large sites where coding can become complex.

Detailed hardware specifications and guidance can be obtained from Cadcorp. 

1. We recommend the internet browsers Netscape v4.0 (or higher) or Microsoft Internet Explorer
version 4.0 (or higher). 
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◆ How Cadcorp SIS ASC works

The Cadcorp SIS ASC allows graphic and attribute data held in an SWD to be displayed in
an internet browser. It is adopts a ‘thin’ client approach, so that the bulk of processing is
performed on the server. The process of serving an SWD via the Cadcorp SIS ASC is shown
below.

To use the Cadcorp SIS ASC you write code within Active Server Pages, which call Cad-
corp SIS ASC methods. An Active Server Page (ASP) is an HTML page that includes one or
more scripts (small, embedded programs) that are processed on a Microsoft Web server
before the page is sent to the browser. An ASP is similar to a server-side include or a com-
mon gateway interface (CGI) application. These all involve programs that run on the server,
usually tailoring a page for the user. Typically, the script in the Web page on the server uses
input received as the result of the user’s request for the page to access data from a database.
It then builds or customizes the page on the fly before sending it to the user.
ASP is a feature of the Microsoft Internet Information Server (IIS), but, since the
server-side script is returning a regular HTML page, it can be delivered to almost any
browser. You can create an ASP file by including a script written in VBScript or JavaScript
in an HTML file, or by using ActiveX Data Objects (ADO) program statements in the
HTML file. You name the HTML file with the *.asp file extension. Microsoft recommends

1

3

4
2

A user connects to an 
appropriate ASC page - 
map.asp - on the server 
via their web browser.

The server interprets any 
commands such as 
Zoom In, Select, etc, 
which are posted from 
the map.asp page.

The ASC calculates what should be 
displayed as a result of step 2. It 
then renders a new map image, or 
calculates responses to formulae or 
queries from map.asp.

The rendered image is 
displayed in the client 
browser.

map.asp 

ASC server
- IIS/PWS
- SWD
- ASC
- hardware key
- Data

connect
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the use of the server-side ASP rather than a client-side script where there is actually a
choice, because the server-side script will result in an HTML page that displays easily. Cli-
ent-side scripts (for example, with JavaScript) may not work as intended on older browsers
(see www.Whatis.com).
By calling Cadcorp SIS methods from your code you can carry out a large range of func-
tions, from creating a simple map image, to allowing the user to pan, zoom and query
spatial data and related databases through a web browser. The Cadcorp SIS ASC interprets
these methods and renders an image (such as JPEG, PNG, or GIF) which is then sent to the
client browser. 

◆ Getting started with Cadcorp SIS ASC

An application built around the Cadcorp SIS ASC needs the five files listed below. Two are
generated by Cadcorp SIS Desktop software:
• an SWD - a collection of data, and information describing it eg line colour, thematic

mapping, and symbols
• SisConst.inc - a constant file generated from the Program Window
You can produce the other three files with an HTML editor (you could use a text editor, but
we do not recommend this):
• Global.asa – session variables and sub routines
• Map.asp – the page which the user interacts with the Cadcorp SIS ASC via a form (it

does not have to be called Map.asp)
• Render.asp – the page which Map.asp calls in order to send a new image to the client

browser
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■ Cadcorp SIS Map Server

◆ What is the Cadcorp SIS Map Server?

Cadcorp SIS offers the capability to serve SWDs on the web quickly and easily. You can
use Cadcorp SIS to create maps which can then be easily distributed around an organisation
and its customers.

The Cadcorp SIS Map Server has been developed around the Web Map Overlay Specifica-
tion, defined by the OpenGIS Consortium through its GIS industry-wide Web Mapping
Testbed (WMT) initiatives. WMT defines an open use of geospatial data on the Web. The
aim is to allow web users to access web servers and display geographical data, regardless of
the differences in GIS data formats or GIS software. The diagram above shows Cadcorp
SIS Map Server with an SWD displayed in a web page, and featuring Pan, Zoom and Layer
functions.

◆ Cadcorp SIS Map Server Requirements

To create and serve your maps, you need three components:
• to create a map and save it as a SWD, use Cadcorp SIS Map Modeller
• to enable you to serve a map on the web, Cadcorp SIS uses the Internet Server Applica-

tion Program Interface (ISAPI) to create the SisIsapi.dll. This is a dynamic link library
(DLL) that contains a set of Microsoft Windows program calls. It allows a user to
access a web server using any standard web browser, ask for map information, receive
that information, and see it displayed on their web page.
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• to present your served Map, we provide a simple template, which is generated by the
DLL

◆ How Cadcorp SIS Map Server Works

With the SisIsapi.dll you can set up a web server that can perform the following tasks ‘out
of the box’:
• display a map in any standard browser without need for plug-ins
• display in a browser a list of available SWDs stored on the server
• display a map window of a SWD with basic information about the content of the file,

such as the list of overlays within it and its scale. It can also provides basic zoom and
pan commands.

• provide information in XML (GML) format about the SWDs found, with additional
information such as their name, current extents, scale and projections

◆ Getting started with Cadcorp SIS Map Server

The Cadcorp SIS Programming Reference Guide contains the information you need
about setting up Cadcorp SIS Map Server, including detailed information for programmers
about the four API calls that are used:

GetMap provides clients of the Map Server with pictures of maps

SwdCatalog responds with an HTML page that lists the available SWDs in the
server

BasicPanZoom yields a simple HTML page with a map and basic viewing controls

GetCapabilities provides clients with a XML (GML) output that describes the cur-
rent capabilities, which specify the SWDs that can be served, what
formats they can be served in and related information
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